summaryrefslogtreecommitdiff
path: root/dev-python/meson-python
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2025-02-17 00:13:57 +0000
committerV3n3RiX <venerix@koprulu.sector>2025-02-17 00:13:57 +0000
commit27b3683509c5229cce540418778a8b64afbc0009 (patch)
treeb7164898142b8b093b91c8254c4387b6eec679ee /dev-python/meson-python
parentf2bdc27fe0f79f8f9a3945eb2b1163ce75c56439 (diff)
gentoo auto-resync : 17:02:2025 - 00:13:57
Diffstat (limited to 'dev-python/meson-python')
-rw-r--r--dev-python/meson-python/Manifest2
-rw-r--r--dev-python/meson-python/meson-python-0.17.1.ebuild11
2 files changed, 10 insertions, 3 deletions
diff --git a/dev-python/meson-python/Manifest b/dev-python/meson-python/Manifest
index 5817a840e8b4..21b620d1fbef 100644
--- a/dev-python/meson-python/Manifest
+++ b/dev-python/meson-python/Manifest
@@ -1,3 +1,3 @@
DIST meson-python-0.17.1.gh.tar.gz 79456 BLAKE2B 88bda9aadc74d186aab41c9b3a2fe5ba7d51b5997c1c043cf4ea9448395d0c5c5763ccf35358ab867d32a4537a4041a3cf480d82c9ec5cd8d1b5d6bc67d35fc8 SHA512 bd5f4c807468b81b3630eeb6973c2a574473c22298eb2c43d30b67b7503ce77fd79d4509a8f1b0186197622d281279a9c3aa5d9d1c2286d46b7aea1ff2461ae5
-EBUILD meson-python-0.17.1.ebuild 1401 BLAKE2B a09d931c2da76efac582b737dc33a4cf075a694b2b6f939c8d563f88fdb0c12cdf7924adeec69962c50fc8c960cc915dcefb9aad01c3b3331927fd2b9502d37c SHA512 6fc80d40816f7c1dc3bbd0643826c076d4ab7ffb6102b1e8dbdce112b37b847ca0b6109681bb116acfca5428d3332db22064d2552a7f06a0428ef532f97eede5
+EBUILD meson-python-0.17.1.ebuild 1572 BLAKE2B 69a15b446e4ee76bfddaa8fdfee9f3310ed09124e8d6df3aaaf07e2234472db56275f65b635a149adbdfce7cc8ba518b1698bce54372d1d8e138bd7cdd4f41a8 SHA512 377ba1c81882cdc8e48ba3804a9aacbbec676d179d6a9f4b2c24244e979513391d0bef365c751d324baec944c6fca40f011930da3ed5c324d2875f848f1a9acf
MISC metadata.xml 411 BLAKE2B 8a7344d7bab741106c4eaf5ccabbbdbe359e3c4f4b4a1a94390820392e0508244652b23a170739d43ccff2e82d1593274bfdaf94171cfcd5a6ec748b2ade482c SHA512 05b9171f27ee6707c893c4f3efbac5c16ca9899134b54e94ef3cad9cce620a03cbbadfbdc134f066abc139631c9b6637614ff5e135e0944dc61c5447ec70c129
diff --git a/dev-python/meson-python/meson-python-0.17.1.ebuild b/dev-python/meson-python/meson-python-0.17.1.ebuild
index ea5282b324b5..fbffdb699840 100644
--- a/dev-python/meson-python/meson-python-0.17.1.ebuild
+++ b/dev-python/meson-python/meson-python-0.17.1.ebuild
@@ -1,10 +1,10 @@
-# Copyright 2022-2024 Gentoo Authors
+# Copyright 2022-2025 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
DISTUTILS_USE_PEP517=standalone
-PYTHON_COMPAT=( python3_{10..13} pypy3 )
+PYTHON_COMPAT=( python3_{10..13} pypy3 pypy3_11 )
inherit distutils-r1
@@ -56,6 +56,13 @@ src_test() {
python_test() {
unset NINJA
+ local EPYTEST_DESELECT=()
+ if ! has_version "dev-build/meson[${PYTHON_USEDEP}]"; then
+ EPYTEST_DESELECT+=(
+ tests/test_wheel.py::test_vendored_meson
+ )
+ fi
+
local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
epytest -p pytest_mock
}