summaryrefslogtreecommitdiff
path: root/dev-python/mkautodoc
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-04-25 11:37:10 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-04-25 11:37:10 +0100
commit38423c67c8a23f6a1bc42038193182e2da3116eb (patch)
tree04e2cf4bd43601b77daa79fe654e409187093c5e /dev-python/mkautodoc
parent623ee73d661e5ed8475cb264511f683407d87365 (diff)
gentoo resync : 25.04.2020
Diffstat (limited to 'dev-python/mkautodoc')
-rw-r--r--dev-python/mkautodoc/Manifest3
-rw-r--r--dev-python/mkautodoc/metadata.xml17
-rw-r--r--dev-python/mkautodoc/mkautodoc-0.1.0.ebuild28
3 files changed, 48 insertions, 0 deletions
diff --git a/dev-python/mkautodoc/Manifest b/dev-python/mkautodoc/Manifest
new file mode 100644
index 000000000000..c4292fb232fa
--- /dev/null
+++ b/dev-python/mkautodoc/Manifest
@@ -0,0 +1,3 @@
+DIST mkautodoc-0.1.0.tar.gz 5654 BLAKE2B c0ae754e800ea25e9cccc621b4fd5c8d1561c57808b301ac5a3036ca18fda1adc432006e13b777a83dcc2cd6960a34745e17dfbcbbda24098902198d4fc9d743 SHA512 7ccb0a03016e2984d88d78eca2a8ee01e2153ff574c912358640c158b2084e3c365ace0fdb89cb74bb1950c68775d9d3cb11201cbf3c6d136dc7886a3294dc89
+EBUILD mkautodoc-0.1.0.ebuild 642 BLAKE2B 4b6fd99fcd77cbbd000acefc2a4f450302ae0299d298ea961f31a5bd682c46bf982f5594499a5f98765c732e3828c5be1903a1dd18ca8f77e4cd01fadaefe4e3 SHA512 4ef8684305f9dd36b0e78f13e841128f90b1ee59eaee7c1a83fc133ba9ce4d09aeb928d7d98dc18483d5aa9c8cdc805e88f04a35e152d97171a8074fafb2c153
+MISC metadata.xml 509 BLAKE2B 8f1b4827849c3bac4db1ceaf5e9930dbee77a07f0cc1ec359189747eb76c665f1b8160087535e88ab44b0762baee6f1f4e57f631710a83b3c4860e582389ac0f SHA512 dddc21e8b45636a67ad28a5e5485d60499e50234c4ea32ea8c0cf618024d4474f7761ed00f7699c30de2b46b0aebfb53a32a0f4ed2c5cba3d264146d172cf871
diff --git a/dev-python/mkautodoc/metadata.xml b/dev-python/mkautodoc/metadata.xml
new file mode 100644
index 000000000000..0858ff1d0d1b
--- /dev/null
+++ b/dev-python/mkautodoc/metadata.xml
@@ -0,0 +1,17 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+
+<pkgmetadata>
+ <maintainer type="person">
+ <email>andrewammerlaan@riseup.net</email>
+ <name>Andrew Ammerlaan</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">tomchristie/mkautodoc</remote-id>
+ <remote-id type="pypi">mkautodoc</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/mkautodoc/mkautodoc-0.1.0.ebuild b/dev-python/mkautodoc/mkautodoc-0.1.0.ebuild
new file mode 100644
index 000000000000..bfc7f38cd6b5
--- /dev/null
+++ b/dev-python/mkautodoc/mkautodoc-0.1.0.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8} )
+
+inherit distutils-r1
+
+DESCRIPTION="Auto documentation for MkDocs"
+HOMEPAGE="
+ https://github.com/tomchristie/mkautodoc
+ https://pypi.org/project/mkautodoc
+"
+SRC_URI="https://github.com/tomchristie/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="dev-python/markdown[${PYTHON_USEDEP}]"
+
+distutils_enable_tests pytest
+
+python_test() {
+ PYTHONPATH="${WORKDIR}/${P}/tests/mocklib:${WORKDIR}/${P}"
+ pytest -vv || die "tests fail with ${EPYTHON}"
+}