summaryrefslogtreecommitdiff
path: root/dev-python/mkdocs-git-authors-plugin
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2021-12-25 20:34:27 +0000
committerV3n3RiX <venerix@koprulu.sector>2021-12-25 20:34:27 +0000
commit0f15659d48c193027158492acb726297501202c5 (patch)
tree5502ba879a78b759da28441d418dbbfe08bd8f03 /dev-python/mkdocs-git-authors-plugin
parent93a93e9a3b53c1a73142a305ea1f8136846942ee (diff)
gentoo xmass resync : 25.12.2021
Diffstat (limited to 'dev-python/mkdocs-git-authors-plugin')
-rw-r--r--dev-python/mkdocs-git-authors-plugin/Manifest2
-rw-r--r--dev-python/mkdocs-git-authors-plugin/mkdocs-git-authors-plugin-0.6.3.ebuild51
2 files changed, 53 insertions, 0 deletions
diff --git a/dev-python/mkdocs-git-authors-plugin/Manifest b/dev-python/mkdocs-git-authors-plugin/Manifest
index 345dd2af622f..2d4ff954783f 100644
--- a/dev-python/mkdocs-git-authors-plugin/Manifest
+++ b/dev-python/mkdocs-git-authors-plugin/Manifest
@@ -1,3 +1,5 @@
DIST mkdocs-git-authors-plugin-0.6.2.tar.gz 27623 BLAKE2B 7b0dd3b865b067b63e467fa75018a92cea8cfeabdeb66791664ea143ebecbb072110698f1366f917f390dd29c33794c7d2cc03e03bb84f8913b572d667e77b9d SHA512 75e4a4e6f3ca443257b5f61f5f0d9784cb4bb28a5a03412cde5c226da697117a29c2f4a3d1cac2aa362421f244fd56ea8580a923414a8e096bedc4502afcb5b0
+DIST mkdocs-git-authors-plugin-0.6.3.tar.gz 27644 BLAKE2B a8778baeb504db5d0571aa20603e8d60e04d8c315c096b5b3f89bb6a3b433a11b04a510d7f80ae86a9bb54259c6a2b0f2e1cb5cdade4220d4dfa1f06612e4aea SHA512 ab1f6984da002b72af2a53131222a3ff7b6b50a7a57f5d1986bca9e7d34365eaa5bfdf7d920e4dbc555e332587607480eef4134d847faf866a3b4750db3747eb
EBUILD mkdocs-git-authors-plugin-0.6.2.ebuild 1235 BLAKE2B 5c8422d30f2b4e0d2a89ea8cef665b718ffc69fff1c40547efab146b9869a6c933df00b9791f3c7e8e2c03e39e85593ff73cca13a047c3a92fba7450851503b8 SHA512 3c19312212180a4074d5ff8a20ac80525caaad6300f903db1ae02f79d8ec9f24fc60ce0c2d91fbdd9c1c608a52e98090ee8bbe67756602d046c585d19d72eb76
+EBUILD mkdocs-git-authors-plugin-0.6.3.ebuild 1235 BLAKE2B 5c8422d30f2b4e0d2a89ea8cef665b718ffc69fff1c40547efab146b9869a6c933df00b9791f3c7e8e2c03e39e85593ff73cca13a047c3a92fba7450851503b8 SHA512 3c19312212180a4074d5ff8a20ac80525caaad6300f903db1ae02f79d8ec9f24fc60ce0c2d91fbdd9c1c608a52e98090ee8bbe67756602d046c585d19d72eb76
MISC metadata.xml 564 BLAKE2B cee03d6742cb66a51c92f8999483f6c04c2b3fc7e8b88f5882bbabc577a54e922bdccf8a1a467e601c43511a372ac90ff8aa4500bd95715cffa83214ee2e64e9 SHA512 2b5539fff2990ebd293715b659e7b9bdeb63117c35933f49a21b873b45188476d3d44f6ac5b1656ee598f028e80f648b91b36ef4dae3f900705dbe2a7355356e
diff --git a/dev-python/mkdocs-git-authors-plugin/mkdocs-git-authors-plugin-0.6.3.ebuild b/dev-python/mkdocs-git-authors-plugin/mkdocs-git-authors-plugin-0.6.3.ebuild
new file mode 100644
index 000000000000..5e3f4cc0b40d
--- /dev/null
+++ b/dev-python/mkdocs-git-authors-plugin/mkdocs-git-authors-plugin-0.6.3.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+
+DOCS_BUILDER="mkdocs"
+DOCS_DEPEND="dev-python/mkdocs-material"
+
+inherit distutils-r1 docs
+
+DESCRIPTION="Mkdocs plugin to display git authors of a page"
+HOMEPAGE="
+ https://github.com/timvink/mkdocs-git-authors-plugin/
+ https://pypi.org/project/mkdocs-git-authors-plugin/
+"
+SRC_URI="https://github.com/timvink/${PN}/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~riscv ~x86"
+
+RDEPEND="
+ dev-python/GitPython[${PYTHON_USEDEP}]
+ >=dev-python/mkdocs-1.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/click[${PYTHON_USEDEP}]
+ dev-python/mkdocs-material[${PYTHON_USEDEP}]
+ dev-python/mkdocs-git-revision-date-localized-plugin[${PYTHON_USEDEP}]
+ dev-vcs/git
+ )
+ doc? ( dev-vcs/git )
+"
+
+distutils_enable_tests --install pytest
+
+python_prepare_all() {
+ # mkdocs-git-authors tests need git repo
+ if use test || use doc; then
+ git init -q || die
+ git config --global user.email "you@example.com" || die
+ git config --global user.name "Your Name" || die
+ git add . || die
+ git commit -qm 'init' || die
+ fi
+
+ distutils-r1_python_prepare_all
+}