summaryrefslogtreecommitdiff
path: root/dev-python/mkdocs-git-authors-plugin
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-11-16 18:55:17 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-11-16 18:55:17 +0000
commit1e3939094253168dfdada63e645d674cad69260e (patch)
treeac694a92b15d94d2e7544b8591123b7b04cf11e9 /dev-python/mkdocs-git-authors-plugin
parentc98eb096c37a4252dc388920f0b0f8b2441c9b5d (diff)
gentoo auto-resync : 16:11:2022 - 18:55:17
Diffstat (limited to 'dev-python/mkdocs-git-authors-plugin')
-rw-r--r--dev-python/mkdocs-git-authors-plugin/Manifest2
-rw-r--r--dev-python/mkdocs-git-authors-plugin/mkdocs-git-authors-plugin-0.7.0.ebuild54
2 files changed, 56 insertions, 0 deletions
diff --git a/dev-python/mkdocs-git-authors-plugin/Manifest b/dev-python/mkdocs-git-authors-plugin/Manifest
index 033c52dc50c1..37d432ee2c8b 100644
--- a/dev-python/mkdocs-git-authors-plugin/Manifest
+++ b/dev-python/mkdocs-git-authors-plugin/Manifest
@@ -1,3 +1,5 @@
DIST mkdocs-git-authors-plugin-0.6.4.tar.gz 27799 BLAKE2B 02456df969fac72fc29906ed6faa34ead8d04dcd005fdc39bf72393e5252934c398995cb07133107af99672328d03b96e9a19625a7a83ee438278cf4f8587f50 SHA512 948b59bed123acc4b02a01248b831ac27fd98a24653fbae315424a1da33573d109667ff8b836be454e7c9b56a6f68f45200effe8649fd4fe6d5551d1b93a6cd5
+DIST mkdocs-git-authors-plugin-0.7.0.gh.tar.gz 28526 BLAKE2B 876b273b476d10f037053ac8c4892f9225b514bfedecd26a7a9dcfd067609c5458fa4c2ed741048092c88dfcda196eab035e4909d3a8184579971273401cbf7c SHA512 aa92a5b49c4f02ea1c4eb5242fc585a341f837e7ebb27a450d703a170fb5e2e9ea5b04e2c6f121747300d86ac5fc0e69a553e1d7b02786e8fd6cd4943cbec6c2
EBUILD mkdocs-git-authors-plugin-0.6.4.ebuild 1257 BLAKE2B d17e49782c0433fbf0c954025d952e853e04408ffe020a7736668900d992beda923f7e022f64ba5cd68a30ec7f8dda365b8de93db03f51c589b6d422cbe11b2a SHA512 5159e91f51cfbc45cab872351a0e039183464cb8809113cb9144048264929ae468c9c602a2a7ef4b6fce8c02dc00bf78db129dc99e003efb41d55b06690e10b5
+EBUILD mkdocs-git-authors-plugin-0.7.0.ebuild 1262 BLAKE2B ec1f07ea60ba16c4eeb3d6d4b19c65ca767190d17809be6b9e65eee1fceb13da0137877ad0f5a8e63bce87586418d7268367e816f50321e0440779657232d95b SHA512 27113ff5252e8c00463002318d6253a3a56d9900683da747082e8a6f81bfe68f5d6db56b282c71f609b74d6aa4887b60718e0de857855cc6e503a9ab07c9bf2a
MISC metadata.xml 564 BLAKE2B cee03d6742cb66a51c92f8999483f6c04c2b3fc7e8b88f5882bbabc577a54e922bdccf8a1a467e601c43511a372ac90ff8aa4500bd95715cffa83214ee2e64e9 SHA512 2b5539fff2990ebd293715b659e7b9bdeb63117c35933f49a21b873b45188476d3d44f6ac5b1656ee598f028e80f648b91b36ef4dae3f900705dbe2a7355356e
diff --git a/dev-python/mkdocs-git-authors-plugin/mkdocs-git-authors-plugin-0.7.0.ebuild b/dev-python/mkdocs-git-authors-plugin/mkdocs-git-authors-plugin-0.7.0.ebuild
new file mode 100644
index 000000000000..753af67ceed1
--- /dev/null
+++ b/dev-python/mkdocs-git-authors-plugin/mkdocs-git-authors-plugin-0.7.0.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517="setuptools"
+PYTHON_COMPAT=( python3_{8..11} )
+
+# Requires self to be installed to build docs
+# TODO: Do this a bit better
+DOCS_BUILDER="mkdocs"
+DOCS_DEPEND="
+ dev-python/mkdocs-material
+ dev-python/mkdocs-git-authors-plugin
+"
+DOCS_INITIALIZE_GIT=1
+
+inherit distutils-r1 docs
+
+DESCRIPTION="Mkdocs plugin to display git authors of a page"
+HOMEPAGE="
+ https://github.com/timvink/mkdocs-git-authors-plugin/
+ https://pypi.org/project/mkdocs-git-authors-plugin/
+"
+SRC_URI="https://github.com/timvink/${PN}/archive/refs/tags/v${PV}.tar.gz -> ${P}.gh.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~riscv ~x86"
+
+# Tests are broken outside of upstream git repo
+RESTRICT="test"
+
+RDEPEND="
+ dev-python/GitPython[${PYTHON_USEDEP}]
+ >=dev-python/mkdocs-1.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/click[${PYTHON_USEDEP}]
+ dev-python/mkdocs-material[${PYTHON_USEDEP}]
+ dev-python/mkdocs-git-revision-date-localized-plugin[${PYTHON_USEDEP}]
+ dev-vcs/git
+ )
+"
+
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ # mkdocs-git-authors tests need git repo
+ use test && initialize_git_repo
+
+ distutils-r1_python_prepare_all
+}