summaryrefslogtreecommitdiff
path: root/dev-python/mkdocs-git-authors-plugin
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-03-20 00:40:44 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-03-20 00:40:44 +0000
commit4cbcc855382a06088e2f016f62cafdbcb7e40665 (patch)
tree356496503d52354aa6d9f2d36126302fed5f3a73 /dev-python/mkdocs-git-authors-plugin
parentfcc5224904648a8e6eb528d7603154160a20022f (diff)
gentoo resync : 20.03.2022
Diffstat (limited to 'dev-python/mkdocs-git-authors-plugin')
-rw-r--r--dev-python/mkdocs-git-authors-plugin/Manifest2
-rw-r--r--dev-python/mkdocs-git-authors-plugin/mkdocs-git-authors-plugin-0.6.4.ebuild52
2 files changed, 54 insertions, 0 deletions
diff --git a/dev-python/mkdocs-git-authors-plugin/Manifest b/dev-python/mkdocs-git-authors-plugin/Manifest
index 50f8368e67e2..17616a1223f3 100644
--- a/dev-python/mkdocs-git-authors-plugin/Manifest
+++ b/dev-python/mkdocs-git-authors-plugin/Manifest
@@ -1,5 +1,7 @@
DIST mkdocs-git-authors-plugin-0.6.2.tar.gz 27623 BLAKE2B 7b0dd3b865b067b63e467fa75018a92cea8cfeabdeb66791664ea143ebecbb072110698f1366f917f390dd29c33794c7d2cc03e03bb84f8913b572d667e77b9d SHA512 75e4a4e6f3ca443257b5f61f5f0d9784cb4bb28a5a03412cde5c226da697117a29c2f4a3d1cac2aa362421f244fd56ea8580a923414a8e096bedc4502afcb5b0
DIST mkdocs-git-authors-plugin-0.6.3.tar.gz 27644 BLAKE2B a8778baeb504db5d0571aa20603e8d60e04d8c315c096b5b3f89bb6a3b433a11b04a510d7f80ae86a9bb54259c6a2b0f2e1cb5cdade4220d4dfa1f06612e4aea SHA512 ab1f6984da002b72af2a53131222a3ff7b6b50a7a57f5d1986bca9e7d34365eaa5bfdf7d920e4dbc555e332587607480eef4134d847faf866a3b4750db3747eb
+DIST mkdocs-git-authors-plugin-0.6.4.tar.gz 27799 BLAKE2B 02456df969fac72fc29906ed6faa34ead8d04dcd005fdc39bf72393e5252934c398995cb07133107af99672328d03b96e9a19625a7a83ee438278cf4f8587f50 SHA512 948b59bed123acc4b02a01248b831ac27fd98a24653fbae315424a1da33573d109667ff8b836be454e7c9b56a6f68f45200effe8649fd4fe6d5551d1b93a6cd5
EBUILD mkdocs-git-authors-plugin-0.6.2.ebuild 1235 BLAKE2B 5c8422d30f2b4e0d2a89ea8cef665b718ffc69fff1c40547efab146b9869a6c933df00b9791f3c7e8e2c03e39e85593ff73cca13a047c3a92fba7450851503b8 SHA512 3c19312212180a4074d5ff8a20ac80525caaad6300f903db1ae02f79d8ec9f24fc60ce0c2d91fbdd9c1c608a52e98090ee8bbe67756602d046c585d19d72eb76
EBUILD mkdocs-git-authors-plugin-0.6.3.ebuild 1233 BLAKE2B 89fe7ee0e50bdd73b247adf81943b4c48271d48ca24c5e0bb911f4b4d6980bd1c3f866fae432773b18ce4f253d9202cf8a0f0e618d7234f41f2e36e10ff95c6a SHA512 e3d7b905f6929aecabd899a369ff62f4ba0646b499e43aa26573b104222d7b4d7c6c6e1b098c8379c677ee47a8df221d7248dfee22050c4d104e542114dcd380
+EBUILD mkdocs-git-authors-plugin-0.6.4.ebuild 1259 BLAKE2B 06ba7717ca6a4f8e9fbc1677a5a2881022180997c8d7c97821cf28950109bc62bb4bec47ba9ab953cb009381a5d82a1a93cd9ca77af50548a15e95cb8c136149 SHA512 15c4c591db3e928ba82bab38eb5d2854ae59869611d50e9847c09eb889f6629017d957ccae244c170add5376ef6d591f00da848615183b741b0166a1749a28d7
MISC metadata.xml 564 BLAKE2B cee03d6742cb66a51c92f8999483f6c04c2b3fc7e8b88f5882bbabc577a54e922bdccf8a1a467e601c43511a372ac90ff8aa4500bd95715cffa83214ee2e64e9 SHA512 2b5539fff2990ebd293715b659e7b9bdeb63117c35933f49a21b873b45188476d3d44f6ac5b1656ee598f028e80f648b91b36ef4dae3f900705dbe2a7355356e
diff --git a/dev-python/mkdocs-git-authors-plugin/mkdocs-git-authors-plugin-0.6.4.ebuild b/dev-python/mkdocs-git-authors-plugin/mkdocs-git-authors-plugin-0.6.4.ebuild
new file mode 100644
index 000000000000..9351c88694ad
--- /dev/null
+++ b/dev-python/mkdocs-git-authors-plugin/mkdocs-git-authors-plugin-0.6.4.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517="setuptools"
+PYTHON_COMPAT=( python3_{8..10} )
+
+DOCS_BUILDER="mkdocs"
+DOCS_DEPEND="dev-python/mkdocs-material"
+
+inherit distutils-r1 docs
+
+DESCRIPTION="Mkdocs plugin to display git authors of a page"
+HOMEPAGE="
+ https://github.com/timvink/mkdocs-git-authors-plugin/
+ https://pypi.org/project/mkdocs-git-authors-plugin/
+"
+SRC_URI="https://github.com/timvink/${PN}/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~riscv ~x86"
+
+RDEPEND="
+ dev-python/GitPython[${PYTHON_USEDEP}]
+ >=dev-python/mkdocs-1.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/click[${PYTHON_USEDEP}]
+ dev-python/mkdocs-material[${PYTHON_USEDEP}]
+ dev-python/mkdocs-git-revision-date-localized-plugin[${PYTHON_USEDEP}]
+ dev-vcs/git
+ )
+ doc? ( dev-vcs/git )
+"
+
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ # mkdocs-git-authors tests need git repo
+ if use test || use doc; then
+ git init -q || die
+ git config --global user.email "you@example.com" || die
+ git config --global user.name "Your Name" || die
+ git add . || die
+ git commit -qm 'init' || die
+ fi
+
+ distutils-r1_python_prepare_all
+}