summaryrefslogtreecommitdiff
path: root/dev-python/mkdocs-git-revision-date-localized-plugin
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-09-09 12:30:03 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-09-09 12:30:03 +0100
commitd8a7472fc6314625f7d16e0427004eb448412908 (patch)
tree0dba2e223a5a5e200a4b84a4a5e3ff690e5059e7 /dev-python/mkdocs-git-revision-date-localized-plugin
parent8e49340ce0aaf205556648d8fa27dd30e8cf4435 (diff)
gentoo auto-resync : 09:09:2024 - 12:30:03
Diffstat (limited to 'dev-python/mkdocs-git-revision-date-localized-plugin')
-rw-r--r--dev-python/mkdocs-git-revision-date-localized-plugin/Manifest2
-rw-r--r--dev-python/mkdocs-git-revision-date-localized-plugin/mkdocs-git-revision-date-localized-plugin-1.2.8.ebuild64
2 files changed, 66 insertions, 0 deletions
diff --git a/dev-python/mkdocs-git-revision-date-localized-plugin/Manifest b/dev-python/mkdocs-git-revision-date-localized-plugin/Manifest
index ba08064881c2..c4c4d3c6c0f2 100644
--- a/dev-python/mkdocs-git-revision-date-localized-plugin/Manifest
+++ b/dev-python/mkdocs-git-revision-date-localized-plugin/Manifest
@@ -1,3 +1,5 @@
DIST mkdocs-git-revision-date-localized-plugin-1.2.7.gh.tar.gz 377565 BLAKE2B 5af96b8775d605329a4156ed72d7ba4987e109e93035a12ca90ac74723d46529312113dad5a19084648e84bfde8f392f6617db95d0f1842e009d780e0e27fa1f SHA512 70f459fdbae7a8e5dc7649bec91c397059aabb4ff2da440be8a040b5c058052db27025a851344cf2853450041c0f18a2ec23e705f6d75bc2870c134a8952f756
+DIST mkdocs-git-revision-date-localized-plugin-1.2.8.gh.tar.gz 377738 BLAKE2B 32a6d3d0f084ddf411a33572743cc04ca57d9dde6a690dbf6cd7a6d1773e839f1422334fa4a54eb6d3bd17645492e4525efe6cd2ed281600e0ed57e44161d691 SHA512 0c5451ba169025eab6ed85beb6ca9af337dd1476c93c3f4009900dd7678caf98f85801e43edac84fc48b0e5ae7186fcee2f49dd3c51d34a29cc88260f933d93e
EBUILD mkdocs-git-revision-date-localized-plugin-1.2.7.ebuild 1569 BLAKE2B 450214ce8b06aeb2005e4a52064dd9598f62ce611d8a5c582d6721f2924db7bfd74a42f2b10f9c9563ec430a91f2005c09fb2b77ff651eee104bf9bc9e7234df SHA512 aed2bf425453ff579fa848ca57449df8244d31ad7e51c765b448aeadbfac79c910cf9030e3cec9a323a8c117dd38695f35f30fbdcf319e96fdd6188e058b9faa
+EBUILD mkdocs-git-revision-date-localized-plugin-1.2.8.ebuild 1617 BLAKE2B 1e1d715c4cec5dc6cb3dfb99983edb1ec9687e1fd92bf27323329bc72bf07258e2eba4a3f6b5b2b572f0473d4f60aaac497f0c9e6a877a9e5fac5bc4bfe2a3a0 SHA512 dfc668102bba695ce47f7f0bf67208d367e240cdf2120bff1391cee60f70fcab3ccf779acbd57127c6204adc6382d15b31fbb84c52f21f6be103cf96c1a33d78
MISC metadata.xml 596 BLAKE2B 9010c7fd37265b6770544a605f918524b75d7b1afea8809075c3b5afb5e56f6848aff4c7fe98367b3dcb3de16f0d21682f9a2fc80f441783f32f904dd8f9a152 SHA512 431dff95204b056afa3a4dab48eec1559d72d0c1ae9a65d89d95fb97454f858c9022578043238a34ce205ac5a16871e6f6d68a3bfe3231c20852437c4fd66254
diff --git a/dev-python/mkdocs-git-revision-date-localized-plugin/mkdocs-git-revision-date-localized-plugin-1.2.8.ebuild b/dev-python/mkdocs-git-revision-date-localized-plugin/mkdocs-git-revision-date-localized-plugin-1.2.8.ebuild
new file mode 100644
index 000000000000..f8706543cd4a
--- /dev/null
+++ b/dev-python/mkdocs-git-revision-date-localized-plugin/mkdocs-git-revision-date-localized-plugin-1.2.8.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517="setuptools"
+PYTHON_COMPAT=( python3_{10..13} )
+
+DOCS_BUILDER="mkdocs"
+DOCS_DEPEND="
+ dev-python/regex
+ dev-python/mkdocs-static-i18n
+ dev-python/mkdocs-material
+ dev-python/mkdocs-git-authors-plugin
+ dev-python/mkdocs-git-revision-date-localized-plugin
+"
+
+inherit distutils-r1 docs
+
+DESCRIPTION="Display the localized date of the last git modification of a markdown file"
+HOMEPAGE="
+ https://github.com/timvink/mkdocs-git-revision-date-localized-plugin/
+ https://pypi.org/project/mkdocs-git-revision-date-localized-plugin/
+"
+SRC_URI="
+ https://github.com/timvink/${PN}/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~x86"
+
+RDEPEND="
+ >=dev-python/Babel-2.7.0[${PYTHON_USEDEP}]
+ dev-python/GitPython[${PYTHON_USEDEP}]
+ >=dev-python/mkdocs-1.0[${PYTHON_USEDEP}]
+ dev-python/pytz[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ dev-python/setuptools-scm[${PYTHON_USEDEP}]
+ test? (
+ dev-python/click[${PYTHON_USEDEP}]
+ dev-python/mkdocs-material[${PYTHON_USEDEP}]
+ dev-python/mkdocs-static-i18n[${PYTHON_USEDEP}]
+ dev-vcs/git
+ )
+ doc? ( dev-vcs/git )
+"
+
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ # mkdocs-git-revision-date-localized-plugin's tests need git repo
+ if use test || use doc; then
+ git init -q || die
+ git config --global user.email "larry@gentoo.org" || die
+ git config --global user.name "Larry the Cow" || die
+ git add . || die
+ git commit -qm 'init' || die
+ fi
+
+ distutils-r1_python_prepare_all
+}