summaryrefslogtreecommitdiff
path: root/dev-python/mkdocstrings-python
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-06-21 00:11:18 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-06-21 00:11:18 +0100
commitbed3b604e16fc6075e29f1af8d47507a07035bd3 (patch)
tree1f5d57fd86e90db37f62afb463f4b4c08a2b6eda /dev-python/mkdocstrings-python
parentd6ca4e4f90cb75c323b5988eefa96a04c0d36908 (diff)
gentoo auto-resync : 21:06:2024 - 00:11:18
Diffstat (limited to 'dev-python/mkdocstrings-python')
-rw-r--r--dev-python/mkdocstrings-python/Manifest2
-rw-r--r--dev-python/mkdocstrings-python/mkdocstrings-python-1.10.5.ebuild40
2 files changed, 42 insertions, 0 deletions
diff --git a/dev-python/mkdocstrings-python/Manifest b/dev-python/mkdocstrings-python/Manifest
index de672f3b716b..a5a28cc68429 100644
--- a/dev-python/mkdocstrings-python/Manifest
+++ b/dev-python/mkdocstrings-python/Manifest
@@ -1,5 +1,7 @@
DIST mkdocstrings-python-1.10.3.gh.tar.gz 157856 BLAKE2B 74d1c9b57e439195494aef03f82606971084800ec23fdd21a17b743830860f73f3c5d421d3202a51b3146c09c547b7719ceeb11e3ff8347027941fafcbde3250 SHA512 7ddb34e7847fe58f69ba97f4f4a2974ef79cb826d9017b09e11fecdef43a3f71ad06ef93ecfcdba715fbd0524e6af6702b162bb5109f5a2055eb424e54811c3b
DIST mkdocstrings-python-1.10.4.gh.tar.gz 157012 BLAKE2B d51032f35baff3ab7260b773e24eab3f4bcba8fe0341cb3b8415a27540d73e80120aac9975aa6ef8b92a51408ffb6a9790d929c0d9b61b05264999141c62ec2d SHA512 f6576e6326043ab6db48334517a8cb4d157cd290e665dcf5d054150babaa874c37f29b467e8a6249d4c2005d0fe5eb5fc1543a388e70cacb3c57c5540215969a
+DIST mkdocstrings-python-1.10.5.gh.tar.gz 157091 BLAKE2B 1f0685fc8b04ea4e5f33e3e4ca9637d590bd45b5be85d856ea0f6693d3be2a7d215751b68f811ca73afec078ffa5cc1acf88ab1907bd9842c6e390eb14fd71c0 SHA512 0bc3b103a99add6d38621243d2a21339efd837fb3476feb13bc55afabcee481d45ea7b410f8d16312583f308ee9f36f387762cdd1ef1e9758ecdb5b1be9dcb9e
EBUILD mkdocstrings-python-1.10.3.ebuild 875 BLAKE2B 164dddd0c0108f6b0a6df7259187f26c47e2e5378666b1379764e1e8403b8783044af6f8ec143c2a820496d887ead262d651b25694c052f6e6d13ed961975643 SHA512 b664894d3defd0cb2fa232bed7470b5347deb66272349af9b5d215e30de9a0f7cc9042e68f256ab81a31f4d329707f20d9cfae6362a5b82d30c33e00ef02e35f
EBUILD mkdocstrings-python-1.10.4.ebuild 875 BLAKE2B 164dddd0c0108f6b0a6df7259187f26c47e2e5378666b1379764e1e8403b8783044af6f8ec143c2a820496d887ead262d651b25694c052f6e6d13ed961975643 SHA512 b664894d3defd0cb2fa232bed7470b5347deb66272349af9b5d215e30de9a0f7cc9042e68f256ab81a31f4d329707f20d9cfae6362a5b82d30c33e00ef02e35f
+EBUILD mkdocstrings-python-1.10.5.ebuild 875 BLAKE2B eb07c4f6732cc8c10e2d77de5e3e305fbebef9e26854a7c5a1c6fbae25f8ecdf5b0f6eed21af06c82e5209300f46322a606770a7d7b456d02821169f3bbc8c47 SHA512 9adacdf272b15eff1f228a6bde423609915cb57d754d219e3a40ae664e4c392707519b92006957083fb7e3d09d9653cd1320272135863905d0de5e6fa9ae0b14
MISC metadata.xml 411 BLAKE2B 0ac98abc8de945139a73e2083e8c04df749bd8c0c26c446df65218057182391ae025885fa5c5bde2d1139dde9916aa3baa0426d70b57326563c3fdaf466a20d8 SHA512 c7ec032c8ae7197452714dc2b541ccad1cf84d7844dafc4e7581ffb00c62c0fd2c38d453e62a7706d74d2d20146acdf1e99e502ab8bd8976acfd6f5a605e1c56
diff --git a/dev-python/mkdocstrings-python/mkdocstrings-python-1.10.5.ebuild b/dev-python/mkdocstrings-python/mkdocstrings-python-1.10.5.ebuild
new file mode 100644
index 000000000000..be4fc9ad361b
--- /dev/null
+++ b/dev-python/mkdocstrings-python/mkdocstrings-python-1.10.5.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..12} )
+DISTUTILS_USE_PEP517=pdm-backend
+
+inherit distutils-r1
+
+DESCRIPTION="Python handler for dev-python/mkdocstrings"
+HOMEPAGE="
+ https://mkdocstrings.github.io/python/
+ https://github.com/mkdocstrings/python/
+ https://pypi.org/project/mkdocstrings-python/
+"
+# Tests need files absent from the PyPI tarballs
+SRC_URI="
+ https://github.com/mkdocstrings/python/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+S="${WORKDIR}/python-${PV}"
+
+LICENSE="ISC"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~riscv"
+
+RDEPEND="
+ >=dev-python/griffe-0.47[${PYTHON_USEDEP}]
+ >=dev-python/mkdocstrings-0.25.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/mkdocs-material[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+export PDM_BUILD_SCM_VERSION=${PV}