summaryrefslogtreecommitdiff
path: root/dev-python/mkdocstrings
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-09-02 12:28:17 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-09-02 12:28:17 +0100
commit20b6ab983b55b022c6e4af317154089e18ad41cb (patch)
tree07060dcd7f71fd5f02ecf6463cb8bf3665b65bcc /dev-python/mkdocstrings
parent12a4866975c254ac127821e7562eda5ac119fba3 (diff)
gentoo auto-resync : 02:09:2024 - 12:28:17
Diffstat (limited to 'dev-python/mkdocstrings')
-rw-r--r--dev-python/mkdocstrings/Manifest2
-rw-r--r--dev-python/mkdocstrings/mkdocstrings-0.26.0.ebuild56
2 files changed, 58 insertions, 0 deletions
diff --git a/dev-python/mkdocstrings/Manifest b/dev-python/mkdocstrings/Manifest
index 156c026232ac..a95d9676b087 100644
--- a/dev-python/mkdocstrings/Manifest
+++ b/dev-python/mkdocstrings/Manifest
@@ -1,5 +1,7 @@
DIST mkdocstrings-0.25.1.gh.tar.gz 89869 BLAKE2B 248436eeabafbb7cbee27362b43d2feadeadda7692b5843621bd97261e17a93783c38f37850700c6e79b7f23f15fdc8f21567329afba9b4fb0618f277acc1865 SHA512 155dc5d15fd71f9c5dbd5d5f70f380ad5197fc0c1dc0fe722205b30decbd19307daa631d3a4a40206cdf36981f414ea1a4c001d8cef517ffed569e96ea0e8302
DIST mkdocstrings-0.25.2.tar.gz 91796 BLAKE2B d666d402fc94f00df107f54ae6057fbdaba2a2da20c283fe5f1bfb33cf4cca4dc882e9132156434439560848dfea224916c96450a759924175fe6244e75dac43 SHA512 ad1d771ffbbb04bfa9b8a4190c41303fe6d78f9bb07fe3236ccb284836886d759a9031c42192e2608fc3941a0a59c149c241d193cbc2fe96462605b4f37b2545
+DIST mkdocstrings-0.26.0.tar.gz 92218 BLAKE2B 6eee2a080b568ccb90d8ac122da9bb9c1d35088e4f3d43f98da287e581f549f25b6da9dd7f0fbe9dffcaeea8acc1143cd77b4e2fb5d208d592242954724f98e3 SHA512 b1e63fae1e22f0fd1977e7274b94bf3f50ab673d6e3c77d291095bf3503fff8afde08d29917fdbddd00ac716ac048248362dbc526446924592b57f2ea339caf8
EBUILD mkdocstrings-0.25.1.ebuild 1821 BLAKE2B e2c6af80353955ae3703f857b8f98f73cfe14d42e099f81f223ff258e575e62fb11aef04830208d888c72e4387a163fe73f08b2125af49871a472b6d69b9928d SHA512 36d597b27bfb33ee48069598e65155596a10f89de6e90a60636a85eecf2258fc9d8ee94656f3dcfb239e309213728b34b45c5c4c538dd0ce9a9641e64e5e38e9
EBUILD mkdocstrings-0.25.2.ebuild 1679 BLAKE2B 70083989186e6e1cc32b2509de9f60e92f607041623cfd52ab6da83fc669cd45db9123b29885b3feab89d14a919816de672dc60ca967d84a05449a0ccaccb971 SHA512 11ccf7a1ee2e231136fe0397f3f994742cfe35308df2a6a5ce989d053905364ff1ad13e729c6ace6112689b10be23f6e9ef1895b6a697a97b351e6dc5b9c13eb
+EBUILD mkdocstrings-0.26.0.ebuild 1675 BLAKE2B 5262f3e60a31f89a0a6db319015057e97f217cea34b2dcc3370433309739291b41c3966c9d0163cbb4f37ede5f135511cbb7b42a8c23c43951325379f25493ae SHA512 e9c73d67494d8393e5662bfad6c4f23b212c986151a2e46b307dc1bd60bc4aa12314f1f1db818b037f06cb53ebac27be8dd377f52089260b6d5517f3162f1268
MISC metadata.xml 405 BLAKE2B cd4fbf980873ef6e1ed8da7d608da6a97a9f46324521542a4d5943c4dd6e6d926ee7316cde0725c890fc7b4bbe3e6f1c694c00574cfcac94f6306c645fab1521 SHA512 37e403dff85ba044fd0a00e34c0d139f348933500466417577ff202a0ca425c9532df1fad8a15a97f524d720ae1297d653663b28f07fe7d01a39adc675ff9b8a
diff --git a/dev-python/mkdocstrings/mkdocstrings-0.26.0.ebuild b/dev-python/mkdocstrings/mkdocstrings-0.26.0.ebuild
new file mode 100644
index 000000000000..0738246d3fd9
--- /dev/null
+++ b/dev-python/mkdocstrings/mkdocstrings-0.26.0.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=pdm-backend
+PYTHON_COMPAT=( python3_{10..13} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Automatic documentation from sources, for MkDocs"
+HOMEPAGE="
+ https://mkdocstrings.github.io/
+ https://github.com/mkdocstrings/mkdocstrings/
+ https://pypi.org/project/mkdocstrings/
+"
+
+LICENSE="ISC"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~riscv"
+
+RDEPEND="
+ >=dev-python/click-7.0[${PYTHON_USEDEP}]
+ >=dev-python/jinja-2.11.1[${PYTHON_USEDEP}]
+ >=dev-python/markdown-3.6[${PYTHON_USEDEP}]
+ >=dev-python/markupsafe-1.1[${PYTHON_USEDEP}]
+ >=dev-python/mkdocs-1.5[${PYTHON_USEDEP}]
+ >=dev-python/mkdocs-autorefs-1.2[${PYTHON_USEDEP}]
+ >=dev-python/platformdirs-2.2[${PYTHON_USEDEP}]
+ >=dev-python/pymdown-extensions-6.3[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/markdown-exec[${PYTHON_USEDEP}]
+ dev-python/mkdocs-material[${PYTHON_USEDEP}]
+ dev-python/mkdocstrings-python[${PYTHON_USEDEP}]
+ dev-python/sphinx[${PYTHON_USEDEP}]
+ )
+"
+
+# mkdocstrings documentation generation requires several currently
+# unpackaged mkdocs extensions and plug-ins, and this test
+# makes use of mkdocs configuration
+EPYTEST_DESELECT=(
+ tests/test_plugin.py::test_disabling_plugin
+ # WTF, it tries to unlink installed files from installed package?!
+ tests/test_handlers.py::test_extended_templates
+ # Needs unpackaged mkdocs-callouts, mkdocs-literate-nav, and possibly more
+ tests/test_inventory.py::test_sphinx_load_mkdocstrings_inventory_file
+ # Internet
+ tests/test_inventory.py::test_load_inventory
+)
+
+distutils_enable_tests pytest
+
+export PDM_BUILD_SCM_VERSION=${PV}