summaryrefslogtreecommitdiff
path: root/dev-python/mkdocstrings
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-10-14 04:04:03 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-10-14 04:04:03 +0100
commit2916cf6049cf9d3092021e247d56c580df6029a7 (patch)
treec796a6fc8b6fd0e4fd5ac06b009000b438fed7d9 /dev-python/mkdocstrings
parent7b5306e0d287565138e8b051e32f57e6af6ae0ed (diff)
gentoo auto-resync : 14:10:2024 - 04:04:03
Diffstat (limited to 'dev-python/mkdocstrings')
-rw-r--r--dev-python/mkdocstrings/Manifest2
-rw-r--r--dev-python/mkdocstrings/mkdocstrings-0.26.2.ebuild56
2 files changed, 58 insertions, 0 deletions
diff --git a/dev-python/mkdocstrings/Manifest b/dev-python/mkdocstrings/Manifest
index 63d1264f0bb0..ed3826493500 100644
--- a/dev-python/mkdocstrings/Manifest
+++ b/dev-python/mkdocstrings/Manifest
@@ -1,5 +1,7 @@
DIST mkdocstrings-0.26.0.tar.gz 92218 BLAKE2B 6eee2a080b568ccb90d8ac122da9bb9c1d35088e4f3d43f98da287e581f549f25b6da9dd7f0fbe9dffcaeea8acc1143cd77b4e2fb5d208d592242954724f98e3 SHA512 b1e63fae1e22f0fd1977e7274b94bf3f50ab673d6e3c77d291095bf3503fff8afde08d29917fdbddd00ac716ac048248362dbc526446924592b57f2ea339caf8
DIST mkdocstrings-0.26.1.tar.gz 92677 BLAKE2B 010464f8af2b741fb74cae7140c8552ee05e84a275952701bc29f8f4d057fd4f82a6129da070cb1ae41f0a1e407b8cce6dda4a924650bb83f41c9bf5caf208e4 SHA512 75c1b794dc816523b1c0202304146a986e87403f65e1ed728ed585eb6d78f9ae5fe1ab97798fa8d9ad24f41ec590ad3bb31dec2d420f6312da126b55540301da
+DIST mkdocstrings-0.26.2.tar.gz 92512 BLAKE2B e2ca2ba4d5a8916cdb77efb0db6c0fdc5f8969b27f4b0b5b199873a62c85150b5a0dde45797b48d297e08f9e082c9c5329084feb15379ae0a16821ac11aa3fed SHA512 7ea34df4204ae82faa19ddaf81a073152c57d9ef7f55f8935c1eb1b244ebc6ed749d853c72fd28e69ee5e1aa12ae7a2e4b6fff4f9965856a837d15dd0e2cc11e
EBUILD mkdocstrings-0.26.0.ebuild 1675 BLAKE2B 5262f3e60a31f89a0a6db319015057e97f217cea34b2dcc3370433309739291b41c3966c9d0163cbb4f37ede5f135511cbb7b42a8c23c43951325379f25493ae SHA512 e9c73d67494d8393e5662bfad6c4f23b212c986151a2e46b307dc1bd60bc4aa12314f1f1db818b037f06cb53ebac27be8dd377f52089260b6d5517f3162f1268
EBUILD mkdocstrings-0.26.1.ebuild 1675 BLAKE2B 5262f3e60a31f89a0a6db319015057e97f217cea34b2dcc3370433309739291b41c3966c9d0163cbb4f37ede5f135511cbb7b42a8c23c43951325379f25493ae SHA512 e9c73d67494d8393e5662bfad6c4f23b212c986151a2e46b307dc1bd60bc4aa12314f1f1db818b037f06cb53ebac27be8dd377f52089260b6d5517f3162f1268
+EBUILD mkdocstrings-0.26.2.ebuild 1675 BLAKE2B 5262f3e60a31f89a0a6db319015057e97f217cea34b2dcc3370433309739291b41c3966c9d0163cbb4f37ede5f135511cbb7b42a8c23c43951325379f25493ae SHA512 e9c73d67494d8393e5662bfad6c4f23b212c986151a2e46b307dc1bd60bc4aa12314f1f1db818b037f06cb53ebac27be8dd377f52089260b6d5517f3162f1268
MISC metadata.xml 405 BLAKE2B cd4fbf980873ef6e1ed8da7d608da6a97a9f46324521542a4d5943c4dd6e6d926ee7316cde0725c890fc7b4bbe3e6f1c694c00574cfcac94f6306c645fab1521 SHA512 37e403dff85ba044fd0a00e34c0d139f348933500466417577ff202a0ca425c9532df1fad8a15a97f524d720ae1297d653663b28f07fe7d01a39adc675ff9b8a
diff --git a/dev-python/mkdocstrings/mkdocstrings-0.26.2.ebuild b/dev-python/mkdocstrings/mkdocstrings-0.26.2.ebuild
new file mode 100644
index 000000000000..0738246d3fd9
--- /dev/null
+++ b/dev-python/mkdocstrings/mkdocstrings-0.26.2.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=pdm-backend
+PYTHON_COMPAT=( python3_{10..13} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Automatic documentation from sources, for MkDocs"
+HOMEPAGE="
+ https://mkdocstrings.github.io/
+ https://github.com/mkdocstrings/mkdocstrings/
+ https://pypi.org/project/mkdocstrings/
+"
+
+LICENSE="ISC"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~riscv"
+
+RDEPEND="
+ >=dev-python/click-7.0[${PYTHON_USEDEP}]
+ >=dev-python/jinja-2.11.1[${PYTHON_USEDEP}]
+ >=dev-python/markdown-3.6[${PYTHON_USEDEP}]
+ >=dev-python/markupsafe-1.1[${PYTHON_USEDEP}]
+ >=dev-python/mkdocs-1.5[${PYTHON_USEDEP}]
+ >=dev-python/mkdocs-autorefs-1.2[${PYTHON_USEDEP}]
+ >=dev-python/platformdirs-2.2[${PYTHON_USEDEP}]
+ >=dev-python/pymdown-extensions-6.3[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/markdown-exec[${PYTHON_USEDEP}]
+ dev-python/mkdocs-material[${PYTHON_USEDEP}]
+ dev-python/mkdocstrings-python[${PYTHON_USEDEP}]
+ dev-python/sphinx[${PYTHON_USEDEP}]
+ )
+"
+
+# mkdocstrings documentation generation requires several currently
+# unpackaged mkdocs extensions and plug-ins, and this test
+# makes use of mkdocs configuration
+EPYTEST_DESELECT=(
+ tests/test_plugin.py::test_disabling_plugin
+ # WTF, it tries to unlink installed files from installed package?!
+ tests/test_handlers.py::test_extended_templates
+ # Needs unpackaged mkdocs-callouts, mkdocs-literate-nav, and possibly more
+ tests/test_inventory.py::test_sphinx_load_mkdocstrings_inventory_file
+ # Internet
+ tests/test_inventory.py::test_load_inventory
+)
+
+distutils_enable_tests pytest
+
+export PDM_BUILD_SCM_VERSION=${PV}