summaryrefslogtreecommitdiff
path: root/dev-python/mkdocstrings
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2025-03-12 01:49:51 +0000
committerV3n3RiX <venerix@koprulu.sector>2025-03-12 01:49:51 +0000
commitef0fedb39c21a343a3f316726f272bad9005b22c (patch)
tree0d64e58453e117f61a9e1641532926278f51b72e /dev-python/mkdocstrings
parentcf7807d7aea23a99a144afceaba961cfed652b5f (diff)
gentoo auto-resync : 12:03:2025 - 01:49:51next
Diffstat (limited to 'dev-python/mkdocstrings')
-rw-r--r--dev-python/mkdocstrings/Manifest2
-rw-r--r--dev-python/mkdocstrings/mkdocstrings-0.29.0.ebuild54
2 files changed, 56 insertions, 0 deletions
diff --git a/dev-python/mkdocstrings/Manifest b/dev-python/mkdocstrings/Manifest
index 4cf575cb82dd..602b7f7db889 100644
--- a/dev-python/mkdocstrings/Manifest
+++ b/dev-python/mkdocstrings/Manifest
@@ -1,5 +1,7 @@
DIST mkdocstrings-0.28.2.tar.gz 5691916 BLAKE2B c1593205307285760f1d58db99e022b6ba43db1ab69ee024b109e98918407c1f256fedcddbab7778540cacb94764cdd7d5c042f39651554635fc68aa5727ebfc SHA512 946056f9ad179b58792756caf18f5881c2d24d05fc3adb24efe7fb8af7b44d68c648002098d4ff8b766ee6c9099bd918319df325fc5cb9854d47278c571f52ff
DIST mkdocstrings-0.28.3.tar.gz 104109 BLAKE2B bbeba5319fd0912a214f0e8f7759abb7948ee1da6890472037f68a79f658bbdd29e32988e885e379cec05f61a616315f5baf1c575e460e0a774876929dc26bb8 SHA512 6d9e280aef8d8c35eb583a739b7f47b75fdc97ad093c91309ebfda3b6a1d9dcf31da7872d17eb00de3d731247f1f0396524f90d8db85519632dcdebae2f38bac
+DIST mkdocstrings-0.29.0.tar.gz 1212185 BLAKE2B 003f90c69a4b98f1f9049ed4fa74b165b7ed7a78b1bdf3cb8efa127a6115a3b26adca43d5787d9661b99b532d06cc9edf1d40efd97eed1a5c0c5d92d3e48627b SHA512 5a2ea61f59cf517482e18541aaabe6f284f2af43d9e8712e2096401bfba071f824f4c65f64d94ff57a09a8d625983655cae1466900ae6756e532ea2eb1c8755c
EBUILD mkdocstrings-0.28.2.ebuild 1661 BLAKE2B 1e0b29b11095d52d17a9bbca58325b17c97667660bedba38716b7793f6e69d587975ad64a93148aedcf851344a36efa5103484a863356a420e952804d217a80f SHA512 57d4054886fe7dfcf06f26543674bba5e952825522d450b57abf5c677a4b89670111585ca4151158960a5580b2c6ca365d9007d956c1e2110137a29ff40bd30b
EBUILD mkdocstrings-0.28.3.ebuild 1661 BLAKE2B 159ca2ecb6521ccc57d186e31f318c48b3b954b4c3564d80cd400e8a8551756e8ee25785c2cbd1739caa5fe1852ace783339766a35c29280c49cfac78ead0304 SHA512 405f1b720366ddf0c3958ea558fc6ce924a448045e955f5ade72a9a324b523abc03373daba1f7fde991cf45fe1319eb321bbfbfb2f9921104eac9c986553a168
+EBUILD mkdocstrings-0.29.0.ebuild 1609 BLAKE2B fc291b6a2fca3a37779eb21b49cdf9c0a977a9da9f97bc654e3a1401d51dbde53bcb458d83e74b0ede563ba2517cd75d27ad4436180e3bb1c6f27779675b70ef SHA512 c096cd1112e5d4bf16eb7e0da5124cb28eceb635cb3de7656ca0355b48bd003c8e1c4cbd43b084a46ed9cf34ef8638f7066d13ddf30b758bc72309c81a3495c8
MISC metadata.xml 405 BLAKE2B cd4fbf980873ef6e1ed8da7d608da6a97a9f46324521542a4d5943c4dd6e6d926ee7316cde0725c890fc7b4bbe3e6f1c694c00574cfcac94f6306c645fab1521 SHA512 37e403dff85ba044fd0a00e34c0d139f348933500466417577ff202a0ca425c9532df1fad8a15a97f524d720ae1297d653663b28f07fe7d01a39adc675ff9b8a
diff --git a/dev-python/mkdocstrings/mkdocstrings-0.29.0.ebuild b/dev-python/mkdocstrings/mkdocstrings-0.29.0.ebuild
new file mode 100644
index 000000000000..67ef3b74756c
--- /dev/null
+++ b/dev-python/mkdocstrings/mkdocstrings-0.29.0.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2025 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=pdm-backend
+PYTHON_COMPAT=( pypy3 pypy3_11 python3_{10..13} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Automatic documentation from sources, for MkDocs"
+HOMEPAGE="
+ https://mkdocstrings.github.io/
+ https://github.com/mkdocstrings/mkdocstrings/
+ https://pypi.org/project/mkdocstrings/
+"
+
+LICENSE="ISC"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~riscv"
+
+RDEPEND="
+ >=dev-python/jinja2-2.11.1[${PYTHON_USEDEP}]
+ >=dev-python/markdown-3.6[${PYTHON_USEDEP}]
+ >=dev-python/markupsafe-1.1[${PYTHON_USEDEP}]
+ >=dev-python/mkdocs-1.6[${PYTHON_USEDEP}]
+ >=dev-python/mkdocs-autorefs-1.4[${PYTHON_USEDEP}]
+ >=dev-python/pymdown-extensions-6.3[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/markdown-exec[${PYTHON_USEDEP}]
+ dev-python/mkdocs-material[${PYTHON_USEDEP}]
+ >=dev-python/mkdocstrings-python-1.16.2[${PYTHON_USEDEP}]
+ dev-python/sphinx[${PYTHON_USEDEP}]
+ )
+"
+
+# mkdocstrings documentation generation requires several currently
+# unpackaged mkdocs extensions and plug-ins, and this test
+# makes use of mkdocs configuration
+EPYTEST_DESELECT=(
+ tests/test_plugin.py::test_disabling_plugin
+ # WTF, it tries to unlink installed files from installed package?!
+ tests/test_handlers.py::test_extended_templates
+ # Needs unpackaged mkdocs-callouts, mkdocs-literate-nav, and possibly more
+ tests/test_inventory.py::test_sphinx_load_mkdocstrings_inventory_file
+ # Internet
+ tests/test_inventory.py::test_load_inventory
+)
+
+distutils_enable_tests pytest
+
+export PDM_BUILD_SCM_VERSION=${PV}