summaryrefslogtreecommitdiff
path: root/dev-python/mongoengine
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2021-10-08 23:06:07 +0100
committerV3n3RiX <venerix@koprulu.sector>2021-10-08 23:06:07 +0100
commite23a08d0c97a0cc415aaa165da840b056f93c997 (patch)
tree4c5f7db60483518201fef36f8cc0712789a08db2 /dev-python/mongoengine
parent391b5b359a346aff490103da7dddc85047f83830 (diff)
gentoo resync : 08.10.2021
Diffstat (limited to 'dev-python/mongoengine')
-rw-r--r--dev-python/mongoengine/Manifest2
-rw-r--r--dev-python/mongoengine/mongoengine-0.23.1.ebuild48
2 files changed, 24 insertions, 26 deletions
diff --git a/dev-python/mongoengine/Manifest b/dev-python/mongoengine/Manifest
index 3e4dc8a2620b..3e800e99d6ac 100644
--- a/dev-python/mongoengine/Manifest
+++ b/dev-python/mongoengine/Manifest
@@ -1,3 +1,3 @@
DIST mongoengine-0.23.1.tar.gz 324881 BLAKE2B f6856d432f34c19f9d32aa7fe340c5a09db6976802f5ce320e9722b942f80a1c38a725eab882780104fa379abe212319802f9dd4b405da41454bda84a5d57eb4 SHA512 fcd2ff1df3e2b28bc4cba67cad71a1856e9f94d4d2ecb731a5cce2f1c5e9abc163be37b7db518dfaa54a0ef7f664ac49b621a0554961aa7e13686ff608ef132a
-EBUILD mongoengine-0.23.1.ebuild 2098 BLAKE2B 7364b9ad290bd83dbb1fd2f528679cd2b594aaa4dc158c1856177176341393e7ca2fa624547ab029a27f374033f5751e954672c40db3a2368030a6ea9865f3c2 SHA512 bb828275d6d21750e7637fd4cf4666579602982d2e7ba989f365128085a7ec691ec4340ca9eea10aa3dff1e043169f1bdac5adfb24efbdd677fd2f678be1130a
+EBUILD mongoengine-0.23.1.ebuild 2385 BLAKE2B c1b8ba665fcb94b271229e18971fc72eb23d2f434413ed6ccbdfe0d8d349dacdfcc79283f642a42288d59fd310e5d5afbd15c72246c56afdddc155afc3d81ef6 SHA512 2b75b872bad8b035b32fe7e3c0334deabb280d6309f72d8be4e88ffa75881ada64612a60e7ff5c3fd3b5abe31a6173e8890f28b88bd9937fb1100bf71c5589af
MISC metadata.xml 402 BLAKE2B cdca7f343f9a264c7c565fb4b99cee9dd4e1869ab6068b8b1da6c1ad657d16fea05716d34b3fbec028527e8948dd1fd4e1aa3e272fc814af6646259be381093c SHA512 c5eb1eb9118bf5165146ef41755be092b39a7bb2d6cafbf5cce11066a5a0e15233556ea3a6a2fd250eb8c71cb7a725df37ed32b3018568aef746585c5109efa7
diff --git a/dev-python/mongoengine/mongoengine-0.23.1.ebuild b/dev-python/mongoengine/mongoengine-0.23.1.ebuild
index 8bc583611f98..299f1c980342 100644
--- a/dev-python/mongoengine/mongoengine-0.23.1.ebuild
+++ b/dev-python/mongoengine/mongoengine-0.23.1.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-PYTHON_COMPAT=( python3_{7..9} )
+PYTHON_COMPAT=( python3_{8..10} )
inherit distutils-r1
DESCRIPTION="A Python Object-Document-Mapper for working with MongoDB"
@@ -25,48 +25,46 @@ BDEPEND="
distutils_enable_tests pytest
-src_prepare() {
- # TODO: investigate
- sed -e 's:test_covered_index:_&:' \
- -i tests/document/test_indexes.py || die
- # no $eval
- sed -e 's:test_exec_js_field_sub:_&:' \
- -e 's:test_exec_js_query:_&:' \
- -e 's:test_item_frequencies_normalize:_&:' \
- -e 's:test_item_frequencies_with_0_values:_&:' \
- -e 's:test_item_frequencies_with_False_values:_&:' \
- -e 's:test_item_frequencies_with_null_embedded:_&:' \
- -i tests/queryset/test_queryset.py || die
- # TODO: investigate (wrong order? bad comparison?)
- sed -e 's:test_distinct_ListField_EmbeddedDocumentField:_&:' \
- -i tests/queryset/test_queryset.py || die
-
- distutils-r1_src_prepare
-}
-
python_test() {
+ local EPYTEST_DESELECT=(
+ # TODO: investigate
+ tests/document/test_indexes.py::TestIndexes::test_collation
+ tests/document/test_indexes.py::TestIndexes::test_covered_index
+ tests/document/test_indexes.py::TestIndexes::test_create_geohaystack_index
+ # no $eval
+ tests/queryset/test_queryset.py::TestQueryset::test_exec_js_query
+ tests/queryset/test_queryset.py::TestQueryset::test_exec_js_field_sub
+ tests/queryset/test_queryset.py::TestQueryset::test_item_frequencies_normalize
+ tests/queryset/test_queryset.py::TestQueryset::test_item_frequencies_with_0_values
+ tests/queryset/test_queryset.py::TestQueryset::test_item_frequencies_with_False_values
+ tests/queryset/test_queryset.py::TestQueryset::test_item_frequencies_with_null_embedded
+ # TODO: investigate (wrong order? bad comparison?)
+ tests/queryset/test_queryset.py::TestQueryset::test_distinct_ListField_EmbeddedDocumentField
+ )
+
local dbpath=${TMPDIR}/mongo.db
local logpath=${TMPDIR}/mongod.log
+ local DB_PORT=27017
mkdir -p "${dbpath}" || die
ebegin "Trying to start mongod on port ${DB_PORT}"
LC_ALL=C \
mongod --dbpath "${dbpath}" --nojournal \
- --bind_ip 127.0.0.1 --port 27017 \
+ --bind_ip 127.0.0.1 --port ${DB_PORT} \
--unixSocketPrefix "${TMPDIR}" \
--logpath "${logpath}" --fork || die
sleep 2
# Now we need to check if the server actually started...
- if [[ -S "${TMPDIR}"/mongodb-27017.sock ]]; then
+ if [[ -S "${TMPDIR}"/mongodb-${DB_PORT}.sock ]]; then
# yay!
eend 0
else
eend 1
- eerror "Unable to start mongod for tests. See the server log:"
- eerror " ${logpath}"
- die "Unable to start mongod for tests."
+ eerror "Unable to start mongod for tests. Here is the server log:"
+ cat "${logpath}"
+ die "Unable to start mongod for tests"
fi
local failed