summaryrefslogtreecommitdiff
path: root/dev-python/moto
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-10-16 09:55:38 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-10-16 09:55:38 +0100
commit5a2a5572ac35843b9cd1c9369bd96e117647d24f (patch)
tree4f3b96f8834f6c6a9742a7a7e9f3453240fc5cbe /dev-python/moto
parent01f09076452fe45dac176dc2c4fff1ba81f3b5e0 (diff)
gentoo auto-resync : 16:10:2023 - 09:55:38
Diffstat (limited to 'dev-python/moto')
-rw-r--r--dev-python/moto/Manifest2
-rw-r--r--dev-python/moto/moto-4.2.6.ebuild123
2 files changed, 125 insertions, 0 deletions
diff --git a/dev-python/moto/Manifest b/dev-python/moto/Manifest
index 8f9d9553673d..d01858d96b4e 100644
--- a/dev-python/moto/Manifest
+++ b/dev-python/moto/Manifest
@@ -1,5 +1,7 @@
DIST moto-4.1.15.tar.gz 3627847 BLAKE2B 65349e72dc6cc90f0ed148a1a68efae0b3c171adbc79d41dee8d058c62f2944a3e55c86c2e8e302ff865208393be551a4b6bf387a33136dfa808443ccfe3869a SHA512 b49541ac8ddd8d669af06253451ddd2e0d70eea63fd2b2fd28eb783b2fb9dccb1e13e650bfca3a5b0f94932b22b112d15317599bc70307828fb2c47191f94da7
DIST moto-4.2.5.tar.gz 4721089 BLAKE2B 475a26ac75ed1e7e7fc00302b824ed473950c2916281456c1270f1489ab7c225468f2cd193b99f9589e8bf996590520abccdda8bc33278951696e8322ee6a1a8 SHA512 15211c367011acc049840555e2706d16a520226a1b9de0860977c90167b66702b06e7187af537da8c6312b0d8dcf50130e2a293120230d836b1e77691179827e
+DIST moto-4.2.6.tar.gz 4745145 BLAKE2B 76610aafe3ea4106454aadbc8cf853ff5d4617202a62ae92e6cbe46c75a17d1dd8e63e8188c0c17a88af080bfe6c3466ed420378cee27d0287fe617d3412807e SHA512 0bef11a2600d48349735e7d118f6f28b02fb85e2b5e7310aaa0651444740ad4657470a59c59dab75084cb4250c6b5b725eda5e996b9acbc927529850cabc4c1c
EBUILD moto-4.1.15.ebuild 4246 BLAKE2B dcdec57740a106e61de174d523eceee617187e85e2ead5b33789204738ec028423a6e0d751b476be4ee1cf6e7e0a874cca0e57f19bae169c7787e214e150ce8c SHA512 64cde773b905f1ad629b4736facc6fe969208a857e40f99b55936554a754f75c7502aadb29c64977669712b66382454c44eff29ddac390a5a39b64c74fd61ba6
EBUILD moto-4.2.5.ebuild 5171 BLAKE2B 226e9da580f4889f27e7702844875b90dfab2125676b0a4c6aadd3b65a83e7b966bf684578252f4476916d3d8bd2a7d2e5d0635466dfa25380fa45f30bdd959a SHA512 11622379e69baecf9bc4b3e5456b0f0afb374019d5f8b51a3ae99421ea349be0e1b1f1167a144af22619f9bad36a419ea435b4f3ea0669a46d08ee968ccf9990
+EBUILD moto-4.2.6.ebuild 5368 BLAKE2B f3c73f7c483cce1d34ef96da98acb4a5f6f5b851e21234ba94701d18b39e7934cf6f370a088a59583067f3f6f907a0142cebc80934680758517347e787a7a5fe SHA512 6059260f40fac9c3047a39f5368ae0027a6ed8ac2e6ffda76c9a853c200cd14345a9fd83a9f0267a0e411b3ebb8d5d9417496b6be0fd8d27634461cc02cd92da
MISC metadata.xml 553 BLAKE2B 1669d17d3e655aa3fb41a489229a5fbfa6a9cfb23c667e98fbbef931992c7e9645581b9ea12011601093586cba491a5557d68e5256edb9f387c4db362346edf9 SHA512 48ae3bd9be8c3bfb68f7022d0e7bb422c2a06157967809be302067facf91db825023859d18ccea89109931538b0e93181d54a31fcc967628df61a9a3112edd3d
diff --git a/dev-python/moto/moto-4.2.6.ebuild b/dev-python/moto/moto-4.2.6.ebuild
new file mode 100644
index 000000000000..a08145b0f6f2
--- /dev/null
+++ b/dev-python/moto/moto-4.2.6.ebuild
@@ -0,0 +1,123 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit distutils-r1 multiprocessing pypi
+
+DESCRIPTION="Mock library for boto"
+HOMEPAGE="
+ https://github.com/getmoto/moto/
+ https://pypi.org/project/moto/
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~riscv ~x86"
+
+RDEPEND="
+ >=dev-python/aws-xray-sdk-0.93[${PYTHON_USEDEP}]
+ >=dev-python/cfn-lint-0.40.0[${PYTHON_USEDEP}]
+ >=dev-python/cryptography-3.3.1[${PYTHON_USEDEP}]
+ dev-python/cookies[${PYTHON_USEDEP}]
+ >=dev-python/docker-3.0.0[${PYTHON_USEDEP}]
+ >=dev-python/idna-2.5[${PYTHON_USEDEP}]
+ >=dev-python/jinja-2.10.1[${PYTHON_USEDEP}]
+ >=dev-python/jsondiff-1.1.2[${PYTHON_USEDEP}]
+ dev-python/boto3[${PYTHON_USEDEP}]
+ dev-python/botocore[${PYTHON_USEDEP}]
+ dev-python/flask[${PYTHON_USEDEP}]
+ dev-python/flask-cors[${PYTHON_USEDEP}]
+ dev-python/more-itertools[${PYTHON_USEDEP}]
+ >=dev-python/pyparsing-3.0.7[${PYTHON_USEDEP}]
+ >=dev-python/openapi-spec-validator-0.2.8[${PYTHON_USEDEP}]
+ dev-python/pyaml[${PYTHON_USEDEP}]
+ >=dev-python/pyyaml-5.1[${PYTHON_USEDEP}]
+ >=dev-python/python-dateutil-2.1[${PYTHON_USEDEP}]
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+ dev-python/python-jose[${PYTHON_USEDEP}]
+ dev-python/python-sshpubkeys[${PYTHON_USEDEP}]
+ >=dev-python/responses-0.9.0[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.5[${PYTHON_USEDEP}]
+ dev-python/xmltodict[${PYTHON_USEDEP}]
+ dev-python/werkzeug[${PYTHON_USEDEP}]
+ dev-python/zipp[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/freezegun[${PYTHON_USEDEP}]
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
+ dev-python/responses[${PYTHON_USEDEP}]
+ >=dev-python/sure-1.4.11[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # TODO
+ tests/test_firehose/test_firehose_put.py::test_put_record_http_destination
+ tests/test_firehose/test_firehose_put.py::test_put_record_batch_http_destination
+ # broken code (local variable used referenced before definition)
+ tests/test_appsync/test_appsync_schema.py
+ # Needs network (or docker?) but not marked as such, bug #807031
+ # TODO: report upstream
+ tests/test_awslambda/test_lambda_layers_invoked.py::test_invoke_local_lambda_layers
+ tests/test_batch/test_batch_jobs.py::test_cancel_pending_job
+ tests/test_batch/test_batch_jobs.py::test_cancel_running_job
+ tests/test_batch/test_batch_jobs.py::test_container_overrides
+ tests/test_batch/test_batch_jobs.py::test_dependencies
+ tests/test_batch/test_batch_jobs.py::test_failed_dependencies
+ tests/test_batch/test_batch_jobs.py::test_failed_job
+ tests/test_batch/test_batch_jobs.py::test_submit_job_array_size
+ tests/test_batch/test_batch_jobs.py::test_terminate_job
+ tests/test_batch/test_batch_jobs.py::test_terminate_nonexisting_job
+ tests/test_cloudformation/test_cloudformation_custom_resources.py::test_create_custom_lambda_resource__verify_cfnresponse_failed
+
+ tests/test_cloudformation/test_cloudformation_stack_integration.py::test_lambda_function
+ tests/test_core/test_docker.py::test_docker_is_running_and_available
+ tests/test_events/test_events_lambdatriggers_integration.py::test_creating_bucket__invokes_lambda
+ "tests/test_s3/test_s3_lambda_integration.py::test_objectcreated_put__invokes_lambda[match_events0-ObjectCreated:Put]"
+ "tests/test_s3/test_s3_lambda_integration.py::test_objectcreated_put__invokes_lambda[match_events1-ObjectCreated:Put]"
+ "tests/test_s3/test_s3_lambda_integration.py::test_objectcreated_put__invokes_lambda[match_events3-ObjectCreated:Put]"
+ # TODO
+ tests/test_sqs/test_sqs_integration.py::test_invoke_function_from_sqs_queue
+ tests/test_sqs/test_sqs_integration.py::test_invoke_function_from_sqs_fifo_queue
+ # require py_partiql_parser
+ tests/test_s3/test_s3_select.py
+ tests/test_dynamodb/test_dynamodb_statements.py
+ # broken by new urllib3
+ tests/test_moto_api/recorder/test_recorder.py::TestRecorder::test_s3_upload_data
+ tests/test_moto_api/recorder/test_recorder.py::TestRecorder::test_s3_upload_file_using_requests
+ tests/test_s3/test_s3.py::test_upload_from_file_to_presigned_url
+ tests/test_s3/test_s3.py::test_put_chunked_with_v4_signature_in_body
+ tests/test_s3/test_s3.py::test_presigned_put_url_with_approved_headers
+ tests/test_s3/test_s3.py::test_presigned_put_url_with_custom_headers
+ )
+
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ local -x TZ=UTC
+
+ local serial_tests=(
+ # these tests set up credentials that are needed by the tests below
+ tests/test_core/test_importorder.py
+ # these tests apparently rely on some other test setting credentials
+ # up for them, so they need to be run separately, after the above
+ tests/test_lakeformation/test_resource_tags_integration.py
+ tests/test_redshiftdata
+ tests/test_resourcegroupstaggingapi/test_server.py::test_resourcegroupstaggingapi_list
+ tests/test_s3/test_s3.py::test_delete_bucket_cors
+ tests/test_s3/test_s3.py::test_delete_versioned_bucket_returns_metadata
+ tests/test_s3/test_s3_file_handles.py::TestS3FileHandleClosuresUsingMocks
+ tests/test_utilities/test_threaded_server.py::TestThreadedMotoServer::test_server_can_handle_multiple_services
+ )
+
+ epytest "${serial_tests[@]}"
+
+ EPYTEST_DESELECT+=( "${serial_tests[@]}" )
+ epytest -m 'not network' -p xdist -n "$(makeopts_jobs)" --dist=worksteal
+}