summaryrefslogtreecommitdiff
path: root/dev-python/moto
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-06-30 17:36:28 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-06-30 17:36:28 +0100
commit7014a5a3ea0feffab9701fdd6b64cc7667a985af (patch)
treef2cbbaa8bb9209cd15208721103228336149b799 /dev-python/moto
parent7a86906b67693cc65671d3e1476835d3a7e13092 (diff)
gentoo resync : 30.06.2019
Diffstat (limited to 'dev-python/moto')
-rw-r--r--dev-python/moto/Manifest2
-rw-r--r--dev-python/moto/moto-1.3.8-r1.ebuild76
2 files changed, 78 insertions, 0 deletions
diff --git a/dev-python/moto/Manifest b/dev-python/moto/Manifest
index 4dd4f17f3d85..821f2db18fe5 100644
--- a/dev-python/moto/Manifest
+++ b/dev-python/moto/Manifest
@@ -1,5 +1,7 @@
DIST moto-0.4.30.tar.gz 614008 BLAKE2B 2868ab25414e488299cb521ce814239698466d69e806245fd86ceb9d5835d08fa530f2da0a5a16f595a88b3c0e421cc264f361bc68d31841726896826240fbab SHA512 ece27979911f46adbb0aec9aa3755b13c09ced00b24ea136ab9c8a8a992550e9c38dac15d8b0c71822953f070761083253ee5fb5cbe44a4b108d140ab4407699
DIST moto-1.0.1.tar.gz 731617 BLAKE2B 6f20c07c0635a8c10f8f70530aeaac5ed7c2136d4fc87ff57774a95f4d2e1ea8cf1100b9f0871b29138cec9059de5746a9c01104d856f8248edbb648cc4a78e0 SHA512 3171ea3e8f9d267960a7b82caf7e42b86fceba5a80e96d35b849e4e72b7fc6aed94090161219a520f9c1b4050f7de12e0f6c0d560ab1f90ca43fc0387b62d377
+DIST moto-1.3.8.tar.gz 1571716 BLAKE2B 8e79808d8488bcf8c15e8b5a55e93392ceb5f642f1f52c0af441cecb7adfe23a718f6d283e473e5dab82ddd21bcbed36ecb52b444cbd933405d13c8818e4f74d SHA512 901556249a2a28885b7f77e9f2c209b06391efcea66b78ce3c16edec14bcd03b251c37ef5d800d8f7a35180d59ce7568a68bcebf18e25b092eb5de801db6c587
EBUILD moto-0.4.30.ebuild 857 BLAKE2B 444ceb952a989c9464811cfb42f042ec7782fb5492410c5653a9b3772da113f4025f3e983e0565badc061cadfe97f56c11b5b7f224e8aa550eaefa329cc82f20 SHA512 179362a90cc09caea49019df697039b009ee86ea03079f8c148ed226c83397614c6fd5ba1362be252374fa0cc2e028238f0d23a5e96cb37993e638f70a679b41
EBUILD moto-1.0.1-r1.ebuild 1286 BLAKE2B 12e25889b037ebae406b65f3cc482e6a545c5a670ffbcdf4d2810d855f7d4cd474dae4ac6765cc74e5e468eb35c5797b8976ca82583271251e703424dc2b5091 SHA512 dee6ca369ffc4d1703d8c06c849d823550685a540a9de1e540609ae3732994da21f5e92992d1cfc2d48f937bb0c702bd626b00703dafaa0e6d842a3abbd5b461
+EBUILD moto-1.3.8-r1.ebuild 2442 BLAKE2B 3b4215dff97712e2850f1fc1663fe8d01e97a834348e130c58b8fa394d18952494d2f32cc40619ded1d5107281b1a696207b1d403848afb8f9b0ead7c816bbb2 SHA512 bd3ceb59958484697fed08d1134a68ccdbaa19a2dbd96ef496c01b8719f3f66a6f41ca61f865744e5fe5fccecb170d021c6758e9687883ef5182ac8c14e28210
MISC metadata.xml 486 BLAKE2B 5fbd350934c9a51d9b34d57a4031b6180acad41a2f981465b8ce78b76cf2ed25679fc4b5e9af59dab1e27cfe0eff2856419394902bcca26a2ffb7ece199d1838 SHA512 9e69d49c588ebbeef151cee987986de7a942a3daa9bf4d4f442314d7e47bd1ad8650c6190c6313e6f4303c03038313b6562d5e0a32ec536227c04e7702ef316f
diff --git a/dev-python/moto/moto-1.3.8-r1.ebuild b/dev-python/moto/moto-1.3.8-r1.ebuild
new file mode 100644
index 000000000000..85dc90877561
--- /dev/null
+++ b/dev-python/moto/moto-1.3.8-r1.ebuild
@@ -0,0 +1,76 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python2_7 python3_{5,6,7} )
+
+inherit distutils-r1
+
+DESCRIPTION="Mock library for boto"
+HOMEPAGE="https://github.com/spulec/moto"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ >=dev-python/aws-xray-sdk-python-0.93[${PYTHON_USEDEP}]
+ dev-python/backports-tempfile[${PYTHON_USEDEP}]
+ dev-python/cfn-python-lint[${PYTHON_USEDEP}]
+ >=dev-python/cryptography-2.3.0[${PYTHON_USEDEP}]
+ dev-python/cookies[${PYTHON_USEDEP}]
+ dev-python/dicttoxml[${PYTHON_USEDEP}]
+ >=dev-python/docker-py-2.5.1[${PYTHON_USEDEP}]
+ >=dev-python/idna-2.5[${PYTHON_USEDEP}]
+ >=dev-python/jinja-2.10.1[${PYTHON_USEDEP}]
+ >=dev-python/jsondiff-1.1.2[${PYTHON_USEDEP}]
+ >=dev-python/boto-2.36.0[${PYTHON_USEDEP}]
+ >=dev-python/boto3-1.9.86[${PYTHON_USEDEP}]
+ >=dev-python/botocore-1.12.86[${PYTHON_USEDEP}]
+ dev-python/flask[${PYTHON_USEDEP}]
+ dev-python/pretty-yaml[${PYTHON_USEDEP}]
+ >=dev-python/python-dateutil-2.1[${PYTHON_USEDEP}]
+ dev-python/pytz[${PYTHON_USEDEP}]
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+ dev-python/python-jose[${PYTHON_USEDEP}]
+ >=dev-python/responses-0.9.0[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.5[${PYTHON_USEDEP}]
+ dev-python/xmltodict[${PYTHON_USEDEP}]
+ >=dev-python/six-1.9[${PYTHON_USEDEP}]
+ dev-python/werkzeug[${PYTHON_USEDEP}]
+"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( ${RDEPEND}
+ dev-python/freezegun[${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/nose[${PYTHON_USEDEP}]
+ dev-python/responses[${PYTHON_USEDEP}]
+ >=dev-python/sure-1.4.11[${PYTHON_USEDEP}]
+ )
+"
+
+python_prepare_all() {
+ sed -e 's|==|>=|' \
+ -i setup.py moto.egg-info/requires.txt || die
+
+ # Disable tests that fail with network-sandbox.
+ sed -e 's|^\(def \)\(test_context_manager()\)|\1_\2|' \
+ -e 's|^\(def \)\(test_decorator_start_and_stop()\)|\1_\2|' \
+ -i tests/test_core/test_decorator_calls.py || die
+
+ # Disable tests that fail with userpriv.
+ sed -e 's|^\(def \)\(test_invoke_function_from_sns()\)|\1_\2|' \
+ -e 's|^\(def \)\(test_invoke_requestresponse_function()\)|\1_\2|' \
+ -i tests/test_awslambda/test_lambda.py || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ PYTHONPATH=${BUILDDIR}/lib \
+ nosetests -sv ./tests || die
+}