summaryrefslogtreecommitdiff
path: root/dev-python/moviepy
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-python/moviepy
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-python/moviepy')
-rw-r--r--dev-python/moviepy/Manifest3
-rw-r--r--dev-python/moviepy/metadata.xml21
-rw-r--r--dev-python/moviepy/moviepy-0.2.2.ebuild38
3 files changed, 62 insertions, 0 deletions
diff --git a/dev-python/moviepy/Manifest b/dev-python/moviepy/Manifest
new file mode 100644
index 000000000000..c2153ce97cd4
--- /dev/null
+++ b/dev-python/moviepy/Manifest
@@ -0,0 +1,3 @@
+DIST moviepy-0.2.2.tar.gz 400489 BLAKE2B 46cbf9fa6b2800dfa7c315c572448c7ba12ab4629dc5d57590ed70d40d83acabe1b140c193f04c990bbe79aa6ac5e7a6ec662e5862e01ccf41c80ce7f159bdc0 SHA512 a4300b31552e8b4120448b8973ce812579b4f38be48fb46546f4a33e9c10903fb73a89c8075d161d441ecf084b3936ef7d6f0d1b637ad347d00db2c643f1cc43
+EBUILD moviepy-0.2.2.ebuild 905 BLAKE2B f1c3d4bc8d3ab0463fc4fd6c9b805dbd4d5fff45eeca9cf3ed529aede2e85ae8ed288349bd79bc2669a611dc87f82683f1d525df861cf9596a7a111a7b213045 SHA512 9c72d0fff6577f1f225c035cb4f629cbc6d6fe9e3e908f4e99092b5797b465a094e2be3c9d1648ede6d9aefc5312d1590838178ea98a3c12c9c1b05b6eca8c83
+MISC metadata.xml 732 BLAKE2B 7366dd5078337dd825a1612310d068dc3be9ab38c6a9741038fe4af3ba60a19420d67e6bb5a24c0548a6e9bf8cdf257147735d16a5fb1d2195099e079f1d1d3d SHA512 46bce08e60a3a53dcdd6a6fad0ba31c3d11b5c7a4995ac830a31a1e7f0d2ccf458d1c9d1e45ebf80365675cec5d313a6cc58c9b6ce7083daa14483f2832fa630
diff --git a/dev-python/moviepy/metadata.xml b/dev-python/moviepy/metadata.xml
new file mode 100644
index 000000000000..c59c71875d2f
--- /dev/null
+++ b/dev-python/moviepy/metadata.xml
@@ -0,0 +1,21 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>horea.christ@gmail.com</email>
+ <name>Horea Christian</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <longdescription lang="en">
+ MoviePy is a Python module for video editing: cuts, concatenations,
+ title insertions, video compositing (a.k.a. non-linear editing),
+ video processing, and creation of custom effects. See the gallery
+ for some examples of use.
+ </longdescription>
+ <upstream>
+ <remote-id type="github">Zulko/moviepy</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/moviepy/moviepy-0.2.2.ebuild b/dev-python/moviepy/moviepy-0.2.2.ebuild
new file mode 100644
index 000000000000..4df793e65d42
--- /dev/null
+++ b/dev-python/moviepy/moviepy-0.2.2.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
+PYTHON_REQ_USE="threads(+)"
+
+inherit distutils-r1
+
+DESCRIPTION="Video editing with Python"
+HOMEPAGE="http://zulko.github.io/moviepy/"
+SRC_URI="https://github.com/Zulko/moviepy/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/pytest[${PYTHON_USEDEP}] )
+ "
+RDEPEND="
+ dev-python/decorator[${PYTHON_USEDEP}]
+ dev-python/imageio[${PYTHON_USEDEP}]
+ dev-python/matplotlib[${PYTHON_USEDEP}]
+ dev-python/numpy[${PYTHON_USEDEP}]
+ dev-python/pygame[${PYTHON_USEDEP}]
+ dev-python/tqdm[${PYTHON_USEDEP}]
+ dev-python/urllib3[${PYTHON_USEDEP}]
+ sci-libs/scipy[${PYTHON_USEDEP}]
+ virtual/ffmpeg
+ "
+
+python_test() {
+ py.test --verbose || die
+}