summaryrefslogtreecommitdiff
path: root/dev-python/mpi4py
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-02-17 08:06:58 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-02-17 08:06:58 +0000
commit29394d0921808a94a409f01eff49f681651de5d5 (patch)
tree93d18027cb4ea68a3c967602c5793af032180bab /dev-python/mpi4py
parent5987fa693ef880163ebde423615a177cb5bda20e (diff)
gentoo auto-resync : 17:02:2023 - 08:06:58
Diffstat (limited to 'dev-python/mpi4py')
-rw-r--r--dev-python/mpi4py/Manifest2
-rw-r--r--dev-python/mpi4py/mpi4py-3.1.3.ebuild62
2 files changed, 0 insertions, 64 deletions
diff --git a/dev-python/mpi4py/Manifest b/dev-python/mpi4py/Manifest
index daeba628f11e..6b3fc1e7884e 100644
--- a/dev-python/mpi4py/Manifest
+++ b/dev-python/mpi4py/Manifest
@@ -1,5 +1,3 @@
-DIST mpi4py-3.1.3.tar.gz 2461368 BLAKE2B 3ff7f6519a1ee96249567b1c65401fd1242c433bbb0a55c9d0a9b07f167ec44c71aefc24ac5fb354ceeb591dbfe97a4306f8455bb00559789367e91b78d80c16 SHA512 7a15224692016253120e8e88be1f7201e6f4548c1fb5ed15f04f416000b0d9e259dd8e80c0e237b1a960143e52b4a840d2a541359833387ac12868af1c059cea
DIST mpi4py-3.1.4.tar.gz 2493282 BLAKE2B e1a048e6053263f6685c549e2e6f96072b7d95db68595c8848d0ecdb0a6cadf2b102e4c4ce589053ed17a090335afc56f4b3630b60944aeac7e4bc4ad82d4a1b SHA512 f59ad765bc272f8b63f74cfde4e588f640c4fc3d47d05729509da45a2155f830c1d409ec716ff374756748fa8ebfa6e72f9fbe188a6b89ea3fa115740a532b08
-EBUILD mpi4py-3.1.3.ebuild 1560 BLAKE2B 1d98e087ecc0b5a8814c2f9d7d1a9dfbd2fe783c2508aa7f8a720811744f826aff9ce27ee0da4272fe2c297aa880bf5556fe7939fe8684a937e53a30b7adc31f SHA512 a510cacc85e4d84f6d0fd4bc329e9214b1b171f40c3dbb30e5dba7646437d17a5f6164d203a20f82c907858bd5a85b9ca8865ed569e21c15695823fa17f0186a
EBUILD mpi4py-3.1.4.ebuild 1560 BLAKE2B 959cf5b577b5ae45b21c4962ae0c6e27bccf1a2fc49b3af3262d481a61e6afaa16f9470a75ddc7d20cfdc78aaf46153c76ef8c6c97f6552042537369a1bf18d9 SHA512 4e902aefa6768404347dbe5b395fc72fee9745632e0ede5493f930c12c84889b13e82bb685731914a0a2980b41f68714355fb7f2a0604bb38d66bdedcb33a2a3
MISC metadata.xml 1229 BLAKE2B 1634ae0e35f9b9362e9b4eaf21443a1fe6c7fc54ec6e4cc5914695533a3563586371cde7b48e34dfcdad6dc5a89f49bec705e434e68353e93e122c272fa163f3 SHA512 d0892adce1d1b5253185a9b539d2dca2a0d4cc96ce7e6e5cfb0507a90fdc88d92d7c74fc6fc93e951872bcfad73d4071b403b7e4269081c55b18789f09b35226
diff --git a/dev-python/mpi4py/mpi4py-3.1.3.ebuild b/dev-python/mpi4py/mpi4py-3.1.3.ebuild
deleted file mode 100644
index bcc5f7cfbd44..000000000000
--- a/dev-python/mpi4py/mpi4py-3.1.3.ebuild
+++ /dev/null
@@ -1,62 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-PYTHON_COMPAT=( python3_{9..10} )
-inherit distutils-r1
-
-DESCRIPTION="Message Passing Interface for Python"
-HOMEPAGE="https://github.com/mpi4py/mpi4py https://pypi.org/project/mpi4py/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="amd64 ~arm ~riscv x86 ~amd64-linux ~x86-linux"
-IUSE="doc examples test"
-
-RESTRICT="!test? ( test )"
-
-RDEPEND="
- dev-python/cython[${PYTHON_USEDEP}]
- dev-python/numpy[${PYTHON_USEDEP}]
- virtual/mpi
-"
-DEPEND="${RDEPEND}
- test? (
- virtual/mpi[romio]
- )
-"
-
-DISTUTILS_IN_SOURCE_BUILD=1
-
-python_prepare_all() {
- # not needed on install
- rm -vr docs/source || die
- rm test/test_pickle.py || die # disabled by Gentoo-bug #659348
- distutils-r1_python_prepare_all
-}
-
-src_compile() {
- export FAKEROOTKEY=1
- distutils-r1_src_compile
-}
-
-python_test() {
- echo "Beginning test phase"
- pushd "${BUILD_DIR}"/../ &> /dev/null || die
- # spawn is not stable in OpenMPI 4
- # https://github.com/jsquyres/ompi/pull/4#issuecomment-806897758
- # oob_tcp_if_include lo is needed to allow test in systemd-nspawn container
- mpiexec --use-hwthread-cpus --mca btl tcp,self --mca oob_tcp_if_include lo \
- -n 1 "${PYTHON}" -B ./test/runtests.py -v \
- --exclude="test_msgspec" --exclude="test_spawn" ||
- die "Testsuite failed under ${EPYTHON}"
- popd &> /dev/null || die
-}
-
-python_install_all() {
- use doc && local HTML_DOCS=( docs/. )
- use examples && local DOCS=( demo )
- distutils-r1_python_install_all
-}