summaryrefslogtreecommitdiff
path: root/dev-python/mpi4py
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-01-06 18:11:38 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-01-06 18:11:38 +0000
commit6c0d1528e3598898fd1026a3da35ffede0a1f14a (patch)
treed5ab9d7f6d2b41d05fb156069ee81e9ed779f12b /dev-python/mpi4py
parent29efd7db303b443e103311cc0e458ee5c134e8e5 (diff)
gentoo auto-resync : 06:01:2023 - 18:11:38
Diffstat (limited to 'dev-python/mpi4py')
-rw-r--r--dev-python/mpi4py/Manifest4
-rw-r--r--dev-python/mpi4py/mpi4py-3.1.3.ebuild3
-rw-r--r--dev-python/mpi4py/mpi4py-3.1.4.ebuild62
3 files changed, 66 insertions, 3 deletions
diff --git a/dev-python/mpi4py/Manifest b/dev-python/mpi4py/Manifest
index 427333f64e7b..8a17052a89b8 100644
--- a/dev-python/mpi4py/Manifest
+++ b/dev-python/mpi4py/Manifest
@@ -1,3 +1,5 @@
DIST mpi4py-3.1.3.tar.gz 2461368 BLAKE2B 3ff7f6519a1ee96249567b1c65401fd1242c433bbb0a55c9d0a9b07f167ec44c71aefc24ac5fb354ceeb591dbfe97a4306f8455bb00559789367e91b78d80c16 SHA512 7a15224692016253120e8e88be1f7201e6f4548c1fb5ed15f04f416000b0d9e259dd8e80c0e237b1a960143e52b4a840d2a541359833387ac12868af1c059cea
-EBUILD mpi4py-3.1.3.ebuild 1596 BLAKE2B 6b763755f484b58b6959482890ded6892000692924b4aece0f9b55ef5001aa72b18ef6e0dbcd04021bb552bafeccf4e2891bcb67e733a91a0b82860b4db2cf76 SHA512 6fcfd5682dc74e6bf65b9b3169618e1a4e252ec0254c495514bad1ff7fe07f5bd1faafdd2ce8cfc06d78d0daf26569e2bb568fc96de9fa27d38b09ab19fbdb5d
+DIST mpi4py-3.1.4.tar.gz 2493282 BLAKE2B e1a048e6053263f6685c549e2e6f96072b7d95db68595c8848d0ecdb0a6cadf2b102e4c4ce589053ed17a090335afc56f4b3630b60944aeac7e4bc4ad82d4a1b SHA512 f59ad765bc272f8b63f74cfde4e588f640c4fc3d47d05729509da45a2155f830c1d409ec716ff374756748fa8ebfa6e72f9fbe188a6b89ea3fa115740a532b08
+EBUILD mpi4py-3.1.3.ebuild 1560 BLAKE2B 4b81e7c5a4d5dd8587d599b0fdd1c32aa81a85605a5b8cb05a8e77c5b1202a6c70f4a177d41c5958fbedc770339e5df5958cae32f852ce406eb512879e0b0f7b SHA512 5e74f4764273b6070af8c3a5e1df1e47d5c99eb6096ef99360f64d95e62233ad8ba15c113c108f6e02c4f294d81a25d537733918fcd0cbadf83890871df4bf16
+EBUILD mpi4py-3.1.4.ebuild 1562 BLAKE2B bdf364c84d19f89b4cfe5aa49922b1c6d40e88cdde50e14073893458ff6eec02eb7778f0234b33b7efa39259bae02f5828518e9f861bbc05c71c30bcc5bb494d SHA512 fc4efe627bca2f9edfe2c649628be1829447b981814aa0aed2f6f65248137d173e97828615e963e6ae786af305d2067510672c06ee891410780666f63ccbdcac
MISC metadata.xml 1229 BLAKE2B 1634ae0e35f9b9362e9b4eaf21443a1fe6c7fc54ec6e4cc5914695533a3563586371cde7b48e34dfcdad6dc5a89f49bec705e434e68353e93e122c272fa163f3 SHA512 d0892adce1d1b5253185a9b539d2dca2a0d4cc96ce7e6e5cfb0507a90fdc88d92d7c74fc6fc93e951872bcfad73d4071b403b7e4269081c55b18789f09b35226
diff --git a/dev-python/mpi4py/mpi4py-3.1.3.ebuild b/dev-python/mpi4py/mpi4py-3.1.3.ebuild
index c1d94939330e..7da1ef7e8f65 100644
--- a/dev-python/mpi4py/mpi4py-3.1.3.ebuild
+++ b/dev-python/mpi4py/mpi4py-3.1.3.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -24,7 +24,6 @@ RDEPEND="
"
DEPEND="${RDEPEND}
test? (
- dev-python/nose[${PYTHON_USEDEP}]
virtual/mpi[romio]
)
"
diff --git a/dev-python/mpi4py/mpi4py-3.1.4.ebuild b/dev-python/mpi4py/mpi4py-3.1.4.ebuild
new file mode 100644
index 000000000000..85ed88fe6299
--- /dev/null
+++ b/dev-python/mpi4py/mpi4py-3.1.4.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..11} )
+inherit distutils-r1
+
+DESCRIPTION="Message Passing Interface for Python"
+HOMEPAGE="https://github.com/mpi4py/mpi4py https://pypi.org/project/mpi4py/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~riscv ~x86 ~amd64-linux ~x86-linux"
+IUSE="doc examples test"
+
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ dev-python/cython[${PYTHON_USEDEP}]
+ dev-python/numpy[${PYTHON_USEDEP}]
+ virtual/mpi
+"
+DEPEND="${RDEPEND}
+ test? (
+ virtual/mpi[romio]
+ )
+"
+
+DISTUTILS_IN_SOURCE_BUILD=1
+
+python_prepare_all() {
+ # not needed on install
+ rm -vr docs/source || die
+ rm test/test_pickle.py || die # disabled by Gentoo-bug #659348
+ distutils-r1_python_prepare_all
+}
+
+src_compile() {
+ export FAKEROOTKEY=1
+ distutils-r1_src_compile
+}
+
+python_test() {
+ echo "Beginning test phase"
+ pushd "${BUILD_DIR}"/../ &> /dev/null || die
+ # spawn is not stable in OpenMPI 4
+ # https://github.com/jsquyres/ompi/pull/4#issuecomment-806897758
+ # oob_tcp_if_include lo is needed to allow test in systemd-nspawn container
+ mpiexec --use-hwthread-cpus --mca btl tcp,self --mca oob_tcp_if_include lo \
+ -n 1 "${PYTHON}" -B ./test/runtests.py -v \
+ --exclude="test_msgspec" --exclude="test_spawn" ||
+ die "Testsuite failed under ${EPYTHON}"
+ popd &> /dev/null || die
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( docs/. )
+ use examples && local DOCS=( demo )
+ distutils-r1_python_install_all
+}