summaryrefslogtreecommitdiff
path: root/dev-python/mpi4py
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-python/mpi4py
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-python/mpi4py')
-rw-r--r--dev-python/mpi4py/Manifest5
-rw-r--r--dev-python/mpi4py/metadata.xml24
-rw-r--r--dev-python/mpi4py/mpi4py-2.0.0.ebuild47
-rw-r--r--dev-python/mpi4py/mpi4py-3.0.0.ebuild47
4 files changed, 123 insertions, 0 deletions
diff --git a/dev-python/mpi4py/Manifest b/dev-python/mpi4py/Manifest
new file mode 100644
index 000000000000..d698fde7f867
--- /dev/null
+++ b/dev-python/mpi4py/Manifest
@@ -0,0 +1,5 @@
+DIST mpi4py-2.0.0.tar.gz 1279957 BLAKE2B ad75492ec09edbf6663a8962bcb4592c076ef47cdf8a9c14275077dea0abf4ce01f928d03eec80941fec37941c2ba99287263b71436baf7ed755a84cca2ea983 SHA512 6459b482db782fea1a80499774ebfeb09c828b6c3f1805a0ca306f26f3ebcac52ad1c83bb97a98a01b518b6a6c887f6b99dbda9c37381a5ce05ddff0edb16d81
+DIST mpi4py-3.0.0.tar.gz 1426843 BLAKE2B a68182c6abebac6af73654f04db9eba38f020793a9f6d0f98a5e4a483b0531e44aca3c853c20572123cc02331350bf98f8405ddd12b77e79de732f714437da9f SHA512 29ce8b7fd187aadd0bf8e1928ed00cac3e898ff82432b7a95984a248559b0d580c5af418b1986d83b17ad2cf8cbb45135afacf290ba4d9b75a62b03e9ca08e16
+EBUILD mpi4py-2.0.0.ebuild 1119 BLAKE2B 72c47630cf3146b4593ddb2efd58064e8b2cb846265ca40e8f742fe8c1cf9eaa7193f47cee57e996fa39e0c79dc9117c6d10c9b60413120cf57c1e2f0e245286 SHA512 c1638aa10b6281ac2f97e46178852abed44b664bd7fc396845a9b902b8339d8819e09137288e54914b9f7a475558f58c2914dde05cb655817b9f7c30ccd1e9b0
+EBUILD mpi4py-3.0.0.ebuild 1121 BLAKE2B c166c7a0869b4d4552969e0512b340c01a7604c07c22764bf6033dbfed3b5bc100a58530911bde5c370bb55aa425dcfc21523d1f5a42ea27b6644dd3ae2031df SHA512 fd1a1e2009960d98d155eb32247ddbadc38d878c3940ba00c5c39f47ea9760b0728772688d8a02e6722944a72d0bd33e3f4785c854c494fb579a0ae448390f6d
+MISC metadata.xml 1118 BLAKE2B 0bc626a2106e628d7eb639e6ce90c4badb63ec2ea66b0322e7b83418791b7edc4bd443294fba3d31133812416eb4428b5dc47d074da3aeebf6867e8a0998d046 SHA512 7afb6d05007036bf5562d6d262165d8c2576bb49a86f9230f939d6a2ef929affa8461fa6421ffd8d97203a4425b397a8dd8556190364f29622e53a67674978c7
diff --git a/dev-python/mpi4py/metadata.xml b/dev-python/mpi4py/metadata.xml
new file mode 100644
index 000000000000..a7842f1c7b32
--- /dev/null
+++ b/dev-python/mpi4py/metadata.xml
@@ -0,0 +1,24 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+ <longdescription lang="en">MPI for Python (mpi4py) provides bindings of the Message Passing
+ Interface (MPI) standard for the Python programming language,
+ allowing any Python program to exploit multiple processors.
+ This package is constructed on top of the MPI-1/MPI-2 specification
+ and provides an object oriented interface which closely follows
+ MPI-2 C++ bindings. It supports point-to-point (sends, receives) and
+ collective (broadcasts, scatters, gathers) communications of any
+ picklable Python object as well as optimized communications of
+ Python object exposing the single-segment buffer interface (NumPy
+ arrays, builtin bytes/string/array objects).
+ </longdescription>
+ <upstream>
+ <remote-id type="google-code">mpi4py</remote-id>
+ <remote-id type="bitbucket">mpi4py</remote-id>
+ <remote-id type="pypi">mpi4py</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/mpi4py/mpi4py-2.0.0.ebuild b/dev-python/mpi4py/mpi4py-2.0.0.ebuild
new file mode 100644
index 000000000000..ee20e4c6d564
--- /dev/null
+++ b/dev-python/mpi4py/mpi4py-2.0.0.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
+
+inherit distutils-r1
+
+DESCRIPTION="Message Passing Interface for Python"
+HOMEPAGE="https://bitbucket.org/mpi4py/ https://pypi.org/project/mpi4py/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="amd64 ~arm x86 ~amd64-linux ~x86-linux"
+IUSE="doc examples test"
+
+RDEPEND="virtual/mpi"
+DEPEND="${RDEPEND}
+ test? ( dev-python/nose[${PYTHON_USEDEP}]
+ virtual/mpi[romio] )"
+DISTUTILS_IN_SOURCE_BUILD=1
+
+python_prepare_all() {
+ # not needed on install
+ rm -vr docs/source || die
+ distutils-r1_python_prepare_all
+}
+
+src_compile() {
+ export FAKEROOTKEY=1
+ distutils-r1_src_compile
+}
+
+python_test() {
+ echo "Beginning test phase"
+ pushd "${BUILD_DIR}"/../ &> /dev/null || die
+ mpiexec -n 2 "${PYTHON}" ./test/runtests.py -v || die "Testsuite failed under ${EPYTHON}"
+ popd &> /dev/null || die
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( docs/. )
+ use examples && local DOCS=( demo )
+ distutils-r1_python_install_all
+}
diff --git a/dev-python/mpi4py/mpi4py-3.0.0.ebuild b/dev-python/mpi4py/mpi4py-3.0.0.ebuild
new file mode 100644
index 000000000000..f4eebf6042af
--- /dev/null
+++ b/dev-python/mpi4py/mpi4py-3.0.0.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
+
+inherit distutils-r1
+
+DESCRIPTION="Message Passing Interface for Python"
+HOMEPAGE="https://bitbucket.org/mpi4py/ https://pypi.org/project/mpi4py/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86 ~amd64-linux ~x86-linux"
+IUSE="doc examples test"
+
+RDEPEND="virtual/mpi"
+DEPEND="${RDEPEND}
+ test? ( dev-python/nose[${PYTHON_USEDEP}]
+ virtual/mpi[romio] )"
+DISTUTILS_IN_SOURCE_BUILD=1
+
+python_prepare_all() {
+ # not needed on install
+ rm -vr docs/source || die
+ distutils-r1_python_prepare_all
+}
+
+src_compile() {
+ export FAKEROOTKEY=1
+ distutils-r1_src_compile
+}
+
+python_test() {
+ echo "Beginning test phase"
+ pushd "${BUILD_DIR}"/../ &> /dev/null || die
+ mpiexec -n 2 "${PYTHON}" ./test/runtests.py -v || die "Testsuite failed under ${EPYTHON}"
+ popd &> /dev/null || die
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( docs/. )
+ use examples && local DOCS=( demo )
+ distutils-r1_python_install_all
+}