summaryrefslogtreecommitdiff
path: root/dev-python/mpmath
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-10-10 04:03:58 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-10-10 04:03:58 +0100
commit3aae425b3c39d02e2dc917db0fae8c225c158ca1 (patch)
tree89f296451fba2217a7c18592ecb1762a920dead7 /dev-python/mpmath
parent6ee17dd82a3bcd0e90af4ebfbb3e411d342761be (diff)
gentoo auto-resync : 10:10:2024 - 04:03:57
Diffstat (limited to 'dev-python/mpmath')
-rw-r--r--dev-python/mpmath/Manifest2
-rw-r--r--dev-python/mpmath/mpmath-1.4.0_alpha2.ebuild74
2 files changed, 76 insertions, 0 deletions
diff --git a/dev-python/mpmath/Manifest b/dev-python/mpmath/Manifest
index 0a97e00be229..549b9b9fcc02 100644
--- a/dev-python/mpmath/Manifest
+++ b/dev-python/mpmath/Manifest
@@ -1,5 +1,7 @@
DIST mpmath-1.3.0.tar.gz 508106 BLAKE2B 9d4eebbbb6788dd3ee45c8c30068ef3512043dd09ab626cbaf69b0f6bdf057a6e8c53c34e3dda7627db923f0d536a0bebf83916d8942f4dde9546bb8e0046f33 SHA512 a68028150095d743eae9669a0f70cbe6b7bcb4d27dfad6b1a96575f0885ec7306459a2a464117bab18779883ee8b4293502b4bd0ebd8672767e1d08d38f8b202
DIST mpmath-1.4.0a1.tar.gz 2063946 BLAKE2B 0c6a86b1c8dc9addc3eb82586d4c4182ae6a9318cbe45d4fc699b9fbf9539774ae30f11c2d50137a3aa16ed4b0c328990483c2ceea812f86751cfa3ce419de5c SHA512 260afb20faaa949b89054ced3b039e346086d47c6ea018c8d226a0c42d9aa8f792611fe709c894a0df6930a0703dc8cfcf814432eba7ac977a821effd8879903
+DIST mpmath-1.4.0a2.tar.gz 2079112 BLAKE2B 9d2d99dddd4e800b3860f38ef1955b7d803c928d54a7e5d7b07386a127c5a6477818e3ac5c9f679f596c7a2c21bbf430f0bb2348c70ab77d6a888cfb19c6a218 SHA512 523775f3e7d96fd9e0d2c5e4caf855f62d0b683ac00df9dce4fd50d8764bfcf77282fdb34afb51bc53bb303178e7f0e8b6d72700e530d3ca11e3d365b09fc4de
EBUILD mpmath-1.3.0-r1.ebuild 855 BLAKE2B 9a51290a8a128467afe77eff887190deaee0327fc175541d316f6c62aef777567e53c7884342ac6082ad5a9eab7081a75a1c7b4dd3090f6cd2f5efe2f85aafb1 SHA512 21ec5b38e62a62dad3907d3828a29221e93c9d86f5fc6284881a5863f82b499d7f0ed3f488c08b31de274d24220d6280571bafdc0abebac36fd24b2cf2c6a019
EBUILD mpmath-1.4.0_alpha1.ebuild 1768 BLAKE2B bf5fc2fe057652fb6c00eaf8b89289bb58ae268da4aff15b47c458d093a6a5a53f17eaa0e86a31140407ff5505f797a0a7cadcd17e890ce727b29c9d0ec1c9a0 SHA512 a7950ae439c6edf06231508512cfda89bd2a2e3c5a01107210ac9cf108c3add14f4c5ba0ba0b81a017ffef6336bd4824b86551a66d88a65c68a2778a777cc10b
+EBUILD mpmath-1.4.0_alpha2.ebuild 1973 BLAKE2B baa663519c18229737104ebfb01f05eddf7308a770f7370492d26f64a9718689047a51b3cffcea99a5b0303f7a8b242800d53828015eac216be5edcbcca41c7b SHA512 4711c8443d502f092ccf61f69cbc8b61181a998e1e2271adcfb0f1a690a70bd1b169df9a09e5ca976c46371d28c5df611938634f79b5efb6d7c211dcee11c4f4
MISC metadata.xml 624 BLAKE2B 8526d1f6329f8cb4d2ee5a9ae73dc5bf3861adce5beaa6a0aaf5abb918de11ad1ab0c5c206331bd4eaeaa7bdeda0c6ea6a2007492825be0545caa121f41abd6c SHA512 dc4c6f5e82ce735e70bdc1bbfbc01f9c1d62c2d46c54a173287a59b90882aa09945da39bb41e7b28f6d0066851e2adf07f0b7033aa77cc5620491864e89f188e
diff --git a/dev-python/mpmath/mpmath-1.4.0_alpha2.ebuild b/dev-python/mpmath/mpmath-1.4.0_alpha2.ebuild
new file mode 100644
index 000000000000..eef610f1e8c6
--- /dev/null
+++ b/dev-python/mpmath/mpmath-1.4.0_alpha2.ebuild
@@ -0,0 +1,74 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( pypy3 python3_{10..13} )
+
+inherit distutils-r1 optfeature pypi
+
+DESCRIPTION="Python library for arbitrary-precision floating-point arithmetic"
+HOMEPAGE="
+ https://mpmath.org/
+ https://github.com/mpmath/mpmath/
+ https://pypi.org/project/mpmath/
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~loong ~mips ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos"
+
+BDEPEND="
+ dev-python/setuptools-scm[${PYTHON_USEDEP}]
+ test? (
+ dev-python/hypothesis[${PYTHON_USEDEP}]
+ dev-python/numpy[${PYTHON_USEDEP}]
+ dev-python/packaging[${PYTHON_USEDEP}]
+ dev-python/pexpect[${PYTHON_USEDEP}]
+ dev-python/pytest-rerunfailures[${PYTHON_USEDEP}]
+ dev-python/pytest-timeout[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ dev-python/gmpy[${PYTHON_USEDEP}]
+ ' 'python3*')
+ !mips? (
+ dev-python/matplotlib[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ dev-python/ipython[${PYTHON_USEDEP}]
+ ' 3.{10..12})
+ )
+ )
+"
+
+EPYTEST_XDIST=1
+distutils_enable_tests pytest
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # TODO
+ mpmath/tests/test_cli.py::test_bare_console_bare_division
+ mpmath/tests/test_cli.py::test_bare_console_no_bare_division
+ mpmath/tests/test_cli.py::test_bare_console_pretty
+ mpmath/tests/test_cli.py::test_bare_console_without_ipython
+ mpmath/tests/test_cli.py::test_bare_console_wrap_floats
+ )
+
+ case ${EPYTHON} in
+ pypy3)
+ EPYTEST_DESELECT+=(
+ # minor whitespace mismatch
+ # https://github.com/mpmath/mpmath/issues/874
+ mpmath/tests/test_format.py::test_mpf_floats_bulk
+ mpmath/tests/test_format.py::test_mpc_complexes
+ )
+ ;;
+ esac
+
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest -p rerunfailures --reruns=5 -p timeout
+}
+
+pkg_postinst() {
+ optfeature "gmp support" dev-python/gmpy
+ optfeature "matplotlib support" dev-python/matplotlib
+}