summaryrefslogtreecommitdiff
path: root/dev-python/mpmath
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-03-07 17:57:54 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-03-07 17:57:54 +0000
commitbc75b42f7650c33ffdb61e5e29b0b96cb9111932 (patch)
tree867908c0cf83e6015a5b1544cfdc4e17f1c13753 /dev-python/mpmath
parentb3fef92e618039dc93153a93176184a49606c74a (diff)
gentoo auto-resync : 07:03:2023 - 17:57:54
Diffstat (limited to 'dev-python/mpmath')
-rw-r--r--dev-python/mpmath/Manifest2
-rw-r--r--dev-python/mpmath/mpmath-1.3.0.ebuild32
2 files changed, 34 insertions, 0 deletions
diff --git a/dev-python/mpmath/Manifest b/dev-python/mpmath/Manifest
index 29b5f845a852..c4e336ff32d1 100644
--- a/dev-python/mpmath/Manifest
+++ b/dev-python/mpmath/Manifest
@@ -1,3 +1,5 @@
DIST mpmath-1.2.1.tar.gz 2135690 BLAKE2B a21e0ef04a025f23e32dad5839db411708266c6cf3408e97ec5c995f197b14f446c1d328bd2e9f50e1c48a2e08239ef7908fcc3aab8659118fc1e0e78106a47e SHA512 2dd908bca26162adcdce0493146d009e04d3d96db965ff2207c332504020fa6f5a5e2af97d38e8fb3e7442a26c1e93a756a8d93b378da720ab7c07753f700d10
+DIST mpmath-1.3.0.tar.gz 2136844 BLAKE2B 42b121896e1bcffe459ac5591a4e0ec41fdd708d5518b1a76bf4cc434f34e5801d77207ea9769d11b6746340aa32a84b58e089c81b5163b48a80ccc6ecd0a345 SHA512 ec703e661323035e3c973fc2e52206e793f6182ed9897e5a483cb35a22421d7869df850cdd89fc1ef4e1bb28b17b4914447116dbeed136a687e582cce0bf9e42
EBUILD mpmath-1.2.1.ebuild 959 BLAKE2B a044500435ec937b16101674f10b3f84f44da60c9d86b03b4592b68cd3475c92d83f5b25f5e655cccd28f02b57a5df701d72f3d08d1ef91d241253d3c2813f6c SHA512 4c7e7ce6bffdb4f62d627c11d3ef95018aa1f44d6d95814dcbcf985e5839a6f5f98b2025b28428e2d507053044465329c1f6a3c2da880df62163479bce81a884
+EBUILD mpmath-1.3.0.ebuild 843 BLAKE2B d7637f54834dbbd2c687270ae76903286fece5d23bae8e8f27960646f837f9c9665c84d7dd66a1ef8ea4b9a6561e4263d3862a57eeb354f8007038b0a661f5f8 SHA512 ddad39adf27783eae436db89852d2012e5e9f0ed6796d5bf7d1a768ec08e668b6859f6d03343fca6bfe36d15d2f8a90af8ce1c80a82b861a3925b22a2bd62051
MISC metadata.xml 732 BLAKE2B ea477c6ec344dd4d81872b771fda360f78739c0853ff45f2b3a32569f5cab76cd73233fbe3380ae19e10da61b172fba6f35db0e55d2b0af788da47167f320871 SHA512 7525d8d88ebcc5063f6c171b825c9d115c3c7223f49be28eae80d00b66e2a281060f28d5fda9c547833f3c0b0f3d2667434acfd52a30fdadb99193afb170769d
diff --git a/dev-python/mpmath/mpmath-1.3.0.ebuild b/dev-python/mpmath/mpmath-1.3.0.ebuild
new file mode 100644
index 000000000000..ddc293e2387e
--- /dev/null
+++ b/dev-python/mpmath/mpmath-1.3.0.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} )
+inherit distutils-r1 virtualx
+
+DESCRIPTION="Python library for arbitrary-precision floating-point arithmetic"
+HOMEPAGE="https://mpmath.org/"
+SRC_URI="https://github.com/fredrik-johansson/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~riscv ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos"
+IUSE="gmp matplotlib"
+
+RDEPEND="
+ gmp? ( dev-python/gmpy[${PYTHON_USEDEP}] )
+ matplotlib? ( dev-python/matplotlib[${PYTHON_USEDEP}] )
+"
+
+distutils_enable_tests pytest
+
+src_test() {
+ virtx distutils-r1_src_test
+}
+
+python_test() {
+ "${EPYTHON}" mpmath/tests/runtests.py -local || die "Tests failed with ${EPYTHON}"
+}