summaryrefslogtreecommitdiff
path: root/dev-python/mpmath
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-02-13 21:41:11 +0000
committerV3n3RiX <venerix@redcorelinux.org>2021-02-13 21:41:11 +0000
commitc8d60dada2ec8eb48b2d2b290cd6683ccec40e39 (patch)
treec44943ee0563a3fa957716de909fed683117fcb9 /dev-python/mpmath
parent69051588e2f955485fe5d45d45e616bc60a2de57 (diff)
gentoo (valentine's day) resync : 14.02.2021
Diffstat (limited to 'dev-python/mpmath')
-rw-r--r--dev-python/mpmath/Manifest4
-rw-r--r--dev-python/mpmath/metadata.xml1
-rw-r--r--dev-python/mpmath/mpmath-1.2.1.ebuild40
3 files changed, 44 insertions, 1 deletions
diff --git a/dev-python/mpmath/Manifest b/dev-python/mpmath/Manifest
index 97b4d88d8d14..15f946abd7da 100644
--- a/dev-python/mpmath/Manifest
+++ b/dev-python/mpmath/Manifest
@@ -1,4 +1,6 @@
AUX mpmath-1.0.0.patch 422 BLAKE2B b79a223fb3d6c712a11e225c4f617d68cfda595ad314fb33ba02333eedcf39909f9bf76c98f004619f62cfb4516172615b8e79017362807980b1c61724423543 SHA512 a5c7c8816d7e4ba2dc481480a887d94ca158fee804a01e86f91fcea037372217ed8b029f85f6a0c15558b44aaf56f6fadf36b4f7476713a04a66f18b6f1ab997
DIST mpmath-1.1.0.tar.gz 2136921 BLAKE2B 8c3a5f39b48015aab1147aaf77ee7523dbffd7f34911ff2158d7b8bf1612e64f91d157494c5199b22090e986aba02044d610171bb92a2b230cdfbe025652e340 SHA512 628b6c61015825516d983bfcc54fc3a2793f3d9d2b93ba9c5a487a340ddf13eb4e83f17fa35692b22dd8a200a8da3a65ed88091d75abb4c48c9c4e4f2c686bcc
+DIST mpmath-1.2.1.tar.gz 2135690 BLAKE2B a21e0ef04a025f23e32dad5839db411708266c6cf3408e97ec5c995f197b14f446c1d328bd2e9f50e1c48a2e08239ef7908fcc3aab8659118fc1e0e78106a47e SHA512 2dd908bca26162adcdce0493146d009e04d3d96db965ff2207c332504020fa6f5a5e2af97d38e8fb3e7442a26c1e93a756a8d93b378da720ab7c07753f700d10
EBUILD mpmath-1.1.0.ebuild 1031 BLAKE2B 050b254a31c7e1c05035db520f86ff95b028baa99df08b143731a09dcae6b172e4b0fe9307e8c779f314753248548ed91a8050a32e000982ccb6b53ecefa6381 SHA512 2f483ffce54d352fa7746b7051136fdf645768cc4d0c00c02e98dc602a80265866673ae1c7213945ccd1e3288adf968eeeeb0f5321e7f5ff1a00ec821305e401
-MISC metadata.xml 534 BLAKE2B 19f996d0a1fd717bf099b05dba1c2313dfea37108b412da6ae4efd37f5d982e924f6134a4ea6a5f9e62af33ce52793d7208b31aa993e34ced42b56e0441c7ef4 SHA512 d791c8fd0722872e136f3c9fc222d55d39c5b1ee5f71f1dab0a475c7e39a164e646274c003e97b52111505f0f1d96f973971fbb51965d713c2e60e27b5b37f92
+EBUILD mpmath-1.2.1.ebuild 989 BLAKE2B 2d2ebc833c62002dfe38033f8ca46a498c3e89ab6922b09efc2171d95be130a4d7ee97782672e10dbc59ce0885fc3fcb34a23b9e96f7b2a2a9178191540158cb SHA512 f178b31d5676654e0017cdb87cede1ebd49982bd7d4bb13c8de77064987aa7974f0e8ab4b7f7874a8fd5aa91bd8e216454ff37720e6144b639067b52317cf2fa
+MISC metadata.xml 598 BLAKE2B 56e7cf984af382507983ca0cbc48ef70cf5eb508882509bdb9eedc3698790f662c42e2868bbfafd67efa800c90e6e9fb6294fb0f17a859f8dcd0b6acd7a779ee SHA512 0a70ea57a15514b2686d8c2bc5a96a17045dfb2d27edada2612eaf1a901dac171243c666828979d6e0f532779132580761d9d7859e7883f77a50055c50bef569
diff --git a/dev-python/mpmath/metadata.xml b/dev-python/mpmath/metadata.xml
index c769837f2044..1bb6157b0013 100644
--- a/dev-python/mpmath/metadata.xml
+++ b/dev-python/mpmath/metadata.xml
@@ -14,5 +14,6 @@
</use>
<upstream>
<remote-id type="pypi">mpmath</remote-id>
+ <remote-id type="github">fredrik-johansson/mpmath</remote-id>
</upstream>
</pkgmetadata>
diff --git a/dev-python/mpmath/mpmath-1.2.1.ebuild b/dev-python/mpmath/mpmath-1.2.1.ebuild
new file mode 100644
index 000000000000..ee062f0cf511
--- /dev/null
+++ b/dev-python/mpmath/mpmath-1.2.1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..9} )
+
+inherit distutils-r1 virtualx
+
+DESCRIPTION="Python library for arbitrary-precision floating-point arithmetic"
+HOMEPAGE="https://mpmath.org/"
+SRC_URI="https://github.com/fredrik-johansson/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos"
+IUSE="gmp matplotlib test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ gmp? ( dev-python/gmpy[${PYTHON_USEDEP}] )
+ matplotlib? ( dev-python/matplotlib[${PYTHON_USEDEP}] )"
+BDEPEND="
+ dev-python/setuptools_scm[${PYTHON_USEDEP}]"
+
+distutils_enable_tests pytest
+
+src_configure() {
+ export SETUPTOOLS_SCM_PRETEND_VERSION=${PV}
+}
+
+src_test() {
+ virtx distutils-r1_src_test
+}
+
+python_test() {
+ pushd ${PN}/tests >/dev/null
+ ${EPYTHON} runtests.py -local || die "Tests failed with ${EPYTHON}"
+ popd >/dev/null
+}