summaryrefslogtreecommitdiff
path: root/dev-python/msgpack
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-03-09 12:02:14 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-03-09 12:02:14 +0000
commit0fd62365fc104d7e6d5f3ef67800df09225a4019 (patch)
tree163b4a5055e07325ae1dc4f9bbbc2021ca1b6afa /dev-python/msgpack
parent442eaf1780a48ddbd7a39f5a3f34d959c3c6d27e (diff)
gentoo auto-resync : 09:03:2023 - 12:02:14
Diffstat (limited to 'dev-python/msgpack')
-rw-r--r--dev-python/msgpack/Manifest2
-rw-r--r--dev-python/msgpack/msgpack-1.0.5.ebuild43
2 files changed, 45 insertions, 0 deletions
diff --git a/dev-python/msgpack/Manifest b/dev-python/msgpack/Manifest
index ac458d9da261..33d81e82c113 100644
--- a/dev-python/msgpack/Manifest
+++ b/dev-python/msgpack/Manifest
@@ -1,3 +1,5 @@
DIST msgpack-1.0.4.tar.gz 128053 BLAKE2B fcbaafbea57f87c949a43a6bd6f6507eb3a07ac5e4a9c44fabfbb7c07849f1edabb8dadcd99a547fed32bce0f900f965368c4ee744acd4e850cad5c27022f463 SHA512 dcd59bf77408acf7171bdcc46c4d6bf875d36e80b216b7721544855e6c2b20be469415ee768b2195e74fe4650621ee6bfaa7897e709ac0d8d59cdb30772cb90b
+DIST msgpack-1.0.5.tar.gz 127834 BLAKE2B 3dcf454630021e35d5c6d5ce850d7ac74a6d11d6fe7c7ed07040daa62585bd6b11dc0f68a5b4c4bf20346c25bc23017f79f2d1bad09f175008b184461d0eea5d SHA512 bc3bf27ca7a9204c5ebc009e4a03db4fb48f6c2733bef393aed16652f07ac92c9400258818743245598343c86494d39b39017ab70d7563a5844091eca11a9faa
EBUILD msgpack-1.0.4.ebuild 1023 BLAKE2B 02ac41c76f53982fbabb4c672903e69ddd1b8384554db7f89f327387d973ce90fffdb1b6073c442b03a304f26f49cda322c92f82e4abbd0bd6786770de915cde SHA512 9bc624dce8555c02e2d4ef8293cc3cc6eb952e095e790450ad1a79635891283ee2b5bdc05d505e1fa8496963241a73a158efeb5932fd35204a60c7a444effa17
+EBUILD msgpack-1.0.5.ebuild 982 BLAKE2B 9ee428dcc90f2277a9ba86c1c0e67ade7b569a11590bddc192a68eb5e8f44c6758e350893c7318c5e2d684b08c167528677abcd94be08a721986e88cd5d0af20 SHA512 0a1cb2de6a8804a9ca8d0e224a6b7e87414ff6c31d2383b79a0d439111c891cd6040b9e6b287c289fa05ece81be45d3fd714e28716d874f2f2410d42599a8c11
MISC metadata.xml 520 BLAKE2B 5facc8e5c11591c6010fe5eef4030e23502b890d15a896ada0c5625e63179887e13206f28695af92b358c56a9f9660767d8b4234c2c8b489cad41fec01af289d SHA512 a62502d0b2ec3da1b21297f4d4e5fee86c206c8d6a2c19d7bffe2a64b4a2fa990edb3ba07bbacccb59ed79efd23fa713a37b8adffa7f0cbc811fc0fa249d9b63
diff --git a/dev-python/msgpack/msgpack-1.0.5.ebuild b/dev-python/msgpack/msgpack-1.0.5.ebuild
new file mode 100644
index 000000000000..b58b4c19500d
--- /dev/null
+++ b/dev-python/msgpack/msgpack-1.0.5.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} pypy3 )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="MessagePack (de)serializer for Python"
+HOMEPAGE="
+ https://msgpack.org/
+ https://github.com/msgpack/msgpack-python/
+ https://pypi.org/project/msgpack/
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~ppc ~ppc64 ~riscv ~sparc ~x86 ~x64-macos"
+IUSE="+native-extensions"
+
+# extension code is relying on CPython implementation details
+BDEPEND="
+ native-extensions? (
+ $(python_gen_cond_dep '
+ >=dev-python/cython-0.29.30[${PYTHON_USEDEP}]
+ ' 'python*')
+ )
+"
+
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ # Remove pre-generated cython files
+ rm msgpack/_cmsgpack.cpp || die
+
+ if ! use native-extensions ; then
+ sed -i -e "/have_cython/s:True:False:" setup.py || die
+ fi
+
+ distutils-r1_python_prepare_all
+}