summaryrefslogtreecommitdiff
path: root/dev-python/multidict
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2025-02-17 00:13:57 +0000
committerV3n3RiX <venerix@koprulu.sector>2025-02-17 00:13:57 +0000
commit27b3683509c5229cce540418778a8b64afbc0009 (patch)
treeb7164898142b8b093b91c8254c4387b6eec679ee /dev-python/multidict
parentf2bdc27fe0f79f8f9a3945eb2b1163ce75c56439 (diff)
gentoo auto-resync : 17:02:2025 - 00:13:57
Diffstat (limited to 'dev-python/multidict')
-rw-r--r--dev-python/multidict/Manifest2
-rw-r--r--dev-python/multidict/multidict-6.1.0.ebuild8
2 files changed, 5 insertions, 5 deletions
diff --git a/dev-python/multidict/Manifest b/dev-python/multidict/Manifest
index a989f83de446..8406558f80b5 100644
--- a/dev-python/multidict/Manifest
+++ b/dev-python/multidict/Manifest
@@ -1,3 +1,3 @@
DIST multidict-6.1.0.gh.tar.gz 73800 BLAKE2B 9e3531633b0a35bbb8a97ec2dfe040080fe67efae3b3a16436b0984d6c3a4dc38df1cf5b91bd7b1f750f7a27bd2726667935fa30eefa7b070534fd70f390ee8a SHA512 48e97f442c28c2dfc0b5e19376ae9c8c46b20939ac4f72c07b650450286156dcbe03166f7d238d7a77b438a154022e9d98a38a4c0596aefab7d40fbdda0687dc
-EBUILD multidict-6.1.0.ebuild 1217 BLAKE2B 4778aac577ac7cf5c802df4083e9eace2cb715e79a7cfdfd182c15358d34e2b61a58b0588bac256f6ef306df60533bc4acb7b5c5bea6a50c2c7334df72f783c5 SHA512 30f3bb8d4e5dac4ceb7046e799dfcc18ef7ac3cbcefdf3aa6430277c41db30e0c9dc78759bd9b8e7fcc4a795e261175b5b0e68332f5d60886615e37f20a2aea6
+EBUILD multidict-6.1.0.ebuild 1228 BLAKE2B 462ad43bd9151cbc4d00eba175393b40db3b744ce4557b618d5fffec82075f0437e2ea831b59a4e5901d416a4fcf3d9ed2a74d0ad47a4cdee2b78c0e9a2d0682 SHA512 24b6780b899f2dbe0c8f613b4e010849ed7fcce61911882ad8abf94e97a86b8a44497e1edbfc5c51a9c6c2e5eec1c553dd56a9911323e31d1a6a55e4919f0fd7
MISC metadata.xml 620 BLAKE2B 7d4dcf63e1d4fdc3725be371b49bf49fc0241e16572cb83de1b8f8e6dd89b070bc723a4f62d14a723179e6e07140e2abd5411db92ed25703c9d31c34864ff4d3 SHA512 6c6abebeda31e025359b8b46840d7220fb8633cf62596da471ab3b8ce8a2f717d6b8f94dc7878a1ebe2b2efe63579ee28ad7283e37af9dd89b59ae03faa32fd2
diff --git a/dev-python/multidict/multidict-6.1.0.ebuild b/dev-python/multidict/multidict-6.1.0.ebuild
index f284c94d6595..42b23a21a785 100644
--- a/dev-python/multidict/multidict-6.1.0.ebuild
+++ b/dev-python/multidict/multidict-6.1.0.ebuild
@@ -1,11 +1,11 @@
-# Copyright 1999-2024 Gentoo Authors
+# Copyright 1999-2025 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
DISTUTILS_EXT=1
DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{10..13} pypy3 )
+PYTHON_COMPAT=( python3_{10..13} pypy3 pypy3_11 )
inherit distutils-r1
@@ -39,7 +39,7 @@ python_prepare_all() {
}
python_compile() {
- if ! use native-extensions || [[ ${EPYTHON} == pypy3 ]]; then
+ if ! use native-extensions || [[ ${EPYTHON} == pypy3* ]]; then
local -x MULTIDICT_NO_EXTENSIONS=1
fi
@@ -50,7 +50,7 @@ python_test() {
rm -rf multidict || die
local cext=--c-extensions
- if ! use native-extensions || [[ ${EPYTHON} == pypy3 ]]; then
+ if ! use native-extensions || [[ ${EPYTHON} == pypy3* ]]; then
cext=--no-c-extensions
fi
epytest "${cext}"