summaryrefslogtreecommitdiff
path: root/dev-python/multipart
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-10-22 04:04:46 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-10-22 04:04:46 +0100
commita15e8dc7444560123d7d4be1bccb19afd5b611d0 (patch)
tree6e26ee0323c09494a66d0f78c4b81e305bb0d096 /dev-python/multipart
parent3dc4de6331223493015f198dc61854af604da86c (diff)
gentoo auto-resync : 22:10:2024 - 04:04:46
Diffstat (limited to 'dev-python/multipart')
-rw-r--r--dev-python/multipart/Manifest3
-rw-r--r--dev-python/multipart/metadata.xml12
-rw-r--r--dev-python/multipart/multipart-1.1.0.ebuild21
3 files changed, 36 insertions, 0 deletions
diff --git a/dev-python/multipart/Manifest b/dev-python/multipart/Manifest
new file mode 100644
index 000000000000..54fabf79f56c
--- /dev/null
+++ b/dev-python/multipart/Manifest
@@ -0,0 +1,3 @@
+DIST multipart-1.1.0.tar.gz 34622 BLAKE2B f4973a80aa7f7979f9882c4689b83b9e557a1b5a2cc4dac3df8bde6b46979b542974762826588a641e9ecd52d6c50e4d804732042762c08c59e6c23a62bdf0b7 SHA512 308b3080b2085315b3d080c976be26df8f9028862c9bea14069ddc3a5aad3b5f60cb75fdd387b943e5f555f6aecfbc865a1e9aa457bf06b9a7f08e13aaaba449
+EBUILD multipart-1.1.0.ebuild 434 BLAKE2B 6ee5131d02deeb3e87e670566b7f9d5a990a11c3e86a91a238be710e8c42aac12baf4f8f78df8e305bfb303ad42146394d999de0c844632360d4c71ce7b92fee SHA512 434bfb037604e1f142a44d03777c1e33702a541bf23fb450102e90b3bfab7accef9e3714d7db45d8e832eeffcf8658cd247c4c91b4c5856523d4cc6508e1f2e1
+MISC metadata.xml 372 BLAKE2B 3a3e9fcf03a4a9b4b2d7d6f3571d4f5a027aaecb6f9c602d3510b09c006414d7c1c64c3299ea5f651aed3e222d89b8de0ba2c0d9ed8317f771c844a164908539 SHA512 4eed94dbe74d4f60ec345b22a3599401c651bdc6630d1f21134bd814e7047505fdf4f39e6256f842689a499b0747afec5630783246158512c8d651eecd71620b
diff --git a/dev-python/multipart/metadata.xml b/dev-python/multipart/metadata.xml
new file mode 100644
index 000000000000..e7b1709ecd59
--- /dev/null
+++ b/dev-python/multipart/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ </maintainer>
+ <stabilize-allarches/>
+ <upstream>
+ <remote-id type="github">defnull/multipart</remote-id>
+ <remote-id type="pypi">multipart</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/multipart/multipart-1.1.0.ebuild b/dev-python/multipart/multipart-1.1.0.ebuild
new file mode 100644
index 000000000000..4509a3ed6b46
--- /dev/null
+++ b/dev-python/multipart/multipart-1.1.0.ebuild
@@ -0,0 +1,21 @@
+# Copyright 2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=flit
+PYTHON_COMPAT=( pypy3 python3_{10..13} python3_13t )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Parser for multipart/form-data"
+HOMEPAGE="
+ https://github.com/defnull/multipart/
+ https://pypi.org/project/multipart/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc64 ~x86"
+
+distutils_enable_tests pytest