summaryrefslogtreecommitdiff
path: root/dev-python/munkres
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-06-13 00:08:30 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-06-13 00:08:30 +0100
commit0ebcd2cbf178600b5eb36b2f24cdbb3d2f4a9000 (patch)
tree941e6ba8c256dd27e9f9ca634f08d4bf0278798e /dev-python/munkres
parentf0ddcad13515f66d2f3bf827d33c277bdba7e1dd (diff)
gentoo auto-resync : 13:06:2024 - 00:08:29
Diffstat (limited to 'dev-python/munkres')
-rw-r--r--dev-python/munkres/Manifest3
-rw-r--r--dev-python/munkres/files/munkres-1.1.4-test-32bit.patch34
-rw-r--r--dev-python/munkres/munkres-1.1.4-r1.ebuild7
3 files changed, 42 insertions, 2 deletions
diff --git a/dev-python/munkres/Manifest b/dev-python/munkres/Manifest
index c9e2c4ddc0fc..c5631da1f9dc 100644
--- a/dev-python/munkres/Manifest
+++ b/dev-python/munkres/Manifest
@@ -1,3 +1,4 @@
+AUX munkres-1.1.4-test-32bit.patch 1252 BLAKE2B 341c56a3f2442f26b4979b066fd03b650a5fa512b87c36c22daa266ef14b8e79444df4b3e118aed8fc293d9a94152bad5447081c49d43b48ee03bf3d19528bcf SHA512 f22f886cda0b924b68afc2b53a08aac0da3a153d7c0295487a94ac72da6913dfc31ea41058da467db5b367db1f1d01495ffea2b9a46b6c3868449295613714bb
DIST munkres-release-1.1.4.gh.tar.gz 13777 BLAKE2B d783ac7a4fd55826ef3ddddd2ba82cf0499727e605a2414491af7dd9080193c53f1e48ed17dba9a462578bc958d3d9e2e1e413408143b4cfd0305f9cb3b6c517 SHA512 24ae7d04f4a6fe52f7bb9dc79bbee3e33425b85813382e2634e106a5d26d2d728ba8d34fab9390b7c3d651bc0e95214dcf9c94ac436636cd5b487a054b5a2c54
-EBUILD munkres-1.1.4-r1.ebuild 648 BLAKE2B 7d2dc322c0d2a57218e59593d31e0f2838f67070a5426ae1a3846c7db067880a4e9174a944b4b0d4ab627bbfa555fb59cab6e55de728f5ea6a6f02e7cd74d565 SHA512 af40a256730a635586c0949e7185f9235bbbef76051b2ea3da68bc60d39ee3ccbfc5eafa397ebfce54fea2ca63396e0be0686d32b777b674c3fbf4aef5e67f16
+EBUILD munkres-1.1.4-r1.ebuild 759 BLAKE2B 5797cfb2f36e642588b4edd79bbcb12be2ee87cbfc0666fe5834b4c12edbb678db4afd2fa936bbcde4e70ddb4882318cf85c894d9e3e6edf33b64b8f7efd08e7 SHA512 0802ea1f97f0fbf40eea5d14d20f03fe39ce101e0674e1d3544201767cd1da642dba0f0f1ed11ded5d95b1eeb2366d70e50f75d929bf37e1c8a6e049eb8d85d0
MISC metadata.xml 772 BLAKE2B 476197b5218d2e1b000c16be048dd1ef56b605a93978468b0fc95500032102497777021803c5b6db546ee433aa4b5d1f02f232384a0e4665cea4d2a5b0cf1230 SHA512 5b433e5ab0c97c69680da925ed03362fdbb40ab74c5d8cb851f5b4c3b66f50f9de066657024b230d4d0d8274c6dd1035502b375581ae595c2032f3537035a8a1
diff --git a/dev-python/munkres/files/munkres-1.1.4-test-32bit.patch b/dev-python/munkres/files/munkres-1.1.4-test-32bit.patch
new file mode 100644
index 000000000000..86159299eed5
--- /dev/null
+++ b/dev-python/munkres/files/munkres-1.1.4-test-32bit.patch
@@ -0,0 +1,34 @@
+From 380a0d593a0569a761c4a035edaa4414c3b4b31d Mon Sep 17 00:00:00 2001
+From: Stefano Rivera <stefano@rivera.za.net>
+Date: Sat, 17 Oct 2020 11:15:04 -0700
+Subject: [PATCH] Use a constant cost calculation in test_profit_float()
+
+Rather than an architecture-specific calculation, when our variable
+precision does not differ across architectures.
+
+Fixes: #40
+---
+ test/test_munkres.py | 6 +++---
+ 1 file changed, 3 insertions(+), 3 deletions(-)
+
+diff --git a/test/test_munkres.py b/test/test_munkres.py
+index 23796dd..3cc65d9 100644
+--- a/test/test_munkres.py
++++ b/test/test_munkres.py
+@@ -162,13 +162,13 @@ def test_profit_float():
+ [37.11, 53.12, 57.13, 78.14, 28.15],
+ [59.16, 43.17, 97.18, 88.19, 48.2],
+ [52.21, 19.22, 89.23, 60.24, 60.25]]
+- import sys
++ max_ = 2**32
+ cost_matrix = munkres.make_cost_matrix(
+- profit_matrix, lambda cost: sys.maxsize - cost
++ profit_matrix, lambda cost: max_ - cost
+ )
+ indices = m.compute(cost_matrix)
+ profit = sum([profit_matrix[row][column] for row, column in indices])
+- assert profit == pytest.approx(362.65)
++ assert profit == pytest.approx(392.65)
+
+ def test_irregular():
+ matrix = [[12, 26, 17],
diff --git a/dev-python/munkres/munkres-1.1.4-r1.ebuild b/dev-python/munkres/munkres-1.1.4-r1.ebuild
index 49df5c915ee2..5ea8d6a555e7 100644
--- a/dev-python/munkres/munkres-1.1.4-r1.ebuild
+++ b/dev-python/munkres/munkres-1.1.4-r1.ebuild
@@ -22,6 +22,11 @@ S=${WORKDIR}/${MY_P}
LICENSE="Apache-2.0"
SLOT="0"
-KEYWORDS="amd64 ~arm ~arm64 ~loong ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+KEYWORDS="~alpha amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
distutils_enable_tests pytest
+
+PATCHES=(
+ # https://github.com/bmc/munkres/pull/41
+ "${FILESDIR}/${P}-test-32bit.patch"
+)