summaryrefslogtreecommitdiff
path: root/dev-python/mysql-connector-python
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-11-28 20:40:51 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-11-28 20:40:51 +0000
commit9c417bacd51da6d8b57fa9f37425161d30d4b95b (patch)
tree47c9d6e4243f39a1f48afd54c969b65b00a5c649 /dev-python/mysql-connector-python
parentd934827bf44b7cfcf6711964418148fa60877668 (diff)
gentoo resync : 28.11.2020
Diffstat (limited to 'dev-python/mysql-connector-python')
-rw-r--r--dev-python/mysql-connector-python/Manifest4
-rw-r--r--dev-python/mysql-connector-python/mysql-connector-python-8.0.21.ebuild53
-rw-r--r--dev-python/mysql-connector-python/mysql-connector-python-8.0.22.ebuild2
3 files changed, 2 insertions, 57 deletions
diff --git a/dev-python/mysql-connector-python/Manifest b/dev-python/mysql-connector-python/Manifest
index 2e14231a8f0d..7a494af189c4 100644
--- a/dev-python/mysql-connector-python/Manifest
+++ b/dev-python/mysql-connector-python/Manifest
@@ -1,5 +1,3 @@
-DIST mysql-connector-python-8.0.21.tar.gz 12069002 BLAKE2B db4e7672f0daace08c88e52560db66629d5eb9d9903b76e616bed7ef4a21d80139a65ac24d47d16f9fa5e978f3acb262292c72933f0c348d9494cd51f96f1654 SHA512 d73efd99774450bbf729ddbb19b80d09b8db151715d12b76e40497bf1d9ff658e0ad1e22dc9a73dd5f6736f7c075f94808a2f28b1c975aaa380bbb92cf4e7184
DIST mysql-connector-python-8.0.22.tar.gz 12081967 BLAKE2B fc6b724ec2eb47a92294f7316093d4a4d2f4925981adeb07b305e946a047dbdaedd96c6ff9a07426fd56185f467cf6473bc84e0896d2e8fde70a188af16e9df2 SHA512 07f380922c18f9ade38f95d8e107fe8f90b8a7901fb9a36bbdfdb2b29f9cb79b0b6387a608e89bf90e9344c635d47184c750a206beacb2c9cc7615d6a7df2c29
-EBUILD mysql-connector-python-8.0.21.ebuild 1523 BLAKE2B e9699410d9a65611169ef9cd82ed9e7067a2f927ccb780caca96f321cc71a1a22525b78a17c476389b30681fc551a9a417565bede1f11b2c043ebec2b8ef576f SHA512 b2ad29767cac03861f243ca7804a1edaa9f1ff963cb414f68c01f19c4f6386f7286c809a0d2a81b84324426a5a0e841547735eb8f1673ddcb437150b2b17c6bc
-EBUILD mysql-connector-python-8.0.22.ebuild 1527 BLAKE2B 1f1f3fca3825eb77636a29904fda7fda95646942606ddd1b52f5750f4bb21d154afedf86a4d7913fdd7de667b1f4c79040d0a66937658147c83044db4d95074d SHA512 e17e763d61c55aab66c466a95da1bffef5a272a91785a4ac2bf14939669a105f07961639bb6014e0cad332b8a522b9c53d80107d6d37814896258182a3ed5ca6
+EBUILD mysql-connector-python-8.0.22.ebuild 1525 BLAKE2B 1afce32cf4c3cb952155526234febae20205fdacff2599c8dbf552f7df696bf0efc6ca5e92ca748d9cf21b950c908ea7837d9b88e389bf5ffef70a67576b1762 SHA512 84e59d0cd95c576a2d54ebe9c1b8f487ff1cc1c872f95b8a19b750126defcdab464726a23e692f3dabef251311a5677403167ac845a7893afc114cbad98c8391
MISC metadata.xml 336 BLAKE2B 280111bac38fbd60e25601789026033a61dab0c2706af1874a765aa3a697cdba5d5b051a0dc28490782cf135104f92e793c68d02b74bdcffdd113252b9a3ac7d SHA512 27da38ceaf7dc44250dcb4651e2d171f1ccf0d5a3a2c04845dc6369e1a264b71ea909f7d799d3eabbd989f4c9c37c201f511887956613bf7176697da63378838
diff --git a/dev-python/mysql-connector-python/mysql-connector-python-8.0.21.ebuild b/dev-python/mysql-connector-python/mysql-connector-python-8.0.21.ebuild
deleted file mode 100644
index ae8e4244143f..000000000000
--- a/dev-python/mysql-connector-python/mysql-connector-python-8.0.21.ebuild
+++ /dev/null
@@ -1,53 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{6,7,8} )
-inherit distutils-r1
-
-DESCRIPTION="Python client library for MariaDB/MySQL"
-HOMEPAGE="https://dev.mysql.com/downloads/connector/python/"
-SRC_URI="https://dev.mysql.com/get/Downloads/Connector-Python/${P}.tar.gz"
-
-KEYWORDS="amd64 arm x86"
-LICENSE="GPL-2"
-SLOT="0"
-IUSE="examples test"
-
-BDEPEND=">=dev-libs/protobuf-3.6.1"
-
-RDEPEND="
- >=dev-db/mysql-connector-c-8.0
- >=dev-python/protobuf-python-3.6.1[${PYTHON_USEDEP}]
- dev-python/dnspython[${PYTHON_USEDEP}]
-"
-# tests/mysqld.py does not like MariaDB version strings.
-# See the regex MySQLServerBase._get_version.
-DEPEND="${RDEPEND} test? ( dev-db/mysql[server(+)] )"
-
-# Tests currently fail.
-# mysql.connector.errors.DatabaseError: 1300 (HY000): Invalid utf8 character string: ''
-RESTRICT="test"
-
-DOCS=( README.txt CHANGES.txt README.rst )
-
-python_test() {
- "${EPYTHON}" unittests.py --with-mysql="${EPREFIX}/usr" --unix-socket="${T}" --mysql-topdir="${T}"
-}
-
-# Yeah, this is really broken, but the extension will only build this way during "install"
-python_install() {
- distutils-r1_python_install \
- --with-mysql-capi="${EPREFIX}/usr" \
- --with-protobuf-include-dir="${EPREFIX}/usr/include/google/protobuf/" \
- --with-protobuf-lib-dir="${EPREFIX}/usr/$(get_libdir)" \
- --with-protoc="${EPREFIX}/usr/bin/protoc"
-}
-
-python_install_all() {
- distutils-r1_python_install_all
- if use examples ; then
- dodoc -r examples
- fi
-}
diff --git a/dev-python/mysql-connector-python/mysql-connector-python-8.0.22.ebuild b/dev-python/mysql-connector-python/mysql-connector-python-8.0.22.ebuild
index 1f08a174a33f..7e1b3f04e7d8 100644
--- a/dev-python/mysql-connector-python/mysql-connector-python-8.0.22.ebuild
+++ b/dev-python/mysql-connector-python/mysql-connector-python-8.0.22.ebuild
@@ -10,7 +10,7 @@ DESCRIPTION="Python client library for MariaDB/MySQL"
HOMEPAGE="https://dev.mysql.com/downloads/connector/python/"
SRC_URI="https://dev.mysql.com/get/Downloads/Connector-Python/${P}.tar.gz"
-KEYWORDS="~amd64 ~arm x86"
+KEYWORDS="amd64 arm x86"
LICENSE="GPL-2"
SLOT="0"
IUSE="examples test"