summaryrefslogtreecommitdiff
path: root/dev-python/mysql-connector-python
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-06-21 17:50:24 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-06-21 17:50:24 +0100
commitfeb0daf81d888e9160f9f94502de09b66f2a63fd (patch)
treeb6e5c40ce2abef3da27ed50a023153f475e0ddef /dev-python/mysql-connector-python
parent9452a6e87b6c2c70513bc47a2470bf9f1168920e (diff)
gentoo resync : 21.06.2020
Diffstat (limited to 'dev-python/mysql-connector-python')
-rw-r--r--dev-python/mysql-connector-python/Manifest2
-rw-r--r--dev-python/mysql-connector-python/mysql-connector-python-8.0.20.ebuild53
2 files changed, 55 insertions, 0 deletions
diff --git a/dev-python/mysql-connector-python/Manifest b/dev-python/mysql-connector-python/Manifest
index b3fe78711eb5..4dda2af3923a 100644
--- a/dev-python/mysql-connector-python/Manifest
+++ b/dev-python/mysql-connector-python/Manifest
@@ -1,3 +1,5 @@
DIST mysql-connector-python-8.0.19.tar.gz 12051609 BLAKE2B 252d4ee650c1eddbe54575451ac378236b6a795237c445239ecec096c7adcb60da2244592f083a50df57c9e2ae6447f1dcaf861042973a31c3fe7292509ef93d SHA512 9137b0b6aafbff16c83f59ab03da810232a92f6b76e38f460782153c5ddbdf6ae55d0c72a0c7902b7bc05ad1010bdc849662cd3d2138ae93476abf013e7a508f
+DIST mysql-connector-python-8.0.20.tar.gz 12058227 BLAKE2B ac16d0eb7ccc884e89bd493ce821b06223c7ea7a4c4ffce2ebc586c736524d826d92d3e3c7803c1f937c93a9f28df32205a04b3bd80474650e90bc267661879d SHA512 3b7298036f1b28eed98ca05ebc52619dbdf65393b4a01bf6eccea87d298da430ecfd19a3b327050ebc48b2c237698c7545c0196949d84cb79117f4d767d736aa
EBUILD mysql-connector-python-8.0.19.ebuild 1526 BLAKE2B 54cb1d1096378a1e55112f6d7a59257263143a4ed20260dbdaf6fc16e91b99d5a17a134cdccb52f6736e6cfdb219ccd06025532322d1a217b48164e8a5df42c3 SHA512 697f961fc9e06388abeba2644fae2e6b5f5faf545ebf911535a2e7e0279bcf2b1ebc79c24507c6e498a7b61b1d666ff054efc3368bdf7231cdee8fbb3838aed9
+EBUILD mysql-connector-python-8.0.20.ebuild 1526 BLAKE2B 54cb1d1096378a1e55112f6d7a59257263143a4ed20260dbdaf6fc16e91b99d5a17a134cdccb52f6736e6cfdb219ccd06025532322d1a217b48164e8a5df42c3 SHA512 697f961fc9e06388abeba2644fae2e6b5f5faf545ebf911535a2e7e0279bcf2b1ebc79c24507c6e498a7b61b1d666ff054efc3368bdf7231cdee8fbb3838aed9
MISC metadata.xml 336 BLAKE2B 280111bac38fbd60e25601789026033a61dab0c2706af1874a765aa3a697cdba5d5b051a0dc28490782cf135104f92e793c68d02b74bdcffdd113252b9a3ac7d SHA512 27da38ceaf7dc44250dcb4651e2d171f1ccf0d5a3a2c04845dc6369e1a264b71ea909f7d799d3eabbd989f4c9c37c201f511887956613bf7176697da63378838
diff --git a/dev-python/mysql-connector-python/mysql-connector-python-8.0.20.ebuild b/dev-python/mysql-connector-python/mysql-connector-python-8.0.20.ebuild
new file mode 100644
index 000000000000..b6c5eebd14bc
--- /dev/null
+++ b/dev-python/mysql-connector-python/mysql-connector-python-8.0.20.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8} )
+inherit distutils-r1
+
+DESCRIPTION="Python client library for MariaDB/MySQL"
+HOMEPAGE="https://dev.mysql.com/downloads/connector/python/"
+SRC_URI="https://dev.mysql.com/get/Downloads/Connector-Python/${P}.tar.gz"
+
+KEYWORDS="~amd64 ~arm ~x86"
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="examples test"
+
+BDEPEND=">=dev-libs/protobuf-3.6.1"
+
+RDEPEND="
+ >=dev-db/mysql-connector-c-8.0
+ >=dev-python/protobuf-python-3.6.1[${PYTHON_USEDEP}]
+ dev-python/dnspython[${PYTHON_USEDEP}]
+"
+# tests/mysqld.py does not like MariaDB version strings.
+# See the regex MySQLServerBase._get_version.
+DEPEND="${RDEPEND} test? ( dev-db/mysql[server(+)] )"
+
+# Tests currently fail.
+# mysql.connector.errors.DatabaseError: 1300 (HY000): Invalid utf8 character string: ''
+RESTRICT="test"
+
+DOCS=( README.txt CHANGES.txt README.rst )
+
+python_test() {
+ "${EPYTHON}" unittests.py --with-mysql="${EPREFIX}/usr" --unix-socket="${T}" --mysql-topdir="${T}"
+}
+
+# Yeah, this is really broken, but the extension will only build this way during "install"
+python_install() {
+ distutils-r1_python_install \
+ --with-mysql-capi="${EPREFIX}/usr" \
+ --with-protobuf-include-dir="${EPREFIX}/usr/include/google/protobuf/" \
+ --with-protobuf-lib-dir="${EPREFIX}/usr/$(get_libdir)" \
+ --with-protoc="${EPREFIX}/usr/bin/protoc"
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+ if use examples ; then
+ dodoc -r examples
+ fi
+}