summaryrefslogtreecommitdiff
path: root/dev-python/myst-parser
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2025-02-14 00:13:14 +0000
committerV3n3RiX <venerix@koprulu.sector>2025-02-14 00:13:14 +0000
commit4fda045f90a4e301329bddb766e2e12a0b4401de (patch)
tree1d486767bfd9de15d6c11d341408385eb7f7debe /dev-python/myst-parser
parent965058196f44550f3bc491dd85064071e085b776 (diff)
gentoo auto-resync : 14:02:2025 - 00:13:14
Diffstat (limited to 'dev-python/myst-parser')
-rw-r--r--dev-python/myst-parser/Manifest2
-rw-r--r--dev-python/myst-parser/myst-parser-4.0.1.ebuild63
2 files changed, 65 insertions, 0 deletions
diff --git a/dev-python/myst-parser/Manifest b/dev-python/myst-parser/Manifest
index 573ce0b0e006..2c9d2ce31a05 100644
--- a/dev-python/myst-parser/Manifest
+++ b/dev-python/myst-parser/Manifest
@@ -1,3 +1,5 @@
DIST MyST-Parser-4.0.0.gh.tar.gz 825843 BLAKE2B 60361e72014fc4428e026f6b93f91878824a0cd46bbe128b04c0ab9e9578c252fea6ece23dfbee0b1652d5529e411669d7cdab3ffebe8128e791ebdd26b950cd SHA512 82a8c642d839133413577fd85b5668a6b4d3869f60b7c7c64f98ec6cf52f33b28abd33ee7ddbbf8e286a3f233a152878802e6a8091c88f63844ac774c88ebd62
+DIST MyST-Parser-4.0.1.gh.tar.gz 825970 BLAKE2B 04e8da0947d0acd8fb9dd73b3f133ee14e119868bb119882bfab972ca7a402d0afd9b8fec1f3f26500ae2a6581fcae4f782e577411ef78f3b4b893e1c50c9426 SHA512 40bdad9abb84cda3c77303dd7ad766c77df43bca11c787812007f2399525fe955201b09495079a88973ada3e87102c95eeec2cba6d2be89f6b61d3c9df57bfae
EBUILD myst-parser-4.0.0.ebuild 1600 BLAKE2B ec53d40a65a0868634fcbf222284b347898384f41feabc63a6f2722e977c3d7181bf489dd8a09b8206148eb30b186d5d89275aea0b605f07f272fe0b5b7a39a1 SHA512 4991497c6e779de02853f144a37b98ea221ef5e107d502be421262516f0f4cc374e622e94d0e81e2633c75aba7c976fff61c1ab83bf29b2b4d314486ff3beae6
+EBUILD myst-parser-4.0.1.ebuild 1713 BLAKE2B e3782d8a1a3c8699da517165337e915383970bc8c2d0dd112ffb486aa8533cd3874c3c727c674e9a495e471b534e445352c05c8e9dc6085ce2ef2aac4a2d3184 SHA512 bdba70056692ac7123aee9b4a823054a5929da1771313f86e5a0024889c4ce2c2a1ebfa1e8e47089f59417aa64a4c2897c46b14a7c159bda64a9314bd2710fbb
MISC metadata.xml 406 BLAKE2B d8a974be3dd4fef4800958dcb1eef3124dc8e3ec49e6678d0db7d6096ef290019aa025796c4f7c38bc11b750d1667ba97d4429b64e7271009da707cd945e113f SHA512 acdc27a39e068c487306002342b9c0c5910d61ed34a7b62878272054ea458d5aad46fe24095a52666ed77ffcb6e703687cc83de0c9e2cef395a1decf9003d918
diff --git a/dev-python/myst-parser/myst-parser-4.0.1.ebuild b/dev-python/myst-parser/myst-parser-4.0.1.ebuild
new file mode 100644
index 000000000000..6c96a49d1d98
--- /dev/null
+++ b/dev-python/myst-parser/myst-parser-4.0.1.ebuild
@@ -0,0 +1,63 @@
+# Copyright 2022-2025 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=flit
+PYTHON_COMPAT=( python3_{10..13} pypy3 )
+
+inherit distutils-r1
+
+MY_P=MyST-Parser-${PV}
+DESCRIPTION="Extended commonmark compliant parser, with bridges to Sphinx"
+HOMEPAGE="
+ https://github.com/executablebooks/MyST-Parser/
+ https://pypi.org/project/myst-parser/
+"
+SRC_URI="
+ https://github.com/executablebooks/MyST-Parser/archive/v${PV}.tar.gz
+ -> ${MY_P}.gh.tar.gz
+"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ >=dev-python/docutils-0.18[${PYTHON_USEDEP}]
+ dev-python/jinja2[${PYTHON_USEDEP}]
+ <dev-python/markdown-it-py-4[${PYTHON_USEDEP}]
+ >=dev-python/markdown-it-py-3.0[${PYTHON_USEDEP}]
+ <dev-python/mdit-py-plugins-0.5[${PYTHON_USEDEP}]
+ >=dev-python/mdit-py-plugins-0.4.1[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ <dev-python/sphinx-9[${PYTHON_USEDEP}]
+ >=dev-python/sphinx-6[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/beautifulsoup4[${PYTHON_USEDEP}]
+ dev-python/defusedxml[${PYTHON_USEDEP}]
+ <dev-python/linkify-it-py-3[${PYTHON_USEDEP}]
+ >=dev-python/linkify-it-py-2.0.0[${PYTHON_USEDEP}]
+ dev-python/pytest-regressions[${PYTHON_USEDEP}]
+ dev-python/pytest-param-files[${PYTHON_USEDEP}]
+ >=dev-python/sphinx-7.3[${PYTHON_USEDEP}]
+ dev-python/sphinx-pytest[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_DESELECT=(
+ # minor pygments mismatch
+ tests/test_sphinx/test_sphinx_builds.py::test_includes
+)
+
+src_prepare() {
+ default
+
+ # unpin docutils
+ sed -i -e '/docutils/s:,<[0-9.]*::' pyproject.toml || die
+}