summaryrefslogtreecommitdiff
path: root/dev-python/myst-parser
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-07-24 14:55:44 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-07-24 14:55:44 +0100
commitb83b16e0f6c963583f6323fe1bb12ecbd11d6f81 (patch)
treed67748047921162af2742c3e1255e3f1421f769b /dev-python/myst-parser
parent76617568771869151cb2a3f71939719c15dd47a2 (diff)
gentoo auto-resync : 24:07:2023 - 14:55:44
Diffstat (limited to 'dev-python/myst-parser')
-rw-r--r--dev-python/myst-parser/Manifest4
-rw-r--r--dev-python/myst-parser/myst-parser-1.0.0.ebuild60
-rw-r--r--dev-python/myst-parser/myst-parser-2.0.0.ebuild2
3 files changed, 2 insertions, 64 deletions
diff --git a/dev-python/myst-parser/Manifest b/dev-python/myst-parser/Manifest
index 9db65d8d18e0..ff6d0911bcf1 100644
--- a/dev-python/myst-parser/Manifest
+++ b/dev-python/myst-parser/Manifest
@@ -1,5 +1,3 @@
-DIST MyST-Parser-1.0.0.gh.tar.gz 813309 BLAKE2B 03bc080e0a5103b9fb239cfbea991012b1fb5f411a5a6a121b2113ad7172a1130bf8b77d20ce84a8aade4148ffba36788eb95b15ecd28c53ed321226ae8600f2 SHA512 1f0ecffd2c84b0db5d251dbc771457cdf52a8e6e540d3acde563115af24ce30d43e01223f172b3e72b2c81862052bb05ea5d7c6091f933afbda0a859d1b86e83
DIST MyST-Parser-2.0.0.gh.tar.gz 815453 BLAKE2B 8f5dd823c3c79d843b45a7a4819d5677b51a12f78db2c1ce9700eb6faa8c4f0bc167fb1d8cd947e89ffab85aec947ab527b67dc73ef4db97a393f700a4331738 SHA512 c47bdd773565e93c4714d318a70f9a8adab1be6e2a63c23175667fc4afb5da4d66b84e11176782c8202e9fd68883e74d444911ddfb0b91356c2ba07fa65f7ea4
-EBUILD myst-parser-1.0.0.ebuild 1617 BLAKE2B 19e6bf03c24c2b8087e762fd1438f1abca2b594b3f89d40d45d0334cdd02eb6087bcd09c047bc14808dd62cbf8264ed9ffd10e1977fd128f953edf93fca3a857 SHA512 99f884a276a6900fe7ad9c407cb172f2cc934fedf184bcc97cfe05a332c8e2030cf05a27f0a700366232de39512a3d63c43e7eb3f44cd72713e2be1548d218de
-EBUILD myst-parser-2.0.0.ebuild 1665 BLAKE2B ad2f266e3bdd76bedf1031c517b397f2162045796c610fe5bd7f87bcf2dcb1999634f68237ccda8a4626e3cee4ea2c18b97552bd7a239fba6fc99fd9c246a191 SHA512 119b167484c6dd05ffcbc659e2a055803c3d5305e9cfefe25216150476cb09b2f491639f6d4976ce3b701bc5eaf8782ac8ff48ba67f6bd160472d8bad806d173
+EBUILD myst-parser-2.0.0.ebuild 1657 BLAKE2B ceff8b34b9c96e3abb147eebf22ede04595006b27b4efb630a1cc42057b4bac70a8cba0d941670d1d278aa528dda86b74cfc6dcb62c5dce86d58a9e11a16736f SHA512 76b98210b63002a4e0b704fe73704142580ef7115292db40cc16f60b024a882a246d0b012968c2d27c9870389a7b9d55cfa3e9bb9ae10a52bcb5c2a0ac90fccc
MISC metadata.xml 406 BLAKE2B d8a974be3dd4fef4800958dcb1eef3124dc8e3ec49e6678d0db7d6096ef290019aa025796c4f7c38bc11b750d1667ba97d4429b64e7271009da707cd945e113f SHA512 acdc27a39e068c487306002342b9c0c5910d61ed34a7b62878272054ea458d5aad46fe24095a52666ed77ffcb6e703687cc83de0c9e2cef395a1decf9003d918
diff --git a/dev-python/myst-parser/myst-parser-1.0.0.ebuild b/dev-python/myst-parser/myst-parser-1.0.0.ebuild
deleted file mode 100644
index f6e2f9f396bc..000000000000
--- a/dev-python/myst-parser/myst-parser-1.0.0.ebuild
+++ /dev/null
@@ -1,60 +0,0 @@
-# Copyright 2022-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=flit
-PYTHON_COMPAT=( python3_{10..12} pypy3 )
-
-inherit distutils-r1
-
-MY_P=MyST-Parser-${PV}
-DESCRIPTION="Extended commonmark compliant parser, with bridges to Sphinx"
-HOMEPAGE="
- https://github.com/executablebooks/MyST-Parser/
- https://pypi.org/project/myst-parser/
-"
-SRC_URI="
- https://github.com/executablebooks/MyST-Parser/archive/v${PV}.tar.gz
- -> ${MY_P}.gh.tar.gz
-"
-S=${WORKDIR}/${MY_P}
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86"
-
-RDEPEND="
- <dev-python/docutils-0.20[${PYTHON_USEDEP}]
- dev-python/jinja[${PYTHON_USEDEP}]
- dev-python/markdown-it-py[${PYTHON_USEDEP}]
- >=dev-python/mdit-py-plugins-0.3.4[${PYTHON_USEDEP}]
- dev-python/pyyaml[${PYTHON_USEDEP}]
- <dev-python/sphinx-7[${PYTHON_USEDEP}]
- >=dev-python/sphinx-5[${PYTHON_USEDEP}]
-"
-BDEPEND="
- test? (
- dev-python/beautifulsoup4[${PYTHON_USEDEP}]
- dev-python/pytest-regressions[${PYTHON_USEDEP}]
- dev-python/pytest-param-files[${PYTHON_USEDEP}]
- dev-python/sphinx-pytest[${PYTHON_USEDEP}]
- )
-"
-
-distutils_enable_tests pytest
-
-python_test() {
- local EPYTEST_DESELECT=(
- # Unimportant tests needing a new dep linkify
- tests/test_renderers/test_myst_config.py::test_cmdline
- tests/test_sphinx/test_sphinx_builds.py::test_extended_syntaxes
- )
-
- [[ ${EPYTHON} == pypy3 ]] && EPYTEST_DESELECT+=(
- # bad test relying on exact exception messages
- "tests/test_renderers/test_include_directive.py::test_errors[9-Non-existent path:]"
- )
-
- epytest
-}
diff --git a/dev-python/myst-parser/myst-parser-2.0.0.ebuild b/dev-python/myst-parser/myst-parser-2.0.0.ebuild
index 78026de7bf09..62a14e5a21a3 100644
--- a/dev-python/myst-parser/myst-parser-2.0.0.ebuild
+++ b/dev-python/myst-parser/myst-parser-2.0.0.ebuild
@@ -22,7 +22,7 @@ S=${WORKDIR}/${MY_P}
LICENSE="MIT"
SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86"
RDEPEND="
<dev-python/docutils-0.21[${PYTHON_USEDEP}]