summaryrefslogtreecommitdiff
path: root/dev-python/natgrid
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-python/natgrid
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-python/natgrid')
-rw-r--r--dev-python/natgrid/Manifest3
-rw-r--r--dev-python/natgrid/metadata.xml17
-rw-r--r--dev-python/natgrid/natgrid-0.2.1-r3.ebuild32
3 files changed, 52 insertions, 0 deletions
diff --git a/dev-python/natgrid/Manifest b/dev-python/natgrid/Manifest
new file mode 100644
index 000000000000..76a7c5149ae8
--- /dev/null
+++ b/dev-python/natgrid/Manifest
@@ -0,0 +1,3 @@
+DIST natgrid-0.2.1.tar.gz 35205 BLAKE2B 6ca1108ffc1b30dc8e4c570405817a73dc7b2c0e0b865978d2918bf8d1e9d503904c3eea704f7c5310ae947c558e284d7ce8bd70ff2add6d876c4894bdccedb4 SHA512 489e8454f05ff994bad23d88bb423fd0bc17e838193865d3dbb6be0d01221203dcd1644c133827421ba4acf354295f07533ff838b138056064e1bee73d43c922
+EBUILD natgrid-0.2.1-r3.ebuild 820 BLAKE2B 7108928d3c933d9a7e54018c296796241f3917db2c5ca2b47f18b85c0d190d4f826175bfbdc8a9f89d5eb1ffca69392ef2daceaacb5ae222e811a2534c66daae SHA512 52dab7a4deb0f6eddd6ab764f9fe198b18e73d01478db30a37b556f6d24c064d42e91fe4b2d30734af67a701a6957b301da845958c9e72eb46d98bfe4cc3ef8a
+MISC metadata.xml 615 BLAKE2B 09a4d0ef38af543f9ac7d34760ce60ef9b493523d70261c1c62c1d3fb531378438f66ac8c948501b889a8c6ef762fc36cf07aed98369ec4be5a7da1dbdbc6b61 SHA512 2ec5784f8f6a083852e1c19b41cc0209bd4799820a91002aa4e024a269fcff4c7cf503decec42d634ff8355aeb5b70e85f85d174cd0fea419098c7b1d1d08dec
diff --git a/dev-python/natgrid/metadata.xml b/dev-python/natgrid/metadata.xml
new file mode 100644
index 000000000000..ec0f5a10d4dd
--- /dev/null
+++ b/dev-python/natgrid/metadata.xml
@@ -0,0 +1,17 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>sci@gentoo.org</email>
+ <name>Gentoo Science Project</name>
+ </maintainer>
+ <longdescription lang="en">
+ mpl_toolkits.natgrid is an python interface to natgrid C library for
+ gridding irregularly spaced data.
+ The original natgrid is a natural neighbor gridding package.
+ (See http://www.ncarg.ucar.edu//ngmath/natgrid/nnhome.html).
+ </longdescription>
+ <upstream>
+ <remote-id type="sourceforge">matplotlib</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/natgrid/natgrid-0.2.1-r3.ebuild b/dev-python/natgrid/natgrid-0.2.1-r3.ebuild
new file mode 100644
index 000000000000..692c19f46d7d
--- /dev/null
+++ b/dev-python/natgrid/natgrid-0.2.1-r3.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
+
+inherit distutils-r1
+
+DESCRIPTION="Matplotlib toolkit for gridding irreguraly spaced data"
+HOMEPAGE="http://matplotlib.sourceforge.net/users/toolkits.html"
+SRC_URI="mirror://sourceforge/matplotlib/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+DEPEND=">=dev-python/matplotlib-0.98[${PYTHON_USEDEP}]"
+RDEPEND="${DEPEND}"
+
+python_install_all() {
+ insinto /usr/share/doc/${PF}
+ doins test.py || die "doins failed"
+ distutils-r1_python_install_all
+}
+
+python_install() {
+ # namespace installed by dev-python/matplotlib
+ rm "${BUILD_DIR}/lib/mpl_toolkits/__init__.py" || die
+ distutils-r1_python_install --skip-build
+}