summaryrefslogtreecommitdiff
path: root/dev-python/nautilus-python
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-06-13 10:39:22 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-06-13 10:39:22 +0100
commit9452a6e87b6c2c70513bc47a2470bf9f1168920e (patch)
tree8ac67e26b45f34d71c5aab3621813b100a0d5f00 /dev-python/nautilus-python
parentf516638b7fe9592837389826a6152a7e1b251c54 (diff)
gentoo resync : 13.06.2020
Diffstat (limited to 'dev-python/nautilus-python')
-rw-r--r--dev-python/nautilus-python/Manifest2
-rw-r--r--dev-python/nautilus-python/nautilus-python-1.2.3.ebuild38
2 files changed, 40 insertions, 0 deletions
diff --git a/dev-python/nautilus-python/Manifest b/dev-python/nautilus-python/Manifest
index 80eed316f9bf..91782c573a37 100644
--- a/dev-python/nautilus-python/Manifest
+++ b/dev-python/nautilus-python/Manifest
@@ -1,3 +1,5 @@
DIST nautilus-python-1.2.2.tar.xz 269220 BLAKE2B 9f2b5acc20727acf4464297bc008e8be0bb45ed418601e3658405e90eb3d56306f9aece402948491d5423d58cd261cee5cacbd39dd185957c4d72c90f877842e SHA512 541ab9e6ac15b06994cf475237e5588d21f4b9f71bb562f4bd9d976f79849a29912080de0b16c14406b052bec15c2c754381bf36e15b340d1f8e76c83a2464bc
+DIST nautilus-python-1.2.3.tar.xz 269320 BLAKE2B 3d355bb8c0e67c488bb818d55c2bc97d8d4bfa14aeed8d6cb80d999a4b91ef5dc2f576d3dcca0e44ac004830ae326a93110aeb0cbe1987f100475cbee1b59ba2 SHA512 9c6a1a4bbf74a8c9c7d94a74c6994f0b1fc9de522c9f05d0ccbcdf3d60b1073dcf8058739ac0ee16f54b2632f2b9dd994bbe2bcd98cc165db543567bb1545443
EBUILD nautilus-python-1.2.2-r1.ebuild 946 BLAKE2B 52f4f4077034a671568e4de1337a7464e62718ea2ce9db39aaaeb7ed53af42acd6c3c4870596ed14c648b8c2ed39c5c145d85599d184df6d3e049a8f09e504cc SHA512 6ea8233389a35c5114a9c73b29586d37c64974b3ab8589378a6d94466375eecea712f3dbe87cfa251f1eae6531ff43302de23b609984a1e5442b56756a68e059
+EBUILD nautilus-python-1.2.3.ebuild 952 BLAKE2B 6354343ec86b42de1cf0db07651468559fbb0ddaee6ac1bd7c767c85e5a4cfc7de653e9a6aef8d2cb0104256b6a37248bf17971457bf094668766d399352501f SHA512 9a4a5a29377a5dca89d3cf57352c61ff692e366010b4e2d60abad9f52aa4835c194367f987aa3cfb705c24216b363767a696a961f8e202dc681c848bb60be38d
MISC metadata.xml 253 BLAKE2B a1efbd3751efaa83ee173f557ec1c8a4497a90b60896cf5a7a07da40b4f94a7a299ca0385477e82b2f5e5dbdf9afa482ccbe21f35ef44214e9c451d764b65529 SHA512 8d59f413993268ca783f7407b676900bb2d964754bf705d4175e2bafbe058a52af74f3928e4bd84d292518f8cf13fab7051486ab7cdc61d02fae6e0188d44442
diff --git a/dev-python/nautilus-python/nautilus-python-1.2.3.ebuild b/dev-python/nautilus-python/nautilus-python-1.2.3.ebuild
new file mode 100644
index 000000000000..8f8557f2af2e
--- /dev/null
+++ b/dev-python/nautilus-python/nautilus-python-1.2.3.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+GNOME2_LA_PUNT="yes"
+PYTHON_COMPAT=( python{2_7,3_{6,7,8}} )
+
+inherit gnome2 python-single-r1
+
+DESCRIPTION="Python bindings for the Nautilus file manager"
+HOMEPAGE="https://projects.gnome.org/nautilus-python/"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm64 ~x86"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+# Require pygobject:3 and USE=introspection on nautilus for sanity,
+# because no (user) plugins could work without them; configure itself
+# requires pygobject:3 or :2 and >=nautilus-2.32
+RDEPEND="
+ $(python_gen_cond_dep '
+ dev-python/pygobject:3[${PYTHON_MULTI_USEDEP}]
+ ')
+ >=gnome-base/nautilus-3[introspection]
+ ${PYTHON_DEPS}
+"
+DEPEND="${RDEPEND}
+ >=dev-util/gtk-doc-am-1.14
+ virtual/pkgconfig
+"
+
+src_install() {
+ gnome2_src_install
+ # Directory for systemwide extensions
+ keepdir /usr/share/nautilus-python/extensions
+}