summaryrefslogtreecommitdiff
path: root/dev-python/nbclassic/nbclassic-0.4.8.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-01-28 02:49:59 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-01-28 02:49:59 +0000
commite53aa6b4fbe5a0c6db75d893829f7a6a37a14180 (patch)
treedd095d36490410a724fd271fcdf08c31a5336edd /dev-python/nbclassic/nbclassic-0.4.8.ebuild
parentc5ee568457ac776b65b71fa444e0dd47535bc44a (diff)
gentoo auto-resync : 28:01:2023 - 02:49:59
Diffstat (limited to 'dev-python/nbclassic/nbclassic-0.4.8.ebuild')
-rw-r--r--dev-python/nbclassic/nbclassic-0.4.8.ebuild66
1 files changed, 0 insertions, 66 deletions
diff --git a/dev-python/nbclassic/nbclassic-0.4.8.ebuild b/dev-python/nbclassic/nbclassic-0.4.8.ebuild
deleted file mode 100644
index 2047e47a55f2..000000000000
--- a/dev-python/nbclassic/nbclassic-0.4.8.ebuild
+++ /dev/null
@@ -1,66 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-PYTHON_COMPAT=( python3_{9..11} )
-DISTUTILS_USE_PEP517=jupyter
-
-inherit distutils-r1 xdg-utils
-
-DESCRIPTION="Jupyter Notebook as a Jupyter Server Extension"
-HOMEPAGE="
- https://jupyter.org/
- https://github.com/jupyter/nbclassic/
- https://pypi.org/project/nbclassic/
-"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-
-RDEPEND="
- >=dev-python/jupyter_server-1.17.0[${PYTHON_USEDEP}]
- <dev-python/notebook-7[${PYTHON_USEDEP}]
- >=dev-python/notebook_shim-0.1.0[${PYTHON_USEDEP}]
-"
-
-# pytest-console-scripts seem unused
-BDEPEND="
- test? (
- dev-python/pytest-tornasync[${PYTHON_USEDEP}]
- )
- doc? (
- virtual/pandoc
- )
-"
-
-distutils_enable_tests pytest
-distutils_enable_sphinx docs/source \
- dev-python/sphinx_rtd_theme \
- dev-python/nbsphinx \
- dev-python/sphinxcontrib-github-alt \
- dev-python/myst_parser \
- dev-python/ipython_genutils
-
-python_test() {
- local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
- epytest -p pytest_tornasync.plugin
-}
-
-python_install_all() {
- distutils-r1_python_install_all
- # move /usr/etc stuff to /etc
- mv "${ED}/usr/etc" "${ED}/etc" || die
-}
-
-pkg_postinst() {
- xdg_desktop_database_update
- xdg_icon_cache_update
-}
-
-pkg_postrm() {
- xdg_desktop_database_update
- xdg_icon_cache_update
-}