summaryrefslogtreecommitdiff
path: root/dev-python/nbclient
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-11-07 22:21:54 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-11-07 22:21:54 +0000
commit06dcf64674a43718324bffee383625d2cd050b75 (patch)
tree4de58e857f3f0718fef4fc386e42577c2f4c9478 /dev-python/nbclient
parent198bd0cd3c1be97f7deb5283fa00048718482de4 (diff)
gentoo auto-resync : 07:11:2023 - 22:21:54
Diffstat (limited to 'dev-python/nbclient')
-rw-r--r--dev-python/nbclient/Manifest2
-rw-r--r--dev-python/nbclient/nbclient-0.9.0.ebuild54
2 files changed, 56 insertions, 0 deletions
diff --git a/dev-python/nbclient/Manifest b/dev-python/nbclient/Manifest
index b909a1f56680..c487f8df9640 100644
--- a/dev-python/nbclient/Manifest
+++ b/dev-python/nbclient/Manifest
@@ -1,3 +1,5 @@
DIST nbclient-0.8.0.gh.tar.gz 79287 BLAKE2B 5147195fa75ae5da620eb44b5b3d360f69275f1590d098757c6f460769bdb62d3eca576a344861e382bf430f97159adbfff46f557c3509d5fe06d269a0302cdc SHA512 f77ecba2f03a8886e8a2335e1d345fcc1d3a1726b458d151a8c78b85c621017cd96f1ef30e4532bf61b89c92aea128a364f5e9677858951f5d070c6206a01816
+DIST nbclient-0.9.0.tar.gz 60606 BLAKE2B a734e317cd71f4199a87af0ea6c7a8a9982c60c4e690eeb99dbe4681ed7d9f8a45ae064bb8b92acf084da722ccbec36bbedb7ddc61577103be1492745f84cd9a SHA512 dc6409e1f765e01978f7e5417269d82c2a001dc9a642f474b4d5cd28e34c969a68ae956aed55df3e82315bd457320e2bd25cbc13af2ea1f59a46f9d327d5eef2
EBUILD nbclient-0.8.0.ebuild 1584 BLAKE2B 2fed32b3d31b5123abfb2bb0b66fe38097da13e8b6114d948b7ed90dfb9c81af586ab34a68ac5ad539557e4e5af31c102adbfa2928132fa3141c9ceb194b765b SHA512 9322d2e4bdcee0613d59eaa258c107eab351a2f17fbfbc6a0b6c1fa8933791646e7d0f785169fb94a719ec44cb1f38626383176687e66df9d9a515ceec18cb45
+EBUILD nbclient-0.9.0.ebuild 1516 BLAKE2B a42bacd4406d87f2ef1a1734df71bd9439df0cf10a1198b83d15ec5a5a472b619fc2c12f4055a58b55df3595e8cca8228e0c993e8869b58b89b049cd99919bbd SHA512 7fbb187183ad0be977daff032f4ba8ff5766e9a7b117af2a8e20c95c22a9cda7473c53e89bd274f7240e2470749baaa6f0a8494866f3b281226ee45ad96a29ae
MISC metadata.xml 405 BLAKE2B d1efa5f7bb2a959bdbc6093b1bd3930e6cdb9bffbe872c6775c15dfc1024ae24d6bcb4651c8e1fb06242b17d6a86f683de3b528bbf1a60b5656a90c1f4ac81b7 SHA512 5b0de690d37dd5928e3bfd0b380336d154cced094e342b41dfd16d0caddd2b792a2158b209404a36461cf4d1b12d836024eae2aedf15093b90f4e363382b38bf
diff --git a/dev-python/nbclient/nbclient-0.9.0.ebuild b/dev-python/nbclient/nbclient-0.9.0.ebuild
new file mode 100644
index 000000000000..65800093aa89
--- /dev/null
+++ b/dev-python/nbclient/nbclient-0.9.0.ebuild
@@ -0,0 +1,54 @@
+# Copyright 2020-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="A client library for executing Jupyter notebooks"
+HOMEPAGE="
+ https://nbclient.readthedocs.io/en/latest/
+ https://github.com/jupyter/nbclient/
+ https://pypi.org/project/nbclient/
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ >=dev-python/jupyter-client-6.1.12[${PYTHON_USEDEP}]
+ >=dev-python/jupyter-core-5.1.0[${PYTHON_USEDEP}]
+ >=dev-python/nbformat-5.0[${PYTHON_USEDEP}]
+ >=dev-python/traitlets-5.4[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/flaky[${PYTHON_USEDEP}]
+ dev-python/ipython[${PYTHON_USEDEP}]
+ >=dev-python/ipykernel-6.19.3[${PYTHON_USEDEP}]
+ dev-python/ipywidgets[${PYTHON_USEDEP}]
+ dev-python/nbconvert[${PYTHON_USEDEP}]
+ dev-python/pytest-asyncio[${PYTHON_USEDEP}]
+ dev-python/testpath[${PYTHON_USEDEP}]
+ dev-python/xmltodict[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_DESELECT=(
+ nbclient/tests/test_client.py::test_many_parallel_notebooks
+ 'nbclient/tests/test_client.py::test_run_all_notebooks[Interrupt.ipynb-opts6]'
+)
+
+python_test() {
+ # The tests run the pydevd debugger, the debugger prints a warning
+ # in python3.11 when frozen modules are being used.
+ # This warning makes the tests fail, silence it.
+ local -x PYDEVD_DISABLE_FILE_VALIDATION=1
+ epytest
+}