summaryrefslogtreecommitdiff
path: root/dev-python/nbconvert
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-12-18 19:50:47 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-12-18 19:50:47 +0000
commit1252b7a51c2cc6bd3a81830544cacce0aefc0bf1 (patch)
tree46f7231a8d885b3bd21739910f346623e6d92c86 /dev-python/nbconvert
parent64602f81dd4ecc257e8c5139f42b902d3555ea78 (diff)
gentoo auto-resync : 18:12:2023 - 19:50:47
Diffstat (limited to 'dev-python/nbconvert')
-rw-r--r--dev-python/nbconvert/Manifest2
-rw-r--r--dev-python/nbconvert/nbconvert-7.13.0.ebuild82
2 files changed, 84 insertions, 0 deletions
diff --git a/dev-python/nbconvert/Manifest b/dev-python/nbconvert/Manifest
index 36fa1cbfa938..916b483a53be 100644
--- a/dev-python/nbconvert/Manifest
+++ b/dev-python/nbconvert/Manifest
@@ -1,5 +1,7 @@
DIST nbconvert-7.11.0.tar.gz 851158 BLAKE2B 0506acda6a645ffba6771f600c63f0c37705481021b716a2b5ec61b49f2b9da490beac7a1fec67718d091d7bfcf82d7f07b68e207573ca5c08271fc502214eb1 SHA512 097e740413520b943afea11e2b797fbb163e1c34b79932597ec1c5a2c64bbb9342e4b3e1f0ab7e4d6dbdaa736d747650d8e0e50da0e4db5398151da8c3b57c59
DIST nbconvert-7.12.0.tar.gz 851572 BLAKE2B e6f91a29790fc24901bfb527fc4335000af11354090c969d393eb1c95ad9f36c1e65e941a061b20ed884fd4e70316c6cdf1eb7ca115147ecb8a4726f62a98b83 SHA512 ba450938e7a907a6b5679e619b79ea6555f81b6f4ca387c3fab94377ce060d5b99424804052855451ec3f6f8a160355d58c6b875bdd3951a16c5dacae19a2c24
+DIST nbconvert-7.13.0.tar.gz 851504 BLAKE2B 72e745f58f624c4bf8dc05e366e924f734590cb7deaf27ea14229d6cdcca6b057fd1fb47a35bae511c7abb72cf7836203401613cb37ca2541f543b98422204ee SHA512 8d008ccb5e281cd7fd25c384ca1ecf4f3ddd314c07ec1eae079ad2075ca3ed8d92b4d9849fc29a444f8784727cd92335e02154340980c1631d5fc0d6bad956f9
EBUILD nbconvert-7.11.0.ebuild 2390 BLAKE2B 80dedc85dad12fc83b3602c38478b945bd05381a9207c7d097ccafc945bb002a3f8f41e0c1dd73e1fcf25e8c619d0c59d2fea14a62759e222fd3a125a2e65d5a SHA512 07ab27230ff23a90e5e52ab876871ab451d0b6f82085b7fb69d4e0fc428e9ea5d788ae2e9984e7287502d8da220e5969c7d108b5bd3a59e9bc04baebfea63d56
EBUILD nbconvert-7.12.0.ebuild 2398 BLAKE2B 12761913206dc5e22b0e34ca954a4a82ebb2c66eb7783235e5665fee304b0f31717f259ee409a0e987551fab22562cda0fb7e135da5e4b9fd48a2dbfb8d46a10 SHA512 78813ad98caa42ea738e55455a4921a3aa51abcbf6902f07581719e71fb3ab381484e5ac9b549d04191ca761c7dba0c38487e72b26cd6470a070d9d87a12dbd3
+EBUILD nbconvert-7.13.0.ebuild 2400 BLAKE2B 846ea8d23cb0138d587b0d92596018aa2d94378bf5f4612b2ff050e61255f9a8e095e8d45478d83818ea1274d861919f078adec6b25f213fdf8428ea172f0181 SHA512 be480d5d6bfa2d10a7b4662a3139c51266e91a4204984c0130ebbf2e0a9f612ee66d21cd4aa452654d9ef2c844265fa208edefffc4c4d4eeeb34eceb3ca33668
MISC metadata.xml 527 BLAKE2B a915103b3eaf57236f4257c98354a1e3733771369ac825fa8bbc4f79f0d1a23272dc86e744513620fbee37792e813a15dbb955e633a7c57597c3c38657ed05d3 SHA512 b60a311ce52915dbc12addd4a882670ac96ff8b3be2aa651eaac3d0963d6e73a72eaafd53f90fb685599504857e6bcd0568071962d7696c2605462b77260ad6a
diff --git a/dev-python/nbconvert/nbconvert-7.13.0.ebuild b/dev-python/nbconvert/nbconvert-7.13.0.ebuild
new file mode 100644
index 000000000000..f9b2a54b29af
--- /dev/null
+++ b/dev-python/nbconvert/nbconvert-7.13.0.ebuild
@@ -0,0 +1,82 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( pypy3 python3_{10..12} )
+
+inherit distutils-r1 pypi virtualx
+
+DESCRIPTION="Converting Jupyter Notebooks"
+HOMEPAGE="
+ https://nbconvert.readthedocs.io/
+ https://github.com/jupyter/nbconvert/
+ https://pypi.org/project/nbconvert/
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ dev-python/beautifulsoup4[${PYTHON_USEDEP}]
+ dev-python/bleach[${PYTHON_USEDEP}]
+ dev-python/defusedxml[${PYTHON_USEDEP}]
+ >=dev-python/jinja-3.0[${PYTHON_USEDEP}]
+ >=dev-python/jupyter-core-4.7[${PYTHON_USEDEP}]
+ dev-python/jupyterlab-pygments[${PYTHON_USEDEP}]
+ >=dev-python/markupsafe-2.0[${PYTHON_USEDEP}]
+ <dev-python/mistune-4[${PYTHON_USEDEP}]
+ >=dev-python/nbclient-0.5.0[${PYTHON_USEDEP}]
+ >=dev-python/nbformat-5.7[${PYTHON_USEDEP}]
+ dev-python/packaging[${PYTHON_USEDEP}]
+ >=dev-python/pandocfilters-1.4.1[${PYTHON_USEDEP}]
+ >=dev-python/pygments-2.4.1[${PYTHON_USEDEP}]
+ dev-python/tinycss2[${PYTHON_USEDEP}]
+ >=dev-python/traitlets-5.1.1[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/ipykernel[${PYTHON_USEDEP}]
+ >=dev-python/ipywidgets-7.5[${PYTHON_USEDEP}]
+ dev-python/flaky[${PYTHON_USEDEP}]
+ )
+"
+
+EPYTEST_XDIST=1
+distutils_enable_tests pytest
+
+src_prepare() {
+ mkdir -p share/templates/classic/static || die
+ # tries to refetch stuff even if it's already present
+ sed -e 's:css = .*:raise PermissionError("You shall not fetch!"):' \
+ -i hatch_build.py || die
+ distutils-r1_src_prepare
+}
+
+src_test() {
+ virtx distutils-r1_src_test
+}
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # TODO
+ tests/test_nbconvertapp.py::TestNbConvertApp::test_convert_full_qualified_name
+ tests/test_nbconvertapp.py::TestNbConvertApp::test_post_processor
+ # crazy qtweb* stuff, perhaps permissions
+ tests/exporters/test_qtpdf.py::TestQtPDFExporter::test_export
+ tests/exporters/test_qtpng.py::TestQtPNGExporter::test_export
+ )
+
+ # virtx implies nonfatal, make it explicit to avoid confusion
+ nonfatal epytest || die
+}
+
+pkg_postinst() {
+ if ! has_version virtual/pandoc; then
+ einfo "Pandoc is required for converting to formats other than Python,"
+ einfo "HTML, and Markdown. If you need this functionality, install"
+ einfo "app-text/pandoc or app-text/pandoc-bin."
+ fi
+}