summaryrefslogtreecommitdiff
path: root/dev-python/nbconvert
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-04-04 11:22:15 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-04-04 11:22:15 +0100
commit7f6382ebb44b75c53021d4c4ab77d6b34aed21ac (patch)
tree4d92ef3af5a26ff8a8a5a1ec4f21d18c65f56fe2 /dev-python/nbconvert
parent41e5b5c1f11820df590e0a245bbddf224bc07823 (diff)
gentoo auto-resync : 04:04:2023 - 11:22:14
Diffstat (limited to 'dev-python/nbconvert')
-rw-r--r--dev-python/nbconvert/Manifest2
-rw-r--r--dev-python/nbconvert/nbconvert-7.3.0.ebuild93
2 files changed, 95 insertions, 0 deletions
diff --git a/dev-python/nbconvert/Manifest b/dev-python/nbconvert/Manifest
index d04b64f6d0b6..aed7404ef621 100644
--- a/dev-python/nbconvert/Manifest
+++ b/dev-python/nbconvert/Manifest
@@ -1,5 +1,7 @@
DIST nbconvert-7.2.10.tar.gz 870708 BLAKE2B 837b5cf70f530b8fd3d566809d8d4faefdb3c4581b46e317d218a08bb06b80fdf59dcbd6c337b7fd62a9fdff676ea1cec941a7f6641c54ebee066a1bec19ffcd SHA512 078d6f1375f595f30db9eeebab55842353d549a294290a185c3817fc0bb2459c392120f089890409eec7cfe0fec7909752d20e4c55123249a4685d34655e0c05
DIST nbconvert-7.2.9.tar.gz 870386 BLAKE2B aea62f29d3e696c70d77ab73cc89347a4e0c8e077e98c45331608f7117fb3c98165bf3da89e4f3bf23b9d62c618289d98c9103c5b2998ca81f65cbfda65ca536 SHA512 0053e0e88f279d2fe430e516bcc19f98191e9ce414546ab1ff214f37c8f1cdfc4fc101faa4b5f1d5955fdc65c87aad367f5a5f12ce5991c68c015c5083f2f30c
+DIST nbconvert-7.3.0.tar.gz 879918 BLAKE2B cf1414f5c6a41222f576a66ca8aa49f98d5ee4a0cd6bedcd779a6c429d46550e0435e60723255358f1ccf51b508d74e7461521889cbb7e6dfb10377175ea78a2 SHA512 a7030cced31ae749d9625f7fb7cc2bee17c10fcd90e83f36efed1c00758d02e47ed9d90aa907c2acbe979810a561d48d9fe854a3786b60418beacdd471b14b8f
EBUILD nbconvert-7.2.10-r1.ebuild 3045 BLAKE2B d069c02a385aa2d8b9790693ca87ed0c2ef6fb22ee41c3d967858989f55074d36c6244ffbfa28c7de3c373dea930e6ff9d7270980b95c20120d4876d34261cbc SHA512 43d0bb082c8c0a4c925b44fbece61e3727b046cafa1302dd1618f777e4ce36a6def606dcc1a6e9d955c77b0523b0c5fdb46c584a27e8818f99e6193f79e06dc8
EBUILD nbconvert-7.2.9.ebuild 2772 BLAKE2B 9b7225971cad9b1d88969dd826d4e0712bdd2a7f8e84ad766f375668c03b72832c5cbfa31199a6bcc60ac0d61baf2ddd71dcf4baeda08c7ee9b70b91b0671da6 SHA512 9198cc3fcf2b48e4888d62b656de9b1915600694d18ff092ba01ec553e39184ed126af9641819286e45e36cc60e726eca1a64b5d79ec7bd0554ac72a56b557c5
+EBUILD nbconvert-7.3.0.ebuild 3045 BLAKE2B d069c02a385aa2d8b9790693ca87ed0c2ef6fb22ee41c3d967858989f55074d36c6244ffbfa28c7de3c373dea930e6ff9d7270980b95c20120d4876d34261cbc SHA512 43d0bb082c8c0a4c925b44fbece61e3727b046cafa1302dd1618f777e4ce36a6def606dcc1a6e9d955c77b0523b0c5fdb46c584a27e8818f99e6193f79e06dc8
MISC metadata.xml 527 BLAKE2B a915103b3eaf57236f4257c98354a1e3733771369ac825fa8bbc4f79f0d1a23272dc86e744513620fbee37792e813a15dbb955e633a7c57597c3c38657ed05d3 SHA512 b60a311ce52915dbc12addd4a882670ac96ff8b3be2aa651eaac3d0963d6e73a72eaafd53f90fb685599504857e6bcd0568071962d7696c2605462b77260ad6a
diff --git a/dev-python/nbconvert/nbconvert-7.3.0.ebuild b/dev-python/nbconvert/nbconvert-7.3.0.ebuild
new file mode 100644
index 000000000000..f8c9b4fd4ccd
--- /dev/null
+++ b/dev-python/nbconvert/nbconvert-7.3.0.ebuild
@@ -0,0 +1,93 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( python3_{9..11} )
+
+inherit distutils-r1 multiprocessing pypi virtualx
+
+DESCRIPTION="Converting Jupyter Notebooks"
+HOMEPAGE="
+ https://nbconvert.readthedocs.io/
+ https://github.com/jupyter/nbconvert/
+ https://pypi.org/project/nbconvert/
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ia64 ~ppc ~riscv ~x86"
+
+RDEPEND="
+ dev-python/beautifulsoup4[${PYTHON_USEDEP}]
+ dev-python/bleach[${PYTHON_USEDEP}]
+ dev-python/defusedxml[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ >=dev-python/importlib_metadata-3.6[${PYTHON_USEDEP}]
+ ' 3.9)
+ >=dev-python/jinja-3.0[${PYTHON_USEDEP}]
+ >=dev-python/jupyter_core-4.7[${PYTHON_USEDEP}]
+ dev-python/jupyterlab_pygments[${PYTHON_USEDEP}]
+ >=dev-python/markupsafe-2.0[${PYTHON_USEDEP}]
+ >=dev-python/mistune-2.0.2[${PYTHON_USEDEP}]
+ >=dev-python/nbclient-0.5.0[${PYTHON_USEDEP}]
+ >=dev-python/nbformat-5.1[${PYTHON_USEDEP}]
+ dev-python/packaging[${PYTHON_USEDEP}]
+ >=dev-python/pandocfilters-1.4.1[${PYTHON_USEDEP}]
+ >=dev-python/pygments-2.4.1[${PYTHON_USEDEP}]
+ dev-python/tinycss2[${PYTHON_USEDEP}]
+ >=dev-python/traitlets-5.1.1[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/ipykernel[${PYTHON_USEDEP}]
+ >=dev-python/ipywidgets-7[${PYTHON_USEDEP}]
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ mkdir -p share/templates/classic/static || die
+ # tries to refetch stuff even if it's already present
+ sed -e 's:css = .*:raise PermissionError("You shall not fetch!"):' \
+ -i hatch_build.py || die
+ distutils-r1_src_prepare
+}
+
+src_test() {
+ virtx distutils-r1_src_test
+}
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # Missing pyppeteer for now
+ # TODO: Doesn't skip?
+ nbconvert/exporters/tests/test_webpdf.py
+ # Needs pyppeteer too
+ 'nbconvert/tests/test_nbconvertapp.py::TestNbConvertApp::test_webpdf_with_chromium'
+ # TODO
+ nbconvert/exporters/tests/test_qtpng.py::TestQtPNGExporter::test_export
+ nbconvert/tests/test_nbconvertapp.py::TestNbConvertApp::test_convert_full_qualified_name
+ nbconvert/tests/test_nbconvertapp.py::TestNbConvertApp::test_post_processor
+ # latex failing, might be too new pandoc
+ nbconvert/tests/test_nbconvertapp.py::TestNbConvertApp::test_filename_spaces
+ nbconvert/tests/test_nbconvertapp.py::TestNbConvertApp::test_pdf
+ # too new pandoc but we don't have old anymore
+ nbconvert/utils/tests/test_pandoc.py::TestPandoc::test_minimal_version
+ nbconvert/utils/tests/test_pandoc.py::TestPandoc::test_pandoc_available
+ )
+
+ # virtx implies nonfatal, make it explicit to avoid confusion
+ nonfatal epytest -n "$(makeopts_jobs)" --pyargs nbconvert || die
+}
+
+pkg_postinst() {
+ if ! has_version app-text/pandoc && ! has_version app-text/pandoc-bin; then
+ einfo "Pandoc is required for converting to formats other than Python,"
+ einfo "HTML, and Markdown. If you need this functionality, install"
+ einfo "app-text/pandoc or app-text/pandoc-bin."
+ fi
+}