summaryrefslogtreecommitdiff
path: root/dev-python/nbconvert
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2025-01-29 22:43:19 +0000
committerV3n3RiX <venerix@koprulu.sector>2025-01-29 22:43:19 +0000
commitfa19575643c607e28b1572821c413ad7cb8eea09 (patch)
tree9d9b05acd34c77d7708182eac258ad26975949c7 /dev-python/nbconvert
parentfc4ad6e568738af8995c2e87896c671c39eb8c72 (diff)
gentoo auto-resync : 29:01:2025 - 22:43:19
Diffstat (limited to 'dev-python/nbconvert')
-rw-r--r--dev-python/nbconvert/Manifest2
-rw-r--r--dev-python/nbconvert/nbconvert-7.16.6.ebuild80
2 files changed, 82 insertions, 0 deletions
diff --git a/dev-python/nbconvert/Manifest b/dev-python/nbconvert/Manifest
index 8101e95c406d..336a4d43d17a 100644
--- a/dev-python/nbconvert/Manifest
+++ b/dev-python/nbconvert/Manifest
@@ -1,3 +1,5 @@
DIST nbconvert-7.16.5.tar.gz 856367 BLAKE2B d1b44e2665a4a96c2d7a78c986b93c5e9e5e12bc984f20735a03e1fb28d81b43cc7b1d6ebf0a8dad56b470e5e683c672f096c9fd98d22852f5c8fe94a9c2ce44 SHA512 703ed3e33efc2a42c8bde84829b82a8e9ef2313c1766bfc0ab642743173ade642d4a796afa9ef489ba2f58bd75fc0ce6e50009676e2ef1d3848967ddf775f861
+DIST nbconvert-7.16.6.tar.gz 857715 BLAKE2B 1fdd6397c92f281554fb528a82926e1cf03cf0d5c6c50b4bcc6d4e3ee62c54917d08cfdf879ee6053bb096cb0de4109187ec2abfc14cf628e605bf6bca01bd5b SHA512 527536700e870d0352feb070b1d4cff6fbad11503bdeff860a1fdd6e142b776dc260a60d6c3e887c52ebc83c9465df569b9d27aead53c02a42a0adb60733371d
EBUILD nbconvert-7.16.5.ebuild 2309 BLAKE2B a5526f3b888dc1ecdbcf47d6bd9d9b497dea0b0d4e9c0ce097737da12d5feb2db56ec61e6655a4a17821933efda61c33a2b9a1619b5c04ea46781bd392ca8404 SHA512 29c01140c2f91773c8c35ba5cb8f07ee6109d48c75b3df5c4a7ee523eb218033ffa4d44df8291d74d80ccba59159eba142dfd483a3381903a12d1a5673e6d462
+EBUILD nbconvert-7.16.6.ebuild 2316 BLAKE2B 534100e3b0d6525f57038093b9c63662a649681f85ba6f5735db7141994a79face4bf355ec056993ce5888c762753ade6607940327389aa8dc5ab9df90daf7b8 SHA512 2ff5bb98a087e68ef453cafc463e9385c484c11b4f19f0bf37df42ca9f01346fc1fbb42e7f61d5e8ecb3893f8c3dca597b559c7f765c0cbbf648f442c4831a3a
MISC metadata.xml 527 BLAKE2B a915103b3eaf57236f4257c98354a1e3733771369ac825fa8bbc4f79f0d1a23272dc86e744513620fbee37792e813a15dbb955e633a7c57597c3c38657ed05d3 SHA512 b60a311ce52915dbc12addd4a882670ac96ff8b3be2aa651eaac3d0963d6e73a72eaafd53f90fb685599504857e6bcd0568071962d7696c2605462b77260ad6a
diff --git a/dev-python/nbconvert/nbconvert-7.16.6.ebuild b/dev-python/nbconvert/nbconvert-7.16.6.ebuild
new file mode 100644
index 000000000000..891f16a69514
--- /dev/null
+++ b/dev-python/nbconvert/nbconvert-7.16.6.ebuild
@@ -0,0 +1,80 @@
+# Copyright 1999-2025 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( pypy3 python3_{10..13} )
+
+inherit distutils-r1 pypi virtualx
+
+DESCRIPTION="Converting Jupyter Notebooks"
+HOMEPAGE="
+ https://nbconvert.readthedocs.io/
+ https://github.com/jupyter/nbconvert/
+ https://pypi.org/project/nbconvert/
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~loong ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ dev-python/beautifulsoup4[${PYTHON_USEDEP}]
+ dev-python/bleach[${PYTHON_USEDEP}]
+ dev-python/defusedxml[${PYTHON_USEDEP}]
+ >=dev-python/jinja2-3.0[${PYTHON_USEDEP}]
+ >=dev-python/jupyter-core-4.7[${PYTHON_USEDEP}]
+ dev-python/jupyterlab-pygments[${PYTHON_USEDEP}]
+ >=dev-python/markupsafe-2.0[${PYTHON_USEDEP}]
+ <dev-python/mistune-4[${PYTHON_USEDEP}]
+ >=dev-python/nbclient-0.5.0[${PYTHON_USEDEP}]
+ >=dev-python/nbformat-5.7[${PYTHON_USEDEP}]
+ dev-python/packaging[${PYTHON_USEDEP}]
+ >=dev-python/pandocfilters-1.4.1[${PYTHON_USEDEP}]
+ >=dev-python/pygments-2.4.1[${PYTHON_USEDEP}]
+ >=dev-python/traitlets-5.1.1[${PYTHON_USEDEP}]
+"
+# via bleach[css]
+RDEPEND+="
+ dev-python/tinycss2[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/ipykernel[${PYTHON_USEDEP}]
+ >=dev-python/ipywidgets-7.5[${PYTHON_USEDEP}]
+ dev-python/flaky[${PYTHON_USEDEP}]
+ dev-python/pytest-rerunfailures[${PYTHON_USEDEP}]
+ )
+"
+
+EPYTEST_XDIST=1
+distutils_enable_tests pytest
+
+src_test() {
+ virtx distutils-r1_src_test
+}
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # TODO
+ tests/test_nbconvertapp.py::TestNbConvertApp::test_convert_full_qualified_name
+ tests/test_nbconvertapp.py::TestNbConvertApp::test_post_processor
+ # crazy qtweb* stuff, perhaps permissions
+ tests/exporters/test_qtpdf.py::TestQtPDFExporter::test_export
+ tests/exporters/test_qtpng.py::TestQtPNGExporter::test_export
+ )
+
+ # virtx implies nonfatal, make it explicit to avoid confusion
+ # tests/preprocessors/test_execute.py are extremely flaky over output
+ # buffering
+ nonfatal epytest --reruns=10 || die
+}
+
+pkg_postinst() {
+ if ! has_version virtual/pandoc; then
+ einfo "Pandoc is required for converting to formats other than Python,"
+ einfo "HTML, and Markdown. If you need this functionality, install"
+ einfo "app-text/pandoc or app-text/pandoc-bin."
+ fi
+}