summaryrefslogtreecommitdiff
path: root/dev-python/ndg-httpsclient
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-python/ndg-httpsclient
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-python/ndg-httpsclient')
-rw-r--r--dev-python/ndg-httpsclient/Manifest5
-rw-r--r--dev-python/ndg-httpsclient/metadata.xml12
-rw-r--r--dev-python/ndg-httpsclient/ndg-httpsclient-0.4.0.ebuild27
-rw-r--r--dev-python/ndg-httpsclient/ndg-httpsclient-0.4.2-r1.ebuild63
4 files changed, 107 insertions, 0 deletions
diff --git a/dev-python/ndg-httpsclient/Manifest b/dev-python/ndg-httpsclient/Manifest
new file mode 100644
index 000000000000..ec11fa92a281
--- /dev/null
+++ b/dev-python/ndg-httpsclient/Manifest
@@ -0,0 +1,5 @@
+DIST ndg_httpsclient-0.4.0.tar.gz 24038 BLAKE2B 147ba36c966b2220c068ce3376bd84259807f66c57141fee4ed95457333cd9d568d19fd4d3348e7ef25d456e3f7d794f83f8302a15beb16f451aa02ef6181848 SHA512 3c0225a20c25cf0f12f03005bb79e738527c0488bb660c1eb3b55c505a0ef503002d37fcffb3d013e5f91101bdd03080a68d5805d6d29b682cc01bdc9f0e4a19
+DIST ndg_httpsclient-0.4.2.tar.gz 25062 BLAKE2B 740075cf3031547028afa3ec2e005e5430e7fbb5c2bfd444e4051c60a9ac14ecacd3048f87f546516bddc4c0403738aa3ef227b3fd763a48bca28da09a47f707 SHA512 c7d6f442242ce01f69d2386b8ed41e4e5f72a2523ecbe38785c4333405f1b000e298133ccc4169d9685a3dcdcf0b20567c8e4b2dfd36f42721d36c73ee27d90a
+EBUILD ndg-httpsclient-0.4.0.ebuild 820 BLAKE2B cddc3b89b9af7ed5e612a347367ff20e3d634b2d73c033c4bc781b8b11959f7599aca5fd995cf6a58b9ec26670a65058a5bf96b2c9c3ffeb4bec0f1de6953905 SHA512 4178c0b5461c7b08318d77c6041585a9a62846b5220c65157054c3bcf315fbdfab7c89e8bbe458b91eb4e3b9b02269a59f14a5952e4a8810ce797d380820ee59
+EBUILD ndg-httpsclient-0.4.2-r1.ebuild 1649 BLAKE2B 65dc28a0e743b4984a6d19f677423067f85460400683725ee294ab5b3e17ec072541d849676c11b2a5384451fb57df125f4affb618b171587b519019b6c019a6 SHA512 e20c90468e41465f2cb24a80e76204a9b28526ad2c6a722aa5b2697bd463b8373558e462d5282a0bbdb008c3a4e07ae1016201746b44d00b0fbba90b78dfa4f0
+MISC metadata.xml 393 BLAKE2B bfb003be060fefbbdd7e46aafa06dba5c0207726a303b4d0794a115b2995bb65505ceda29ad37f0cf6d86a8f1c0521f14a004869ec8d8051e374bd11255e7266 SHA512 1092b2a6c3d9ed56cc6429ce9b1ffeb14f18934f2dc8dc9e34b28eb9a048304f31634fe2d7265a599afd338033605c831290b903e933e1a1634ed8fdbb1719ae
diff --git a/dev-python/ndg-httpsclient/metadata.xml b/dev-python/ndg-httpsclient/metadata.xml
new file mode 100644
index 000000000000..9946c2697cca
--- /dev/null
+++ b/dev-python/ndg-httpsclient/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="pypi">ndg-httpsclient</remote-id>
+ <remote-id type="github">cedadev/ndg_httpsclient</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/ndg-httpsclient/ndg-httpsclient-0.4.0.ebuild b/dev-python/ndg-httpsclient/ndg-httpsclient-0.4.0.ebuild
new file mode 100644
index 000000000000..99e961e55593
--- /dev/null
+++ b/dev-python/ndg-httpsclient/ndg-httpsclient-0.4.0.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} pypy pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Provides enhanced HTTPS support for httplib and urllib2 using PyOpenSSL"
+HOMEPAGE="
+ https://github.com/cedadev/ndg_httpsclient/
+ https://pypi.org/project/ndg-httpsclient/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P/-/_}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="alpha amd64 arm arm64 hppa ia64 m68k ~mips ppc ppc64 s390 sh sparc x86 ~x86-fbsd ~amd64-linux ~x86-linux ~x64-macos ~x86-macos"
+IUSE=""
+
+RDEPEND="dev-python/pyopenssl[$(python_gen_usedep 'python*' pypy)]"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+
+S="${WORKDIR}/${P/-/_}"
+
+# doc build by Makefile in folder documentation is broken
diff --git a/dev-python/ndg-httpsclient/ndg-httpsclient-0.4.2-r1.ebuild b/dev-python/ndg-httpsclient/ndg-httpsclient-0.4.2-r1.ebuild
new file mode 100644
index 000000000000..6f43d4f8b6da
--- /dev/null
+++ b/dev-python/ndg-httpsclient/ndg-httpsclient-0.4.2-r1.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} pypy pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Provides enhanced HTTPS support for httplib and urllib2 using PyOpenSSL"
+HOMEPAGE="
+ https://github.com/cedadev/ndg_httpsclient/
+ https://pypi.org/project/ndg-httpsclient/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P/-/_}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x64-cygwin ~x86-fbsd ~amd64-linux ~x86-linux ~x64-macos ~x86-macos"
+IUSE="test"
+
+RDEPEND="dev-python/pyopenssl[$(python_gen_usedep 'python*' pypy)]"
+# we need to block the previous versions since incorrect namespace
+# install breaks tests
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ !!<dev-python/ndg-httpsclient-0.4.2-r1
+ dev-libs/openssl:0
+ )"
+
+S="${WORKDIR}/${P/-/_}"
+
+# doc build by Makefile in folder documentation is broken
+
+src_test() {
+ # we need to start a fake https server for tests to connect to
+ ( cd ndg/httpsclient/test && sh ./scripts/openssl_https_server.sh ) &
+ local server_pid=${!}
+
+ distutils-r1_src_test
+
+ kill "${server_pid}"
+ wait
+}
+
+python_test() {
+ "${PYTHON}" -m unittest discover -v || die "Tests fail with ${EPYTHON}"
+}
+
+python_install() {
+ distutils-r1_python_install
+
+ # install the namespace (this is the only package in ::gentoo
+ # using it; we'll split it if we add more)
+ python_moduleinto ndg
+ python_domodule ndg/__init__.py
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+
+ find "${D}" -name '*.pth' -delete || die
+}