summaryrefslogtreecommitdiff
path: root/dev-python/noiseprotocol/noiseprotocol-0.3.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-06-03 21:32:31 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-06-03 21:32:31 +0100
commit5043a584ce7a3eb644e68694a3266c1a5d2ccba5 (patch)
tree2401f70bb9284c4237ee848dcb65c610db18a643 /dev-python/noiseprotocol/noiseprotocol-0.3.1.ebuild
parentc1503bdaa031111d22d91db2f41dad440fb148e8 (diff)
gentoo auto-resync : 03:06:2023 - 21:32:31
Diffstat (limited to 'dev-python/noiseprotocol/noiseprotocol-0.3.1.ebuild')
-rw-r--r--dev-python/noiseprotocol/noiseprotocol-0.3.1.ebuild16
1 files changed, 12 insertions, 4 deletions
diff --git a/dev-python/noiseprotocol/noiseprotocol-0.3.1.ebuild b/dev-python/noiseprotocol/noiseprotocol-0.3.1.ebuild
index e564c8306957..629395a841b5 100644
--- a/dev-python/noiseprotocol/noiseprotocol-0.3.1.ebuild
+++ b/dev-python/noiseprotocol/noiseprotocol-0.3.1.ebuild
@@ -3,20 +3,28 @@
EAPI=8
-PYTHON_COMPAT=( python3_{10..11} )
+PYTHON_COMPAT=( python3_{10..12} )
DISTUTILS_USE_PEP517=setuptools
inherit distutils-r1
DESCRIPTION="Implementation of Noise Protocol Framework. Compatible with revisions 32 and 33."
-HOMEPAGE="https://pypi.org/project/noiseprotocol"
-SRC_URI="https://github.com/plizonczyk/${PN}/archive/refs/tags/v${PV}.tar.gz -> ${P}.gh.tar.gz"
+HOMEPAGE="
+ https://github.com/plizonczyk/noiseprotocol/
+ https://pypi.org/project/noiseprotocol/
+"
+SRC_URI="
+ https://github.com/plizonczyk/noiseprotocol/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
LICENSE="MIT"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-RDEPEND="dev-python/cryptography[${PYTHON_USEDEP}]"
+RDEPEND="
+ dev-python/cryptography[${PYTHON_USEDEP}]
+"
distutils_enable_tests pytest