summaryrefslogtreecommitdiff
path: root/dev-python/notify2/notify2-0.3.1-r3.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-02-02 01:39:05 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-02-02 01:39:05 +0000
commitfcc5224904648a8e6eb528d7603154160a20022f (patch)
tree3bfce096b38a9cea8eed13fc70c1526c456e9abd /dev-python/notify2/notify2-0.3.1-r3.ebuild
parent2fd57282f0262ca084e05b0f2c63fbada395d02b (diff)
gentoo resync : 02.02.2022
Diffstat (limited to 'dev-python/notify2/notify2-0.3.1-r3.ebuild')
-rw-r--r--dev-python/notify2/notify2-0.3.1-r3.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/dev-python/notify2/notify2-0.3.1-r3.ebuild b/dev-python/notify2/notify2-0.3.1-r3.ebuild
new file mode 100644
index 000000000000..18e4358229b8
--- /dev/null
+++ b/dev-python/notify2/notify2-0.3.1-r3.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1 virtualx
+
+DESCRIPTION="Python interface to DBus notifications"
+HOMEPAGE="https://bitbucket.org/takluyver/pynotify2"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86"
+IUSE="examples"
+
+RDEPEND="dev-python/dbus-python[${PYTHON_USEDEP}]"
+BDEPEND="test? (
+ dev-python/pygobject[${PYTHON_USEDEP}]
+ sys-apps/dbus[X]
+ x11-libs/gdk-pixbuf[introspection]
+ virtual/notification-daemon
+)"
+
+distutils_enable_tests unittest
+
+python_test() {
+ virtx eunittest
+}
+
+python_install_all() {
+ if use examples; then
+ rm examples/notify2.py || die
+ dodoc -r examples
+ fi
+ distutils-r1_python_install_all
+}