summaryrefslogtreecommitdiff
path: root/dev-python/nspektr
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-08-07 09:24:29 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-08-07 09:24:29 +0100
commitfa77846c708f4d0541b610846a5f2ed14b4b20c1 (patch)
tree35860ca9d75749380daddffe86bbd70d3c5866a9 /dev-python/nspektr
parent640c4638f1e12a2c71f539ee18564a0c82d19947 (diff)
gentoo auto-resync : 07:08:2023 - 09:24:28
Diffstat (limited to 'dev-python/nspektr')
-rw-r--r--dev-python/nspektr/Manifest2
-rw-r--r--dev-python/nspektr/nspektr-0.5.0.ebuild54
2 files changed, 56 insertions, 0 deletions
diff --git a/dev-python/nspektr/Manifest b/dev-python/nspektr/Manifest
index 56daba2e0288..45f54f6e0b4f 100644
--- a/dev-python/nspektr/Manifest
+++ b/dev-python/nspektr/Manifest
@@ -1,3 +1,5 @@
DIST nspektr-0.4.0.tar.gz 7734 BLAKE2B 66a52f5080c78accc75e2193dab6d07a6257330f9938ac463c160d7e1f9740294416657193e5831f564354eb0dc3112a9ab41676e1c928ac40769d2a4d218089 SHA512 c8e8dcadd3ccd49bc9b1a38d2ff9f1d8d6f85665d3830cc9d7975ec1c63b1e2f1a7a64e12457701ca658e2e0e30cac7652be6d706a4e47ba6a61ae76d9be8875
+DIST nspektr-0.5.0.tar.gz 8573 BLAKE2B a96aaaee5cd309272d5b0c78eaf9793baf1406e427a142595b67693d513d5badac064149587c02cdf02cdd7720fafeb2787fc98a9db79cc573e77d6158afd4d4 SHA512 b7293a6ccb34a5c4b87a9b28de170322296adf2d883e7671df05ac06453023190ed588eb8e1677b7c5383b6fc5962c079d363ebb214ebb9f8516cfd2039e6167
EBUILD nspektr-0.4.0.ebuild 1404 BLAKE2B c6ded353dc4120a07163b320045e641feff910d6b7de35e628ca9b0ecb01e106509bc92f555186139c6314372f1047a324b100afb50872bb08f41efa3e5f9698 SHA512 ce34ea57f9c1cb9bce4494b551e3e7fb82a0d42bc156e005b6f70a274dcd7423bc0bb3042d5cf37ea4a0c0b0fe33dca56d191938ed92a4ab93bc17c1bc53b2c3
+EBUILD nspektr-0.5.0.ebuild 1412 BLAKE2B 5d84df7be4c9ea9ed3c6d993d71aa1b713a069e47c92b3af2938c04b8a16d3ed19ca0cc3f9146fff396e2b8c73a5b52d41d2448c315cf19362c20c19fe8e2fd3 SHA512 29a15e727137cff7672935b7007eb6bcb4a05b14ffaa50008e1d484787a4106d39d08c70784b2785423d4a0c9eedfd57f8b4d39b25628f8bc6c6884c9aa5f4a6
MISC metadata.xml 367 BLAKE2B e0c1c36f285783d80f298d38d3821fc4aaaf81b83e2a0226972105093406446426fc7e62c3a92138ab2a925e04d1fb58744cb3d51b62941b1118d3b3628aba71 SHA512 bbb3c37cf215be4b8fa83d0c9a592acc3dbd60bab0afeb979fd343b80c6b71766c155b94f7fd8a9f835330f4038194c9bed0b91b2bcac94b1c75409f92f5c9f2
diff --git a/dev-python/nspektr/nspektr-0.5.0.ebuild b/dev-python/nspektr/nspektr-0.5.0.ebuild
new file mode 100644
index 000000000000..a5cbcdf9817a
--- /dev/null
+++ b/dev-python/nspektr/nspektr-0.5.0.ebuild
@@ -0,0 +1,54 @@
+# Copyright 2022-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+# please keep this ebuild at EAPI 7 -- sys-apps/portage dep
+EAPI=7
+
+DISTUTILS_USE_PEP517=flit
+PYTHON_COMPAT=( pypy3 python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Distribution package dependency inspector"
+HOMEPAGE="
+ https://github.com/jaraco/nspektr/
+ https://pypi.org/project/nspektr/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~arm64-macos ~ppc-macos ~x64-macos ~x64-solaris"
+
+RDEPEND="
+ >=dev-python/jaraco-context-4.1.1-r2[${PYTHON_USEDEP}]
+ >=dev-python/jaraco-functools-3.5.0-r2[${PYTHON_USEDEP}]
+ >=dev-python/more-itertools-8.12.0-r1[${PYTHON_USEDEP}]
+ >=dev-python/packaging-21.3-r2[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
+
+src_configure() {
+ grep -q 'build-backend = "setuptools' pyproject.toml ||
+ die "Upstream changed build-backend, recheck"
+ # write a custom pyproject.toml to ease setuptools bootstrap
+ cat > pyproject.toml <<-EOF || die
+ [build-system]
+ requires = ["flit_core >=3.2,<4"]
+ build-backend = "flit_core.buildapi"
+
+ [project]
+ name = "nspektr"
+ version = "${PV}"
+ description = "package inspector"
+
+ # tests inspect itself
+ [project.optional-dependencies]
+ docs = [
+ "fake-nonexisting",
+ ]
+ testing = [
+ "pytest",
+ ]
+ EOF
+}