summaryrefslogtreecommitdiff
path: root/dev-python/numpy
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-04-24 00:08:50 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-04-24 00:08:50 +0100
commitb2523734e380d060074602eb5ce53daf7d98803b (patch)
tree0f6e9c0a8339a7e6bb0b44089507392951245899 /dev-python/numpy
parent622b78d0d832282505f685f2f442c34ea0e8a7b1 (diff)
gentoo auto-resync : 24:04:2023 - 00:08:50
Diffstat (limited to 'dev-python/numpy')
-rw-r--r--dev-python/numpy/Manifest2
-rw-r--r--dev-python/numpy/numpy-1.24.3.ebuild170
2 files changed, 172 insertions, 0 deletions
diff --git a/dev-python/numpy/Manifest b/dev-python/numpy/Manifest
index 346d96df170e..1dc6d074af4c 100644
--- a/dev-python/numpy/Manifest
+++ b/dev-python/numpy/Manifest
@@ -1,6 +1,8 @@
AUX numpy-1.22.0-no-hardcode-blasv2.patch 2710 BLAKE2B 71da07805e25acc58120da2b8d8692ec5893040eee3c2842620e2a9186062936082f34610d3056c44e44a921116f99158dfb7481c4eccc82d33b3b18a63b379e SHA512 87bcecee3435dedcd87128c81d0002a786b4b23928973216f32c8d12b797d6a9948c3e7b41142235abe35734683e6ef84c02ffe255ba492a0ad43626071dc5a9
DIST numpy-1.24.0.tar.gz 10897101 BLAKE2B 59e2b913f90de76589d8fbb2f07e2d389012c7f6ce9bd641bc4837776465ce9c41c34f19f92bee55d4bae6245c1d2c84315b359ef0b089fd68d31cd7e7ec44b1 SHA512 3b4e6255b8d39e8504a50ecd3c2ba09d5b16d3f6c70b23b67e4dbf03d1fe390c55030f46090341d39a1ee8228c61ad6212fdc6e4579fcec9e26b4dbe70268661
DIST numpy-1.24.2.tar.gz 10906862 BLAKE2B e48f65eab709f0c57ec378d813a7b65bcaca6d5960b559d6db1c60726e5cf12517f4b2e1636b0ff815a2109925edccba200270db5170fd0aff5fd635919165ac SHA512 145fd7fb3919a185f75076d51b92c54a7fb1b776b637752ca15fdee15b239d6a517ef1bb8cded7c92e059cf6cda0146c24943c042d19b791e81125bc0ad4b820
+DIST numpy-1.24.3.tar.gz 10909904 BLAKE2B 3b14f8b6a7bd484de43c3b0e57f161388d6226e05ed9bc3d1edfaafc713b9597c7574b9b9c20b4e3a6bd291d32a607d95c72d6e25fa346ffdaf97c94767bc315 SHA512 d4b5841cbe68ee6653f99018e4e0182f2e5519a1cd69c14e0a95aa180f878e6a6786ccf0a7c78bf0d511c53e7535d7144fee428572dec7a4b60b25c8a1c0c9e1
EBUILD numpy-1.24.0.ebuild 4274 BLAKE2B 57ebcd94b9c33477d87500f8b8e9c98faa5a3ec00e855a3215863249b2c7810eb7198e9aa13db0859abad4c4f6b4171419e62022c73144011bfd143bde054424 SHA512 84c221d759a2c80e9c27f34d10b17b82e845d40d0213a73a65957829e38f78b86fedaccbd28dc0d94474976363d5fc1e6b2faab0807fdcfeceb09efa1ce2ed58
EBUILD numpy-1.24.2.ebuild 4396 BLAKE2B 10efeb00b8f685ee0b9a7afd88465b2812612698cbbb18b161405cb790f36019dfbac351738c4e4a286752310134f7f685e9eafc0b28ae5a50bcfbf4f38fb160 SHA512 be793b1b14c5eb2839fb40e5a890704b5b341320bee8869718f69dc1eb03bdaff67ebee700b9f1a90c99086498b7bb8e8dfbd2a6ac536bd065ba7fb6002aa39f
+EBUILD numpy-1.24.3.ebuild 4548 BLAKE2B 1eaa7f8c56213e8aa6a9c54b65f337752cc9643b1e0da99b8c6c38fdf5d94136c9c59bb26b8bdc21280df7961130762d08f4913e8395a1723c3985b124810c44 SHA512 0b3e10c3e8e9f756dd22808dda7ba91c27b33176bf833db30c191c31fad0ada5c04a904c682e96b12827af523b8d06ac9bfd98bda620ccb09461f2cd0fd66a38
MISC metadata.xml 932 BLAKE2B 7a4af31f613bab05ff542da48bf6ff1484d9df2459f559516e71329451dd739d3df0fead507c8033d94ab9ed516b68efe7f21819a8cd6ca303643d8c8bc34e86 SHA512 32cb8c1ab61521a02cbec38f6ea383f074e50d46aa3462ddcb85710f9d348e8e628cf2a5725e3cd921cc32f02885a1b5f02125639f0ec885384eeeff7f468a06
diff --git a/dev-python/numpy/numpy-1.24.3.ebuild b/dev-python/numpy/numpy-1.24.3.ebuild
new file mode 100644
index 000000000000..57a4812e6bfc
--- /dev/null
+++ b/dev-python/numpy/numpy-1.24.3.ebuild
@@ -0,0 +1,170 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_EXT=1
+PYTHON_COMPAT=( python3_{9..11} pypy3 )
+PYTHON_REQ_USE="threads(+)"
+
+FORTRAN_NEEDED=lapack
+
+inherit distutils-r1 flag-o-matic fortran-2 multiprocessing pypi
+inherit toolchain-funcs
+
+DOC_PV=${PV}
+DESCRIPTION="Fast array and numerical python library"
+HOMEPAGE="
+ https://numpy.org/
+ https://github.com/numpy/numpy/
+ https://pypi.org/project/numpy/
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
+IUSE="lapack"
+
+RDEPEND="
+ lapack? (
+ >=virtual/cblas-3.8
+ >=virtual/lapack-3.8
+ )
+"
+BDEPEND="
+ ${RDEPEND}
+ <dev-python/cython-3[${PYTHON_USEDEP}]
+ >=dev-python/cython-0.29.30[${PYTHON_USEDEP}]
+ lapack? (
+ virtual/pkgconfig
+ )
+ test? (
+ $(python_gen_cond_dep '
+ >=dev-python/cffi-1.14.0[${PYTHON_USEDEP}]
+ ' 'python*')
+ dev-python/charset_normalizer[${PYTHON_USEDEP}]
+ >=dev-python/hypothesis-5.8.0[${PYTHON_USEDEP}]
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
+ >=dev-python/pytz-2019.3[${PYTHON_USEDEP}]
+ )
+"
+
+PATCHES=(
+ "${FILESDIR}"/numpy-1.22.0-no-hardcode-blasv2.patch
+)
+
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ # Allow use with setuptools 60.x
+ # See numpy-1.22.1-revert-setuptools-upper-bound.patch for details
+ export SETUPTOOLS_USE_DISTUTILS=stdlib
+
+ if use lapack; then
+ local incdir="${EPREFIX}"/usr/include
+ local libdir="${EPREFIX}"/usr/$(get_libdir)
+ cat >> site.cfg <<-EOF || die
+ [blas]
+ include_dirs = ${incdir}
+ library_dirs = ${libdir}
+ blas_libs = cblas,blas
+ [lapack]
+ library_dirs = ${libdir}
+ lapack_libs = lapack
+ EOF
+ else
+ export {ATLAS,PTATLAS,BLAS,LAPACK,MKL}=None
+ fi
+
+ export CC="$(tc-getCC) ${CFLAGS}"
+
+ append-flags -fno-strict-aliasing
+
+ # See progress in http://projects.scipy.org/scipy/numpy/ticket/573
+ # with the subtle difference that we don't want to break Darwin where
+ # -shared is not a valid linker argument
+ if [[ ${CHOST} != *-darwin* ]]; then
+ append-ldflags -shared
+ fi
+
+ # only one fortran to link with:
+ # linking with cblas and lapack library will force
+ # autodetecting and linking to all available fortran compilers
+ append-fflags -fPIC
+ if use lapack; then
+ NUMPY_FCONFIG="config_fc --noopt --noarch"
+ # workaround bug 335908
+ [[ $(tc-getFC) == *gfortran* ]] && NUMPY_FCONFIG+=" --fcompiler=gnu95"
+ fi
+
+ # don't version f2py, we will handle it.
+ sed -i -e '/f2py_exe/s: + os\.path.*$::' numpy/f2py/setup.py || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_compile() {
+ local -x MAKEOPTS=-j1 #660754
+
+ distutils-r1_python_compile ${NUMPY_FCONFIG}
+}
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # very disk- and memory-hungry
+ numpy/lib/tests/test_histograms.py::TestHistogram::test_big_arrays
+ numpy/lib/tests/test_io.py::test_large_zip
+
+ # precision problems
+ numpy/core/tests/test_umath_accuracy.py::TestAccuracy::test_validate_transcendentals
+
+ # runs the whole test suite recursively, that's just crazy
+ numpy/core/tests/test_mem_policy.py::test_new_policy
+
+ # very slow, unlikely to be practically useful
+ numpy/typing/tests/test_typing.py
+ )
+
+ if use arm && [[ $(uname -m || echo "unknown") == "armv8l" ]] ; then
+ # Degenerate case. arm32 chroot on arm64.
+ # bug #774108
+ EPYTEST_DESELECT+=(
+ numpy/core/tests/test_cpu_features.py::Test_ARM_Features::test_features
+ )
+ fi
+
+ if use x86 ; then
+ EPYTEST_DESELECT+=(
+ # https://github.com/numpy/numpy/issues/18388
+ numpy/core/tests/test_umath.py::TestRemainder::test_float_remainder_overflow
+ # https://github.com/numpy/numpy/issues/18387
+ numpy/random/tests/test_generator_mt19937.py::TestRandomDist::test_pareto
+ # more precision problems
+ numpy/core/tests/test_einsum.py::TestEinsum::test_einsum_sums_int16
+ )
+ fi
+ if use arm || use x86 ; then
+ EPYTEST_DESELECT+=(
+ # too large for 32-bit platforms
+ numpy/core/tests/test_ufunc.py::TestUfunc::test_identityless_reduction_huge_array
+ )
+ fi
+
+ distutils_install_for_testing --single-version-externally-managed \
+ --record "${TMPDIR}/record.txt" ${NUMPY_FCONFIG}
+
+ cd "${TEST_DIR}/lib" || die
+ epytest -k "not _fuzz" -n "$(makeopts_jobs)"
+}
+
+python_install() {
+ # https://github.com/numpy/numpy/issues/16005
+ local mydistutilsargs=( build_src )
+ distutils-r1_python_install ${NUMPY_FCONFIG}
+ python_optimize
+}
+
+python_install_all() {
+ local DOCS=( LICENSE.txt README.md THANKS.txt )
+ distutils-r1_python_install_all
+}