summaryrefslogtreecommitdiff
path: root/dev-python/oauth2
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-python/oauth2
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-python/oauth2')
-rw-r--r--dev-python/oauth2/Manifest4
-rw-r--r--dev-python/oauth2/files/1.9.0_p1-exclude-tests.patch11
-rw-r--r--dev-python/oauth2/metadata.xml12
-rw-r--r--dev-python/oauth2/oauth2-1.9.0_p1-r1.ebuild39
4 files changed, 66 insertions, 0 deletions
diff --git a/dev-python/oauth2/Manifest b/dev-python/oauth2/Manifest
new file mode 100644
index 000000000000..a690b5e4cc3d
--- /dev/null
+++ b/dev-python/oauth2/Manifest
@@ -0,0 +1,4 @@
+AUX 1.9.0_p1-exclude-tests.patch 332 BLAKE2B 82d468bd3f94baf4e99ddcc17252bad0b71ff2331aaeda3ec3d7b4117017b5a9ac2ab57f4fcdaeeaae9afec4c39e1ca5481e2463e197eba7bae40c6d27e0af05 SHA512 9b4b45d22076517ac6e79ecd74430ee7e53501aea07f0e2c43bae3c119e572d9357dfc32adb036920f4ff15c1344ea3cde20e79ee4c609508feeb9fac3293c57
+DIST oauth2-1.9.0.post1.tar.gz 21306 BLAKE2B 3e61ba6d46b98c594fa31e828885930490f99390f14e0173bdf719cfc1d5e8ad385e56c9654e139279cd95611a7e35b1fe0276679a2a4849b67125f5e6919788 SHA512 a3b64eef331d4c4f59c275f14efb2dfb48ad60de47a59a88106f60d64428a09b76d8bedf08c98c113493968d83708b1478b4b61b2b5528b5b01fa22777daff4c
+EBUILD oauth2-1.9.0_p1-r1.ebuild 1013 BLAKE2B 3e8fc7530fa6c7530ba483815ef0a0479a4b08b463650805bb739a6f4bafd4a06fafe7c77eb2f6a1d888328ff5cb26428db491d154293fe5f3b206d70bb42fd4 SHA512 6c0953fd7aa8a4138204c47abe46875037e32657fc7879116fd774bf81091acf70eb5baf8e8767293e0358845bc07ca7663d6963839d664df34d4759e6b04259
+MISC metadata.xml 371 BLAKE2B 6c43294e3af678e152bc35ab923bca43990db39552673b6dde5206eb5d82199ca46d4162d53fe1f62b09ec15ae9b54b27c5c5c59ca3957ccdb532feaab63147c SHA512 292d51b2e24153b3351aa1a78e5246ecc0d36f21697f0637390ee5869b770bc24a9dcf01fa26e8ab6feeb61902bbc34659f34969537eac0c647445c03cb086da
diff --git a/dev-python/oauth2/files/1.9.0_p1-exclude-tests.patch b/dev-python/oauth2/files/1.9.0_p1-exclude-tests.patch
new file mode 100644
index 000000000000..0d3a0fa962af
--- /dev/null
+++ b/dev-python/oauth2/files/1.9.0_p1-exclude-tests.patch
@@ -0,0 +1,11 @@
+--- a/setup.py
++++ b/setup.py
+@@ -45,7 +45,7 @@
+ "Natural Language :: English",
+ "License :: OSI Approved :: MIT License"
+ ],
+- packages = find_packages(),
++ packages = find_packages(exclude=['tests']),
+ install_requires = ['httplib2'],
+ license = "MIT License",
+ keywords="oauth",
diff --git a/dev-python/oauth2/metadata.xml b/dev-python/oauth2/metadata.xml
new file mode 100644
index 000000000000..88a621eb46ee
--- /dev/null
+++ b/dev-python/oauth2/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="pypi">oauth2</remote-id>
+ <remote-id type="github">joestump/python-oauth2</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/oauth2/oauth2-1.9.0_p1-r1.ebuild b/dev-python/oauth2/oauth2-1.9.0_p1-r1.ebuild
new file mode 100644
index 000000000000..9587054d0e20
--- /dev/null
+++ b/dev-python/oauth2/oauth2-1.9.0_p1-r1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} pypy )
+
+inherit distutils-r1
+
+MY_P="${P/_p/.post}"
+
+DESCRIPTION="Library for OAuth version 1.0"
+HOMEPAGE="https://pypi.org/project/oauth2/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${MY_P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="amd64 x86 ~x64-macos"
+IUSE="test"
+
+RDEPEND="dev-python/httplib2[${PYTHON_USEDEP}]"
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( ${RDEPEND}
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/pytest-runner[${PYTHON_USEDEP}]
+ dev-python/pytest[${PYTHON_USEDEP}]
+ )"
+
+# https://github.com/joestump/python-oauth2/pull/212
+PATCHES=( "${FILESDIR}/${PV}-exclude-tests.patch" )
+S="${WORKDIR}/${MY_P}"
+
+python_test() {
+ # Skip tests which require network access
+ py.test -k "not (test_access_token_post or test_access_token_get \
+ or test_two_legged_post or test_two_legged_get)" || die \
+ "tests failed with ${EPYTHON}"
+}