summaryrefslogtreecommitdiff
path: root/dev-python/oauthlib/oauthlib-3.0.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-05-14 11:09:11 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-05-14 11:09:11 +0100
commitdeba8115d2c2af26df42966b91ef04ff4dd79cde (patch)
tree9a48f42594e1a9e6b2020d5535a784314434d7a7 /dev-python/oauthlib/oauthlib-3.0.1.ebuild
parent38423c67c8a23f6a1bc42038193182e2da3116eb (diff)
gentoo resync : 14.05.2020
Diffstat (limited to 'dev-python/oauthlib/oauthlib-3.0.1.ebuild')
-rw-r--r--dev-python/oauthlib/oauthlib-3.0.1.ebuild34
1 files changed, 0 insertions, 34 deletions
diff --git a/dev-python/oauthlib/oauthlib-3.0.1.ebuild b/dev-python/oauthlib/oauthlib-3.0.1.ebuild
deleted file mode 100644
index 5b0c7b2a92ec..000000000000
--- a/dev-python/oauthlib/oauthlib-3.0.1.ebuild
+++ /dev/null
@@ -1,34 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=( python3_{6,7} )
-
-inherit distutils-r1
-
-DESCRIPTION="Spec-compliant and thorough implementation of the OAuth request-signing logic"
-HOMEPAGE="https://github.com/idan/oauthlib https://pypi.org/project/oauthlib/"
-SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="amd64 ~arm ~arm64 x86"
-IUSE="test"
-RESTRICT="!test? ( test )"
-
-# optional extras hard set as RDEPs. See setup.py
-RDEPEND="
- >=dev-python/pyjwt-1.0.0[${PYTHON_USEDEP}]
- dev-python/blinker[${PYTHON_USEDEP}]
- dev-python/cryptography[${PYTHON_USEDEP}]
- "
-DEPEND="
- dev-python/setuptools[${PYTHON_USEDEP}]
- test? ( ${RDEPEND}
- dev-python/nose[${PYTHON_USEDEP}] )
- "
-
-python_test() {
- nosetests -v || die "tests failed under ${EPYTHON}"
-}