summaryrefslogtreecommitdiff
path: root/dev-python/oct2py
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-python/oct2py
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-python/oct2py')
-rw-r--r--dev-python/oct2py/Manifest5
-rw-r--r--dev-python/oct2py/metadata.xml17
-rw-r--r--dev-python/oct2py/oct2py-3.6.0.ebuild64
-rw-r--r--dev-python/oct2py/oct2py-4.0.6.ebuild56
4 files changed, 142 insertions, 0 deletions
diff --git a/dev-python/oct2py/Manifest b/dev-python/oct2py/Manifest
new file mode 100644
index 000000000000..e6f412ba4155
--- /dev/null
+++ b/dev-python/oct2py/Manifest
@@ -0,0 +1,5 @@
+DIST oct2py-3.6.0.tar.gz 668836 BLAKE2B 2edafd7c054a70a604273a7f3f5846926cb54dd05e7f2625aad57034d7760c099e9ad01120b719d3d047e6e6aa11f16e5fe8ca58e51079f038cea6d7aa3efe13 SHA512 f414a0231665bc3bedb7dcdaab8c86f32c140e5107ef80b70e2f99467e737d033de6ff492f2af7233671bff9b148475e0af4881c073ac727d0fd1228b7cf59b6
+DIST oct2py-4.0.6.tar.gz 431738 BLAKE2B d76fd323fa2405cd70dd1d4cbbdf64bbd346d45dc8065de0913d44d833f6d609d20ec8887cefeafdc4e59c382f862a8954b395557ff5ec127a67b1df2d560083 SHA512 997ca843571d2d68c4c57c0213a525c1be5f8b3e3dbffffb6cd41e423d68c8836dd12a03d5210d7f0cbf8ff19be7bb9d25b48c62a236cae68a0762547e574caa
+EBUILD oct2py-3.6.0.ebuild 1421 BLAKE2B ad96c6dad7805ea0a0c8dbc75bb5642ea072bd6c8778d0fbc948d0f29e4b165a0b2bef357a108aeca71ab5f13760e9c9784ced44abd3ce60b430c96821a14de1 SHA512 f9cb7242b01f0b5571916b4f2f979bf3cf8eb29e284ec8af92c58ebc4226a41ff73f9499af4cde461f23bbc6b21f23e506729d64023b7c6ef322949b2fc6f3f1
+EBUILD oct2py-4.0.6.ebuild 1198 BLAKE2B 00406daa489ed242f7c278b26d555dbcc7325fe1174228d637919499a2d788057bb0b090b79e84b8403a3cb311519d7f35d2db05ed582e80aa85286cb5af30a7 SHA512 d3ba28d3a2dca496a2de2eaf87f6ef55d0238a6d12be1d177e6091708aca4b0f246f46c8692f343859d7942f20e52bc31ab46017e445aace6a2ac4a51cb55f63
+MISC metadata.xml 615 BLAKE2B 32a95461360131faf43212d3e419ba75a12f853749baf7f862499155d6f445492c311860ea5ee7c7e22c5e9586c722df8382cfe2eb6f67ac7bc1596f6cb9602a SHA512 e476f193cbbdefdf56caeb8a8a501f57daf1b74a12a32c426b6e9150ea0d5b2538b7bd9bbeb3b7f45ba01aa741be2fd0b4dbf8e8302e867230fc1b2512c10ca2
diff --git a/dev-python/oct2py/metadata.xml b/dev-python/oct2py/metadata.xml
new file mode 100644
index 000000000000..1b0577d069b3
--- /dev/null
+++ b/dev-python/oct2py/metadata.xml
@@ -0,0 +1,17 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>sci-mathematics@gentoo.org</email>
+ <name>Gentoo Mathematics Project</name>
+ </maintainer>
+ <longdescription lang="en">
+ Uses Octave to run commands and m-files. Supports any Octave
+ function or m-file, passing the data seamlessly between Python and
+ Octave using MAT files.
+ </longdescription>
+ <upstream>
+ <remote-id type="pypi">oct2py</remote-id>
+ <remote-id type="github">blink1073/oct2py</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/oct2py/oct2py-3.6.0.ebuild b/dev-python/oct2py/oct2py-3.6.0.ebuild
new file mode 100644
index 000000000000..6b185ef9897c
--- /dev/null
+++ b/dev-python/oct2py/oct2py-3.6.0.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python to GNU Octave bridge"
+HOMEPAGE="
+ https://github.com/blink1073/oct2py
+ https://blink1073.github.io/oct2py/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="amd64 ~arm ~ppc ~ppc64 x86 ~amd64-linux ~x86-linux"
+IUSE="doc examples test"
+
+RDEPEND="
+ >=dev-python/numpy-1.7.1[${PYTHON_USEDEP}]
+ >=sci-libs/scipy-0.12[${PYTHON_USEDEP}]
+ >=sci-mathematics/octave-4.2.0"
+DEPEND="${RDEPEND}
+ doc? (
+ dev-python/sphinx-bootstrap-theme[${PYTHON_USEDEP}]
+ dev-python/numpydoc[${PYTHON_USEDEP}]
+ )
+ test? (
+ dev-python/nose[${PYTHON_USEDEP}]
+ dev-python/ipython[${PYTHON_USEDEP}]
+ )"
+
+python_prepare_all() {
+ # https://github.com/blink1073/oct2py/issues/77
+ sed \
+ -e 's:test_help:disabled:g' \
+ -i oct2py/tests/test_usage.py || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_compile_all() {
+ if use doc; then
+ sphinx-build docs html || die
+ fi
+}
+
+python_test() {
+ unset DISPLAY
+ [[ ${EPYTHON} == python2.7 ]] && local OPTIONS="--with-doctest"
+ nosetests --exe -v oct2py ${OPTIONS} || die "Tests fail with ${EPYTHON}"
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( html/. )
+ if use examples; then
+ docinto examples
+ dodoc -r example/.
+ fi
+
+ distutils-r1_python_install_all
+}
diff --git a/dev-python/oct2py/oct2py-4.0.6.ebuild b/dev-python/oct2py/oct2py-4.0.6.ebuild
new file mode 100644
index 000000000000..9eb85c66fb4b
--- /dev/null
+++ b/dev-python/oct2py/oct2py-4.0.6.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python to GNU Octave bridge"
+HOMEPAGE="
+ https://github.com/blink1073/oct2py
+ https://blink1073.github.io/oct2py/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="doc examples test"
+
+RDEPEND="
+ >=dev-python/numpy-1.11[${PYTHON_USEDEP}]
+ dev-python/octave_kernel[${PYTHON_USEDEP}]
+ >=sci-libs/scipy-0.17[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}
+ doc? (
+ dev-python/numpydoc[${PYTHON_USEDEP}]
+ dev-python/sphinx[${PYTHON_USEDEP}]
+ dev-python/sphinx-bootstrap-theme[${PYTHON_USEDEP}]
+ )
+ test? (
+ dev-python/pytest[${PYTHON_USEDEP}]
+ dev-python/ipython[${PYTHON_USEDEP}]
+ )
+"
+python_compile_all() {
+ if use doc; then
+ sphinx-build docs html || die
+ HTML_DOCS=( html/. )
+ fi
+}
+
+python_test() {
+ cd "${BUILD_DIR}/lib" || die
+ py.test -v -v || die
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+ if use examples; then
+ docinto examples
+ dodoc -r example/.
+ docompress -x /usr/share/doc/${PF}/examples
+ fi
+}