summaryrefslogtreecommitdiff
path: root/dev-python/oct2py
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-11-10 16:37:59 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-11-10 16:37:59 +0000
commita6611f9bc959724ec73dbaa6f1c608698c387a8c (patch)
tree8ff7cd805082a09f072c81e91670cb075fe81ce3 /dev-python/oct2py
parent1b26473bc67c6bcd775f96cdd7ee9824b97d7ee8 (diff)
gentoo auto-resync : 10:11:2023 - 16:37:59
Diffstat (limited to 'dev-python/oct2py')
-rw-r--r--dev-python/oct2py/Manifest2
-rw-r--r--dev-python/oct2py/oct2py-5.6.0.ebuild54
2 files changed, 56 insertions, 0 deletions
diff --git a/dev-python/oct2py/Manifest b/dev-python/oct2py/Manifest
index 12db24c084d8..af67b90ddfe4 100644
--- a/dev-python/oct2py/Manifest
+++ b/dev-python/oct2py/Manifest
@@ -1,4 +1,6 @@
AUX oct2py-5.2.0-mask-pkg-load-test.patch 384 BLAKE2B eb97b0f6fdf6df1bfc6907984ee1b223b9ec406c831c8c7f5908d3f5e130cddb85610487ee6eacf664e2e1859c3cc2ec1f5a22072d3dcac09b68bb631534e015 SHA512 44755cfd9725ef5e4dc572ac5e17954f023c4ae0bbe68ed984e696b485cf96bb15e11ee2d0a8a4a411237d0f5337269f13767af509554a9826fe572a7a2bfa71
DIST oct2py-5.5.1.tar.gz 442518 BLAKE2B c0a645464b64d04137f53f3c15bcd90d1df193d7dd7e955cf1e90b5d279091cc16b3052321a1788b6a382ad8759db1619b0a20d117c627d88abe75d13aeb62e3 SHA512 4bd81fc493d9c0b602bf254f7f8bcf5d2024c5c1004fd8a26d94608eb0c802af44d74efb2f2ff941cff89be5265136d987e9a8fc9c4ab987da513d57b291ad2e
+DIST oct2py-5.6.0.tar.gz 437965 BLAKE2B e22aca80608e1132f2cb8936e9dac7c97bd8e5463b6997dd80f0ed567af2a59a28b4c58995b11e2c1a970bc0bde81afda432d8ce5306b2eb5417b1f75b8b4b19 SHA512 d5eae408812358e48c9a72e823dc06a7556c09176170def00c53aacba75c6568357afe8e9a079c02e08c88ee1e7f1aa4284508471680b5542894745b19e7af36
EBUILD oct2py-5.5.1.ebuild 1245 BLAKE2B 6faa57ae5c81877c964996c3768533efdc1f47fd08e8231c6737bd638fd071c051621aaf92eb1c913393e27706a4ee9f8e8daa4c2021f032b8c99368c5cab22e SHA512 8d557b339906f423f2b85a36934d19b74dda210b8d542f9077c2aeb2f53e2974cb4f7e9cf70a6f5bf2afa1814a9087813596f08485b92db04602f01c4e46f9c5
+EBUILD oct2py-5.6.0.ebuild 1277 BLAKE2B c851bb615243e4ce2e79538e8077aec723692ddc496dcad306c8df67d2284e8fba67bcf97504875d6a300e04286ffc567cb112129f0ec718c7fedd649b85268e SHA512 e72a6f2b148f8215ff181bab0b0a68f885aec3747cc2b6b5e9152f5bc3a6e8354247c860a1854cd649e3fb3e32acd9f3f304a12e3ed4700eb2695859b0bccb2f
MISC metadata.xml 616 BLAKE2B 8ecf15bc368039c2a5abb858bbb1bf78028868070ccc528e62bc2318c9f6348a103a857ca7f256e548de8f0874ebfdc387d264af3fb13764b3145e91265c1e57 SHA512 387f069b113e2ddf805e75d3f440083c72bc07e211c6b8af0c7b20e73bbdb3244a71d012b051041b6de6000d84caa4bceed1747e098f9621096ab30dc8bdac1f
diff --git a/dev-python/oct2py/oct2py-5.6.0.ebuild b/dev-python/oct2py/oct2py-5.6.0.ebuild
new file mode 100644
index 000000000000..ca1780ad9252
--- /dev/null
+++ b/dev-python/oct2py/oct2py-5.6.0.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..12} )
+DISTUTILS_USE_PEP517=hatchling
+inherit distutils-r1 pypi
+
+DESCRIPTION="Python to GNU Octave bridge"
+HOMEPAGE="
+ https://github.com/blink1073/oct2py
+ https://blink1073.github.io/oct2py/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="examples"
+
+RDEPEND="
+ >=dev-python/numpy-1.12[${PYTHON_USEDEP}]
+ >=dev-python/octave_kernel-0.34.0[${PYTHON_USEDEP}]
+ >=dev-python/scipy-0.17[${PYTHON_USEDEP}]"
+BDEPEND="
+ test? (
+ dev-python/ipython[${PYTHON_USEDEP}]
+ dev-python/nbconvert[${PYTHON_USEDEP}]
+ dev-python/pandas[${PYTHON_USEDEP}]
+ )"
+
+EPYTEST_DESELECT=(
+ # No graphics toolkit available: 743589
+ "oct2py/ipython/tests/test_octavemagic.py::OctaveMagicTest::test_octave_plot"
+)
+
+distutils_enable_sphinx docs/source \
+ dev-python/numpydoc \
+ dev-python/sphinx-bootstrap-theme \
+ dev-python/sphinx-rtd-theme \
+ dev-python/myst-parser
+distutils_enable_tests pytest
+
+PATCHES=( "${FILESDIR}"/${PN}-5.2.0-mask-pkg-load-test.patch )
+
+python_install_all() {
+ distutils-r1_python_install_all
+
+ if use examples; then
+ docinto examples
+ dodoc -r example/.
+ docompress -x /usr/share/doc/${PF}/examples
+ fi
+}