summaryrefslogtreecommitdiff
path: root/dev-python/openapi-core
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-11-25 22:29:52 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-11-25 22:29:52 +0000
commit4dc9bfa1f12673bbf1343e64af7e0cd715534a9f (patch)
treeb6bfc88046aa092bbc03342aef7eccf310d43692 /dev-python/openapi-core
parent8cd3c41aa0ccead302235680b9e2fa9903d7548e (diff)
gentoo auto-resync : 25:11:2023 - 22:29:52
Diffstat (limited to 'dev-python/openapi-core')
-rw-r--r--dev-python/openapi-core/Manifest2
-rw-r--r--dev-python/openapi-core/openapi-core-0.18.1.ebuild69
2 files changed, 0 insertions, 71 deletions
diff --git a/dev-python/openapi-core/Manifest b/dev-python/openapi-core/Manifest
index e5d3743702f6..c2b0ca78c3e9 100644
--- a/dev-python/openapi-core/Manifest
+++ b/dev-python/openapi-core/Manifest
@@ -1,5 +1,3 @@
-DIST openapi_core-0.18.1.tar.gz 84070 BLAKE2B 523b620106493aac11135025791440cbc4e7dc415a10344a74e2de3500834bda6158aa286f167e629ae90e1eefd568527832fb86557c16eace162d2bac98e30b SHA512 ae59c0ca948ebfcf01b63db8a463869bbb748336f32c917b2ed22bd94934c91b6fe280bf94bf82a24df9fb29979e6a1b5ce665d12b6bb6480405e9586a9fc8d5
DIST openapi_core-0.18.2.tar.gz 84444 BLAKE2B bb05ba86eff3c70c780f1919a29b93f2137983318834c51204d7ad1094fc645d2dbcef93d92d03096826688fdfe1811c551eee68995fd46739314c2e4bc77cfc SHA512 552109c095c840a46759a54e247a3ac2d8cc36707ba89815740eef4b7fb421bd489929543892341fd89a578bff4043c8c81302fddaa1efe125238e050f152c27
-EBUILD openapi-core-0.18.1.ebuild 2030 BLAKE2B bc02ad4df3fa97fe0a8f5d5da363d4d5a1d142b607e3b71494b8f779f1663feb5fc7cf3965a6db6a7c345e694275c7c3a97c1b59f83d37d2ecbe5e8d91a41110 SHA512 f230dc40536da33441a76d88fafae7bd95cc5bde397d44daac5075c696e750cafa0ac8397dca7efcba6208ccbb845ad6412e9a2293f4cfd2cf1ba2571a012b63
EBUILD openapi-core-0.18.2.ebuild 2036 BLAKE2B 627470243f19362c2ea72a8c8b7c9ba8a74a7bc57f0e850342717ed4ca922b36f445ee6c7e8ae5d5304059cb48a0eaf294b8f3b0e196771e35304b3d52446ea3 SHA512 ca93952e8867a4531df97a14da727ff4d1285361f418a32c0710c23718a39778343dd5f14ab0a4746cac06c12afa5df0dfd03de7ba503980c7b2a94adfc7b90c
MISC metadata.xml 385 BLAKE2B a19f5b70529b6f0575e1196f3ffe0a7f38595fe7b01b43119f0f89c41a9ab5d6992f424a10f345a7407d279736a6091918b9ba1ead0daa92c9d244e4b27e4a18 SHA512 a8a39c8958ad11de5eb6896a74b3bfcb27e95c74a984a362032e4703d86f2831b6559a96a8eef80a7ef89f4687da325b3748f36b1df649cd29c2acb1ea0c9969
diff --git a/dev-python/openapi-core/openapi-core-0.18.1.ebuild b/dev-python/openapi-core/openapi-core-0.18.1.ebuild
deleted file mode 100644
index cb63581f9f1c..000000000000
--- a/dev-python/openapi-core/openapi-core-0.18.1.ebuild
+++ /dev/null
@@ -1,69 +0,0 @@
-# Copyright 2022-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=poetry
-PYTHON_COMPAT=( python3_{10..12} )
-
-inherit distutils-r1 pypi
-
-DESCRIPTION="Client-side and server-side support for the OpenAPI Specification v3"
-HOMEPAGE="
- https://github.com/python-openapi/openapi-core/
- https://pypi.org/project/openapi-core/
-"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="amd64 arm arm64 ~loong ppc64 ~riscv x86"
-
-RDEPEND="
- <dev-python/asgiref-4[${PYTHON_USEDEP}]
- >=dev-python/asgiref-3.6.0[${PYTHON_USEDEP}]
- dev-python/isodate[${PYTHON_USEDEP}]
- <dev-python/jsonschema-5[${PYTHON_USEDEP}]
- >=dev-python/jsonschema-4.17.3[${PYTHON_USEDEP}]
- <dev-python/jsonschema-spec-0.3[${PYTHON_USEDEP}]
- >=dev-python/jsonschema-spec-0.2.3[${PYTHON_USEDEP}]
- dev-python/more-itertools[${PYTHON_USEDEP}]
- dev-python/parse[${PYTHON_USEDEP}]
- <dev-python/openapi-schema-validator-0.7[${PYTHON_USEDEP}]
- >=dev-python/openapi-schema-validator-0.6.0[${PYTHON_USEDEP}]
- <dev-python/openapi-spec-validator-0.7[${PYTHON_USEDEP}]
- >=dev-python/openapi-spec-validator-0.6.0[${PYTHON_USEDEP}]
- dev-python/werkzeug[${PYTHON_USEDEP}]
-"
-
-BDEPEND="
- test? (
- >=dev-python/aiohttp-3.8.4[${PYTHON_USEDEP}]
- dev-python/flask[${PYTHON_USEDEP}]
- >=dev-python/httpx-0.24.0[${PYTHON_USEDEP}]
- >=dev-python/pytest-aiohttp-1.0.4[${PYTHON_USEDEP}]
- dev-python/responses[${PYTHON_USEDEP}]
- >=dev-python/starlette-0.26.1[${PYTHON_USEDEP}]
- dev-python/strict-rfc3339[${PYTHON_USEDEP}]
- dev-python/webob[${PYTHON_USEDEP}]
- )
-"
-
-distutils_enable_tests pytest
-
-EPYTEST_IGNORE=(
- # falcon is not packaged
- tests/integration/contrib/falcon
-
- # TODO: these tests fail to collect
- tests/integration/validation/test_security_override.py
- tests/integration/validation/test_read_only_write_only.py
-
- # unhappy about modern django
- tests/integration/contrib/django/test_django_project.py
- tests/unit/contrib/django/test_django.py
-)
-
-src_prepare() {
- sed -i -e '/--cov/d' pyproject.toml || die
- distutils-r1_src_prepare
-}