summaryrefslogtreecommitdiff
path: root/dev-python/openstackdocstheme/openstackdocstheme-2.3.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-10-01 20:54:53 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-10-01 20:54:53 +0100
commit391b5b359a346aff490103da7dddc85047f83830 (patch)
tree29eea460a0bd7e1ff21d43b9d6df9af4d8a175e1 /dev-python/openstackdocstheme/openstackdocstheme-2.3.1.ebuild
parentc719fdcee603a5a706a45d10cb598762d56a727d (diff)
gentoo resync : 01.10.2021
Diffstat (limited to 'dev-python/openstackdocstheme/openstackdocstheme-2.3.1.ebuild')
-rw-r--r--dev-python/openstackdocstheme/openstackdocstheme-2.3.1.ebuild19
1 files changed, 19 insertions, 0 deletions
diff --git a/dev-python/openstackdocstheme/openstackdocstheme-2.3.1.ebuild b/dev-python/openstackdocstheme/openstackdocstheme-2.3.1.ebuild
new file mode 100644
index 000000000000..9a99ae747093
--- /dev/null
+++ b/dev-python/openstackdocstheme/openstackdocstheme-2.3.1.ebuild
@@ -0,0 +1,19 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1
+
+DESCRIPTION="Theme and extension support for Sphinx documentation"
+HOMEPAGE="https://docs.openstack.org/openstackdocstheme/latest/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~ppc64 ~x86"
+
+BDEPEND=">dev-python/pbr-2.1.0[${PYTHON_USEDEP}]"
+RDEPEND="${BDEPEND}
+ >=dev-python/dulwich-0.15.0[${PYTHON_USEDEP}]"