summaryrefslogtreecommitdiff
path: root/dev-python/os-testr
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-python/os-testr
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-python/os-testr')
-rw-r--r--dev-python/os-testr/Manifest5
-rw-r--r--dev-python/os-testr/metadata.xml12
-rw-r--r--dev-python/os-testr/os-testr-0.8.0.ebuild41
-rw-r--r--dev-python/os-testr/os-testr-1.0.0.ebuild40
4 files changed, 98 insertions, 0 deletions
diff --git a/dev-python/os-testr/Manifest b/dev-python/os-testr/Manifest
new file mode 100644
index 000000000000..685ad756c860
--- /dev/null
+++ b/dev-python/os-testr/Manifest
@@ -0,0 +1,5 @@
+DIST os-testr-0.8.0.tar.gz 42102 BLAKE2B 030ee587bc6465e414f09d177abd4f75d869da7e8339e1b396da31165212cec221d156b4cb095b1466b19f8baf2dc01087559b1d6b73fbfbfd41dced3df033c1 SHA512 62b5fbb859c1a3b44bc0d57cf4b2cd0a5e6eeff540f5507efd079a73e0f9ee70813e47537b456f1bc600c87da55d05fd23aee0c215b8558cc0b5e71a55950af4
+DIST os-testr-1.0.0.tar.gz 43382 BLAKE2B c5a9b22700ce40acff8ceeb796d9fa0b840038cd285d80630b16c3399e8c188d87dc54de653d06a2c0918185e9ffd4695747f59d4d42eb158f9ea18bc361963d SHA512 2189abc76840d935d63635874ebdae7c325b392bc24a52e07e1046b47a17be6fd97ba17dc5593ae7a1e2bff9c5b0dbbfd8ade8a2382dce2223ee4047b3483cec
+EBUILD os-testr-0.8.0.ebuild 1254 BLAKE2B f25d3842a9cde73b46744918443ce29c985045ffc6f4b007927553c52ca27b4d6ce4cf542b3d192c236bd53f341611f23b22eeb56a33f12f5f4e8f9031c03e65 SHA512 d3382e85e03ca1f2e83a1e73629a1b59f13f842910c88456172027c1dc10a15db38b6a68154f2a7f44aff52f1fc4fd3e815c3bbcade36940f08bb93f4de8b93e
+EBUILD os-testr-1.0.0.ebuild 1225 BLAKE2B 3ccdd5ff9232874f727ef14559c18bfd4cff1f03c0b1556623f0cdae3798fc752a4714e93377a668151be1c44692829b7b43f7b5b8d497c27e7a200f44876efa SHA512 d361e43ce462765a34d3caa2c8c7d388064a67d9f8ee485f76603e1a83c27ed2cd6928149dee71f44fe795b16a3f2c42e5949a546141d918c71ea1f98170083f
+MISC metadata.xml 383 BLAKE2B 1d861bbcd12c0cd7c1d3798cf03163ae3a114349b3efc600179c47d71a275c211d65e8e542dc9b5c22b3b4690af4048ba85a573c7a40b8373f2783d154c050b9 SHA512 6e205857c3d2b3d94baceef580f343bee82210bf3003106ac58ad48d0403aa32c38332aee7b030eacd7d0bd272d7bcb34054e5852bd8b4870cebd0af74eb2577
diff --git a/dev-python/os-testr/metadata.xml b/dev-python/os-testr/metadata.xml
new file mode 100644
index 000000000000..4118c7a742e9
--- /dev/null
+++ b/dev-python/os-testr/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>prometheanfire@gentoo.org</email>
+ <name>Matthew Thode</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="pypi">os-testr</remote-id>
+ <remote-id type="github">openstack/os-testr</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/os-testr/os-testr-0.8.0.ebuild b/dev-python/os-testr/os-testr-0.8.0.ebuild
new file mode 100644
index 000000000000..2d40ad42d518
--- /dev/null
+++ b/dev-python/os-testr/os-testr-0.8.0.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python{2_7,3_{4,5}} )
+
+inherit distutils-r1
+
+DESCRIPTION="A testr wrapper to provide functionality for OpenStack projects"
+HOMEPAGE="https://pypi.org/project/os-testr/ https://github.com/openstack/os-testr"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="amd64 ~arm64 x86"
+IUSE="test"
+
+CDEPEND=">=dev-python/pbr-1.6[${PYTHON_USEDEP}]"
+RDEPEND="
+ ${CDEPEND}
+ >=dev-python/Babel-2.3.4[${PYTHON_USEDEP}]
+ >=dev-python/testrepository-0.0.18[${PYTHON_USEDEP}]
+ >=dev-python/subunit-0.0.18[${PYTHON_USEDEP}]
+ >=dev-python/testtools-1.4.0[${PYTHON_USEDEP}]"
+DEPEND="
+ ${CDEPEND}
+ test? ( ${RDEPEND}
+ >=dev-python/coverage-3.6[${PYTHON_USEDEP}]
+ >=dev-python/sphinx-1.2.1[${PYTHON_USEDEP}]
+ <dev-python/sphinx-1.4[${PYTHON_USEDEP}]
+ >=dev-python/oslo-sphinx-3.7.0[${PYTHON_USEDEP}]
+ >=dev-python/oslotest-1.10.0[${PYTHON_USEDEP}]
+ >=dev-python/testscenarios-0.4[${PYTHON_USEDEP}]
+ >=dev-python/ddt-1.0.1[${PYTHON_USEDEP}]
+ >=dev-python/six-1.9.0[${PYTHON_USEDEP}]
+ )"
+
+python_prepare_all() {
+ sed -i '/^hacking/d' test-requirements.txt || die
+ distutils-r1_python_prepare_all
+}
diff --git a/dev-python/os-testr/os-testr-1.0.0.ebuild b/dev-python/os-testr/os-testr-1.0.0.ebuild
new file mode 100644
index 000000000000..5dc2a9c019fa
--- /dev/null
+++ b/dev-python/os-testr/os-testr-1.0.0.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python{2_7,3_{4,5,6}} )
+
+inherit distutils-r1
+
+DESCRIPTION="A testr wrapper to provide functionality for OpenStack projects"
+HOMEPAGE="https://pypi.org/project/os-testr/ https://github.com/openstack/os-testr"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="amd64 ~arm64 x86"
+IUSE="test"
+
+CDEPEND=">=dev-python/pbr-2.0.0[${PYTHON_USEDEP}]"
+RDEPEND="
+ ${CDEPEND}
+ >=dev-python/testrepository-0.0.18[${PYTHON_USEDEP}]
+ >=dev-python/subunit-0.0.18[${PYTHON_USEDEP}]
+ >=dev-python/testtools-1.4.0[${PYTHON_USEDEP}]"
+DEPEND="
+ ${CDEPEND}
+ test? ( ${RDEPEND}
+ >=dev-python/coverage-4.0[${PYTHON_USEDEP}]
+ !~dev-python/coverage-4.1[${PYTHON_USEDEP}]
+ >=dev-python/sphinx-1.6.2[${PYTHON_USEDEP}]
+ >=dev-python/openstackdocstheme-1.16.0[${PYTHON_USEDEP}]
+ >=dev-python/oslotest-1.10.0[${PYTHON_USEDEP}]
+ >=dev-python/testscenarios-0.4[${PYTHON_USEDEP}]
+ >=dev-python/ddt-1.0.1[${PYTHON_USEDEP}]
+ >=dev-python/six-1.9.0[${PYTHON_USEDEP}]
+ )"
+
+python_prepare_all() {
+ sed -i '/^hacking/d' test-requirements.txt || die
+ distutils-r1_python_prepare_all
+}