summaryrefslogtreecommitdiff
path: root/dev-python/os-win
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-python/os-win
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-python/os-win')
-rw-r--r--dev-python/os-win/Manifest5
-rw-r--r--dev-python/os-win/metadata.xml15
-rw-r--r--dev-python/os-win/os-win-2.2.0.ebuild41
-rw-r--r--dev-python/os-win/os-win-3.0.1.ebuild39
4 files changed, 100 insertions, 0 deletions
diff --git a/dev-python/os-win/Manifest b/dev-python/os-win/Manifest
new file mode 100644
index 000000000000..f132c7e886bf
--- /dev/null
+++ b/dev-python/os-win/Manifest
@@ -0,0 +1,5 @@
+DIST os-win-2.2.0.tar.gz 192662 BLAKE2B 4da623f2f3fff0466156468a09477d29cda391275935dc56be06eaf7562cb153d7d00771206385b3cfada2fe86679e1a80e52e32f539a5c4e62bf9aa10967079 SHA512 02bb9b7ddaa7b3807ce66ce32242fe9938f28bde6880cf9ed461072e764e41a34a1238ccdc8b67ebc95a07ac003bb0771b8943602582ede6c8a41440f865060b
+DIST os-win-3.0.1.tar.gz 202691 BLAKE2B 934f90970ccdb7890379ca6f3545936db65f104414c4de51dd8956345b4e5330a3d6db286b6fc2cbc9f218528751fea56b7836d81cb9da1f271737817b220101 SHA512 619b893f4595fda57c2d339b10bf4a7de48c711829f1e2407f981c943b76999d1ee84c15a5b91b03fcd946f16754501cede2081c5ce0ae3ffea0e6f4faaaf23e
+EBUILD os-win-2.2.0.ebuild 1317 BLAKE2B 29d61ac1b7fcef2fcfb2c7ff64b02c529044a0a01bf0c44e9c73fc0c0ced3d47b2171404e6da81532a439316f8613c4720799b0f6ac0fdea3fdacfebe9467b93 SHA512 e54a571099aa7daa338fec6baa128863bf41d592b0c8a21ae3175a8de381625219278e72e4aeee6bf94a370708be6b87188d45c5e27d4afd06a2a84e06865b49
+EBUILD os-win-3.0.1.ebuild 1209 BLAKE2B 17e8eb7ab70235245c72cdd31d39c7fc140701a9a30c514bb272f3d3f0fa1923e84d65d8ce7f04c9ee3f075fb0d3d9391aa5c3f36fd05276eb5bbbbc40782785 SHA512 a9e38ec14a2b3fd447950ef0d3af286eb92fe946c4037e23c1a1b8a746945e2a3389231d77458139dfc353f025010872d37f6c0ff0f2f9224a2bc5f3c40eac72
+MISC metadata.xml 480 BLAKE2B b17e3983e5660147a3a55a76948e00dd9e0fc800e442cdf92e4e17a70737740b749a86063f3f644b092df6e0d00d4e9c36d11f6a8ba697f214c08fd79c560008 SHA512 6454d56af0f829cf94cd211f78651a6d611eabebd8a3aaf5cf2cb92aef29107ed6efa5e974b5f9e5f6f53ed29565c1c6ac0448de72a3f21efbf73ecbcad2dd3e
diff --git a/dev-python/os-win/metadata.xml b/dev-python/os-win/metadata.xml
new file mode 100644
index 000000000000..4d5ec9ded55c
--- /dev/null
+++ b/dev-python/os-win/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version='1.0' encoding='UTF-8'?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>prometheanfire@gentoo.org</email>
+ <name>Matthew Thode</name>
+ </maintainer>
+ <longdescription lang="en">
+ Windows / Hyper-V library for OpenStack projects.
+ </longdescription>
+ <upstream>
+ <remote-id type="github">openstack/os-win</remote-id>
+ <remote-id type="pypi">os-win</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/os-win/os-win-2.2.0.ebuild b/dev-python/os-win/os-win-2.2.0.ebuild
new file mode 100644
index 000000000000..8906f8520a4c
--- /dev/null
+++ b/dev-python/os-win/os-win-2.2.0.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 python3_4 python3_5 )
+
+inherit distutils-r1
+
+DESCRIPTION="Windows / Hyper-V library for OpenStack projects."
+HOMEPAGE="https://github.com/openstack/os-win"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="amd64 ~arm64 x86"
+IUSE=""
+
+CDEPEND=">=dev-python/pbr-2.0.0[${PYTHON_USEDEP}]
+ !~dev-python/pbr-2.1.0"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ ${CDEPEND}"
+RDEPEND="
+ ${CDEPEND}
+ >=dev-python/Babel-2.3.4[${PYTHON_USEDEP}]
+ !~dev-python/Babel-2.4.0[${PYTHON_USEDEP}]
+ >=dev-python/eventlet-0.18.4[${PYTHON_USEDEP}]
+ !~dev-python/eventlet-0.20.1[${PYTHON_USEDEP}]
+ <dev-python/eventlet-0.21.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-concurrency-3.8.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-config-4.0.0[${PYTHON_USEDEP}]
+ !~dev-python/oslo-config-4.3.0[${PYTHON_USEDEP}]
+ !~dev-python/oslo-config-4.4.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-log-3.22.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-utils-3.20.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-i18n-2.1.0[${PYTHON_USEDEP}]
+ !~dev-python/oslo-i18n-3.15.0[${PYTHON_USEDEP}]"
+
+python_prepare_all() {
+ sed -i '/^hacking/d' test-requirements.txt || die
+ distutils-r1_python_prepare_all
+}
diff --git a/dev-python/os-win/os-win-3.0.1.ebuild b/dev-python/os-win/os-win-3.0.1.ebuild
new file mode 100644
index 000000000000..b13eb2885312
--- /dev/null
+++ b/dev-python/os-win/os-win-3.0.1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
+
+inherit distutils-r1
+
+DESCRIPTION="Windows / Hyper-V library for OpenStack projects."
+HOMEPAGE="https://github.com/openstack/os-win"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="amd64 ~arm64 x86"
+IUSE=""
+
+CDEPEND=">=dev-python/pbr-2.0.0[${PYTHON_USEDEP}]
+ !~dev-python/pbr-2.1.0"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ ${CDEPEND}"
+RDEPEND="
+ ${CDEPEND}
+ >=dev-python/Babel-2.3.4[${PYTHON_USEDEP}]
+ !~dev-python/Babel-2.4.0[${PYTHON_USEDEP}]
+ >=dev-python/eventlet-0.18.4[${PYTHON_USEDEP}]
+ !~dev-python/eventlet-0.20.1[${PYTHON_USEDEP}]
+ <dev-python/eventlet-0.21.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-concurrency-3.20.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-config-5.1.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-log-3.30.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-utils-3.33.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-i18n-3.15.3[${PYTHON_USEDEP}]"
+
+python_prepare_all() {
+ sed -i '/^hacking/d' test-requirements.txt || die
+ sed -i '/win32/d' requirements.txt || die
+ distutils-r1_python_prepare_all
+}