summaryrefslogtreecommitdiff
path: root/dev-python/oslo-cache
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-python/oslo-cache
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-python/oslo-cache')
-rw-r--r--dev-python/oslo-cache/Manifest3
-rw-r--r--dev-python/oslo-cache/metadata.xml15
-rw-r--r--dev-python/oslo-cache/oslo-cache-1.28.0.ebuild39
3 files changed, 57 insertions, 0 deletions
diff --git a/dev-python/oslo-cache/Manifest b/dev-python/oslo-cache/Manifest
new file mode 100644
index 000000000000..e9dd3189ffc7
--- /dev/null
+++ b/dev-python/oslo-cache/Manifest
@@ -0,0 +1,3 @@
+DIST oslo-cache-1.28.0.tar.gz 52015 BLAKE2B 897e54008ea99f367f373291d874736287dfd3d480046bdee0ab2b54969e8681144677713794ff32682b1ef65547618d5fcf403e9ae24b57768905daf7ae7f5e SHA512 44deabf9dbe3c24afd04d09f91f95d902221995130559e7895045eed98356ed9e085f5ee9b7e2bd0b4581df563a67707121b7571b0b7f822f0bb5a55b6dedafe
+EBUILD oslo-cache-1.28.0.ebuild 1045 BLAKE2B 5a476016a4a20177ffdafa93bd970a2da0e87fa07a50b7ee493f5a3292f66a727849f33fbae9dbc2d5b36d6b2bf8727d8d75e7be82e25cf331d7349cf1fe0746 SHA512 6b2078d289a99f5fd9db6c7c658064ebcea2cceff76ffe6572e1a44fbe31873378b99450274f431b162e5de8bb5c329707036aef50f3fff871b2a05cc7210495
+MISC metadata.xml 457 BLAKE2B 09e44ecf9952f5bfd930616506874014a267d8622daf6c22b3da4856d9f4bbedcb3e4e72285972da026f310c47973c0bb70c222292caf877d4f9ab6d5166955a SHA512 f98547e9de8c502afabf7c53409df90ec687159b5160c8ff2166acff4d6bce0fe69c8eec78d50f52919cd75733f44f82dea5f9cde362d22ed69200d332b9d6b7
diff --git a/dev-python/oslo-cache/metadata.xml b/dev-python/oslo-cache/metadata.xml
new file mode 100644
index 000000000000..5bcc8af1ede9
--- /dev/null
+++ b/dev-python/oslo-cache/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version='1.0' encoding='UTF-8'?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>prometheanfire@gentoo.org</email>
+ <name>Matthew Thode</name>
+ </maintainer>
+ <longdescription lang="en">
+ Wraps the dogpile.cache library
+ </longdescription>
+ <upstream>
+ <remote-id type="launchpad">oslo</remote-id>
+ <remote-id type="pypi">oslo.cache</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/oslo-cache/oslo-cache-1.28.0.ebuild b/dev-python/oslo-cache/oslo-cache-1.28.0.ebuild
new file mode 100644
index 000000000000..c11639ecaf0d
--- /dev/null
+++ b/dev-python/oslo-cache/oslo-cache-1.28.0.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_{4,5,6}} )
+
+inherit distutils-r1 vcs-snapshot
+
+MY_PN=${PN/-/.}
+
+DESCRIPTION="Oslo Caching around dogpile.cache"
+HOMEPAGE="https://launchpad.net/oslo"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_PN}-${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="amd64 ~arm64 x86 ~amd64-linux ~x86-linux"
+
+CDEPEND=">=dev-python/pbr-2.0.0[${PYTHON_USEDEP}]
+ !~dev-python/pbr-2.1.0[${PYTHON_USEDEP}]"
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ ${CDEPEND}
+"
+RDEPEND="
+ ${CDEPEND}
+ >=dev-python/dogpile-cache-0.6.2[${PYTHON_USEDEP}]
+ >=dev-python/six-1.10.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-config-5.1.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-i18n-3.15.3[${PYTHON_USEDEP}]
+ >=dev-python/oslo-log-3.30.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-utils-3.31.0[${PYTHON_USEDEP}]
+"
+
+python_prepare_all() {
+ sed -i '/^hacking/d' test-requirements.txt || die
+ distutils-r1_python_prepare_all
+}