summaryrefslogtreecommitdiff
path: root/dev-python/oslo-concurrency
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-03-20 00:40:44 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-03-20 00:40:44 +0000
commit4cbcc855382a06088e2f016f62cafdbcb7e40665 (patch)
tree356496503d52354aa6d9f2d36126302fed5f3a73 /dev-python/oslo-concurrency
parentfcc5224904648a8e6eb528d7603154160a20022f (diff)
gentoo resync : 20.03.2022
Diffstat (limited to 'dev-python/oslo-concurrency')
-rw-r--r--dev-python/oslo-concurrency/Manifest1
-rw-r--r--dev-python/oslo-concurrency/oslo-concurrency-4.5.0-r1.ebuild50
2 files changed, 51 insertions, 0 deletions
diff --git a/dev-python/oslo-concurrency/Manifest b/dev-python/oslo-concurrency/Manifest
index 135161f5f9cd..325ed1a185d0 100644
--- a/dev-python/oslo-concurrency/Manifest
+++ b/dev-python/oslo-concurrency/Manifest
@@ -1,3 +1,4 @@
DIST oslo.concurrency-4.5.0.tar.gz 58979 BLAKE2B 9e2eb4a233985a33994aeaf335c195c980e1e9dd8b48a7c4e53ae502599f12c0dc65466ee45569a97b72f1face0e80ce166922ca3e42f6ad28fd5b27bdf884a3 SHA512 13a2f4d39d3241370374e6fe4ea6047dfc4d20da6116aaebd27f085fdbce089d58b0ebab4f1224234c88237cdefafc2f96229e6527bf5cda13ef1e471e25a50c
+EBUILD oslo-concurrency-4.5.0-r1.ebuild 1291 BLAKE2B 744b645eb2734c1bd1add2c93eae991518123f5a0999fbdcfc4d02b5dd26b34c671574dbf34a503c16ea2b9f434c1e576bf6ffe2acaa70e68d4c7bdc8b0d2228 SHA512 8375fdd3152fec41007b67dc5a0cb37adbe97c6cbbcc1b331d3d871f7eb1726e11cc3ab219b999a09eb852f22508319d401532b024c352dfc1fe31d9272835cd
EBUILD oslo-concurrency-4.5.0.ebuild 946 BLAKE2B fba90551b9b739889b64a3fe6d0eab520790aa40dc178d86fc02b1674d9924fcf490e0b865ed4a4aa59b4e99e7916b1688c43347255968f54fe7d0bd7ff89f85 SHA512 87225b52d725468e6daf317069398a08cd5c0897e62bcfe8c2eea2d55276a41eae3226de5c137e9b829e2ab5227ea410ff66122d0f06bc63cfa24a9808519d88
MISC metadata.xml 540 BLAKE2B 3cf35ead27deb8915aafded620fabef948d56e3feff9a6936bf8b80cf4ca3a84a000a0f56c2fee944dbd5c0ad7fb5211656ae861c64257d2ef83629e914521ad SHA512 a10fd1f009c73620ae68719bda0304ee3d8b64c0edb05d6bc818d14475499a1a78c613815b9fd29991c9b90b830e099139f263861e10b696432651da65a7d637
diff --git a/dev-python/oslo-concurrency/oslo-concurrency-4.5.0-r1.ebuild b/dev-python/oslo-concurrency/oslo-concurrency-4.5.0-r1.ebuild
new file mode 100644
index 000000000000..0a3d0cbb71c0
--- /dev/null
+++ b/dev-python/oslo-concurrency/oslo-concurrency-4.5.0-r1.ebuild
@@ -0,0 +1,50 @@
+# Copyright 2021-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="Oslo Concurrency library"
+HOMEPAGE="https://pypi.org/project/oslo.concurrency/ https://github.com/openstack/oslo.concurrency"
+SRC_URI="mirror://pypi/o/${PN/-/.}/${PN/-/.}-${PV}.tar.gz"
+S="${WORKDIR}/${PN/-/.}-${PV}"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+
+RDEPEND="
+ >=dev-python/pbr-2.1.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-config-5.2.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-i18n-3.15.3[${PYTHON_USEDEP}]
+ >=dev-python/oslo-utils-3.33.0[${PYTHON_USEDEP}]
+ >=dev-python/fasteners-0.7.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ >=dev-python/pbr-2.1.0[${PYTHON_USEDEP}]
+ test? (
+ >=dev-python/oslotest-3.2.0[${PYTHON_USEDEP}]
+ >=dev-python/fixtures-3.0.0[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ >=dev-python/eventlet-0.19.0[${PYTHON_USEDEP}]
+ ' python3_{8..9})
+ )
+"
+
+distutils_enable_tests unittest
+
+python_compile() {
+ distutils-r1_python_compile
+ if ! has "${EPYTHON}" python3.{8..9}; then
+ find "${BUILD_DIR}"/install -name '*eventlet*.py' -delete || die
+ fi
+}
+
+python_test() {
+ cd "${BUILD_DIR}/install$(python_get_sitedir)" || die
+ eunittest
+}